aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2023-01-18 17:31:29 +0000
committerDima Panov <fluffy@FreeBSD.org>2023-01-18 17:31:29 +0000
commit1500b166eb6a59a7b2c9b27f8cf59c5b22d45a5c (patch)
treeaf6ba163c04d30628b79ffee03fd6a3285e27412
parente3477f2bb798885731df8eccf2288a7d8b13c7c0 (diff)
downloadports-1500b166eb6a59a7b2c9b27f8cf59c5b22d45a5c.tar.gz
ports-1500b166eb6a59a7b2c9b27f8cf59c5b22d45a5c.zip
games/wesnoth: update to 1.16.7 release (+)
-rw-r--r--games/wesnoth/Makefile3
-rw-r--r--games/wesnoth/distinfo6
-rw-r--r--games/wesnoth/files/patch-src_gettext.cpp49
3 files changed, 4 insertions, 54 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 7ac3ac9bfe83..b384793af4f7 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -1,6 +1,5 @@
PORTNAME= wesnoth
-PORTVERSION= 1.16.6
-PORTREVISION= 2
+PORTVERSION= 1.16.7
PORTEPOCH= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION} \
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index 3a9ce67a5365..b5800569035e 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1662731937
-SHA256 (wesnoth-1.16.6.tar.bz2) = 1fce2c625da53adee4ec62b4e0a810bae1a01c9b893027b10beafaa3a0648501
-SIZE (wesnoth-1.16.6.tar.bz2) = 475677376
+TIMESTAMP = 1674061945
+SHA256 (wesnoth-1.16.7.tar.bz2) = f88b134b2c6ade58f4e5fb4fe459f33870fe336c17edc5772baccb8d60d0ec73
+SIZE (wesnoth-1.16.7.tar.bz2) = 476140035
diff --git a/games/wesnoth/files/patch-src_gettext.cpp b/games/wesnoth/files/patch-src_gettext.cpp
deleted file mode 100644
index 1a53f897bad8..000000000000
--- a/games/wesnoth/files/patch-src_gettext.cpp
+++ /dev/null
@@ -1,49 +0,0 @@
-https://bugs.gentoo.org/886575
-https://github.com/wesnoth/wesnoth/issues/7215
-
-From d71e90ee50a89673cf9b6748bcb2975071d15445 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
- <congdanhqx@gmail.com>
-Date: Mon, 28 Nov 2022 23:21:38 +0700
-Subject: [PATCH] gettext: fix build with Boost.Locale 1.81
-
-See https://github.com/boostorg/locale/pull/128/
-
-(cherry picked from commit fd96415bdf0a2e3a05e1a587a1c3853847e2c2bc)
---- src/gettext.cpp
-+++ src/gettext.cpp
-@@ -26,6 +26,7 @@
- #include <mutex>
- #include <boost/locale.hpp>
- #include <set>
-+#include <type_traits>
-
- #if defined(__GNUC__)
- #pragma GCC diagnostic push
-@@ -224,8 +225,13 @@ namespace
- }
-
- generator_.use_ansi_encoding(false);
-+#if BOOST_VERSION < 108100
- generator_.categories(bl::message_facet | bl::information_facet | bl::collation_facet | bl::formatting_facet | bl::convert_facet);
- generator_.characters(bl::char_facet);
-+#else
-+ generator_.categories(bl::category_t::message | bl::category_t::information | bl::category_t::collation | bl::category_t::formatting | bl::category_t::convert);
-+ generator_.characters(bl::char_facet_t::char_f);
-+#endif
- // We cannot have current_locale_ be a non boost-generated locale since it might not supply
- // the bl::info facet. As soon as we add message paths, update_locale_internal might fail,
- // for example because of invalid .mo files. So make sure we call it at least once before adding paths/domains
-@@ -368,7 +374,12 @@ namespace
- if(std::has_facet<bl::collator<char>>(current_locale_)) {
- res << "has bl::collator<char> facet, ";
- }
-+#if BOOST_VERSION < 108100
- res << "generator categories='" << generator_.categories() << "'";
-+#else
-+ res << "generator categories='" <<
-+ static_cast<std::underlying_type<bl::category_t>::type>(generator_.categories()) << "'";
-+#endif
- return res.str();
- }
-