aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2021-10-19 14:52:39 +0000
committerLarry Rosenman <ler@FreeBSD.org>2021-10-19 14:52:39 +0000
commit156e0517c0f2ead88a55c5a90a63f3d1cbfbcdc6 (patch)
tree9f6f08d639a05b5e4d9d2399c5cfbcf7bd434ab9
parentadc7097c90ee5e8db0d063200faa689034ac91f0 (diff)
downloadports-156e0517c0f2ead88a55c5a90a63f3d1cbfbcdc6.tar.gz
ports-156e0517c0f2ead88a55c5a90a63f3d1cbfbcdc6.zip
devel/cdecl: upgrade 11.2->11.4
ChangeLog: 11.3: Added explicit-ecsu option Both an --explicit-csu/-S command-line and explicit-ecsu set option have been added that set which type keywords enum, class, struct, or union, are included explicitly in C++ declarations. The default is struct and union only, so: c++decl> declare ps as pointer to struct S struct S *ps; c++decl> declare pt as pointer to class T T *pt; Fixed nested array declaration Explaining a declaration like: explain int (a)[4] is now fixed. 11.4: _Atomic(T) in C++23 Now supporting the _Atomic(T) macro in C++23. Fixed pointer to a typedef of void Declarations like: typedef void V explain V *p are now fixed. Allow declarations using unknown scoped type names Previously, cdecl complained about things like: cdecl> define S as struct S cdecl> explain S::T x ^ 19: error: "T": unknown name Now, it just assumes the T is a type: declare x as T of structure S cvr-qualified _Atomic const-volatile-restrict-qualified _Atomic types are now correctly forbidden.
-rw-r--r--devel/cdecl/Makefile2
-rw-r--r--devel/cdecl/distinfo6
2 files changed, 4 insertions, 4 deletions
diff --git a/devel/cdecl/Makefile b/devel/cdecl/Makefile
index c16d4ffa6f2b..47a3800c766c 100644
--- a/devel/cdecl/Makefile
+++ b/devel/cdecl/Makefile
@@ -1,7 +1,7 @@
# Created by: David O'Brien (obrien@NUXI.com)
PORTNAME= cdecl
-PORTVERSION= 11.2
+PORTVERSION= 11.4
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= devel
diff --git a/devel/cdecl/distinfo b/devel/cdecl/distinfo
index 0e77a43dc1f6..7cb713ebf09c 100644
--- a/devel/cdecl/distinfo
+++ b/devel/cdecl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1633302794
-SHA256 (paul-j-lucas-cdecl-cdecl-11.2_GH0.tar.gz) = ef6bf1cb71ed6fad0f5c78c10272e9c03abd98c48dc658bdfb2e8aaa33118d90
-SIZE (paul-j-lucas-cdecl-cdecl-11.2_GH0.tar.gz) = 731926
+TIMESTAMP = 1634654653
+SHA256 (paul-j-lucas-cdecl-cdecl-11.4_GH0.tar.gz) = 44e7272f9cbd68cbfa2e47df459879d7b805f11875b2ba90bf95e4e59f081701
+SIZE (paul-j-lucas-cdecl-cdecl-11.4_GH0.tar.gz) = 737797