aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-06-22 19:25:44 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-06-22 19:25:44 +0000
commit159c6c7314095a10121155f501c093ad6f18c3c4 (patch)
tree79d0b86e19f56fc512738da9f2d4db2fdd30c6f8
parentda3162c7c9f01912ba1940e188b253f2b5c7ba77 (diff)
downloadports-159c6c7314095a10121155f501c093ad6f18c3c4.tar.gz
ports-159c6c7314095a10121155f501c093ad6f18c3c4.zip
security/openvpn: fix missing include for PATH_MAX
While here, add a warning banner about libressl support status, and clean up a leftover INSTALL_DATA workaround no longer needed. Patch suggested and Reported by: Franco Fichtner <franco@opnsense.org> PR: 256744
-rw-r--r--security/openvpn/Makefile10
-rw-r--r--security/openvpn/files/patch-src_plugins_auth-pam_auth-pam.c10
2 files changed, 17 insertions, 3 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index f71a1a813a10..d9b89a1c8554 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -15,7 +15,6 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYRIGHT.GPL
USES= cpe libtool localbase:ldflags pkgconfig shebangfix tar:xz
-IGNORE_SSL= libressl libressl-devel
USE_RC_SUBR= openvpn
SHEBANG_FILES= sample/sample-scripts/verify-cn \
@@ -112,6 +111,13 @@ pre-configure:
@${ECHO} " EXAMPLE: make LOG_OPENVPN=LOG_LOCAL6"
@${ECHO} ""
.endif
+.if !empty(SSL_DEFAULT:Mlibressl*)
+ @${ECHO} "### --------------------------------------------------------- ###"
+ @${ECHO} "### NOTE that libressl is not primarily supported by OpenVPN ###"
+ @${ECHO} "### Do not report bugs without fixes/patches unless the issue ###"
+ @${ECHO} "### can be reproduced with a released OpenSSL version. ###"
+ @${ECHO} "### --------------------------------------------------------- ###"
+.endif
post-configure:
${REINPLACE_CMD} '/^CFLAGS =/s/$$/ -fPIC/' \
@@ -133,8 +139,6 @@ post-install:
@${REINPLACE_CMD} 's|resolvconf -p -a|resolvconf -a|' ${STAGEDIR}${PREFIX}/libexec/openvpn-client.up
${INSTALL_SCRIPT} ${WRKDIR}/openvpn-client ${STAGEDIR}${PREFIX}/sbin/openvpn-client
${MKDIR} ${STAGEDIR}${PREFIX}/include
- @: # workaround for 2.5.0 only XXX FIXME remove after 2.5.0
- ${INSTALL_MAN} ${WRKSRC}/doc/openvpn.8 ${STAGEDIR}${MANPREFIX}/man/man8
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
diff --git a/security/openvpn/files/patch-src_plugins_auth-pam_auth-pam.c b/security/openvpn/files/patch-src_plugins_auth-pam_auth-pam.c
new file mode 100644
index 000000000000..633bc0f0204d
--- /dev/null
+++ b/security/openvpn/files/patch-src_plugins_auth-pam_auth-pam.c
@@ -0,0 +1,10 @@
+--- src/plugins/auth-pam/auth-pam.c.orig 2021-06-21 04:44:39 UTC
++++ src/plugins/auth-pam/auth-pam.c
+@@ -39,6 +39,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <limits.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <sys/types.h>