aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-23 12:38:43 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2021-10-25 14:04:50 +0000
commit15c86847a0af526ce2f95acbb1c6d2e9c4ec3872 (patch)
tree7781157ae9eeb3726839c9f7ad6527bbc393784a
parent34d92a6928553c6b2be6e8b34450f62e36d1402e (diff)
downloadports-15c86847a0af526ce2f95acbb1c6d2e9c4ec3872.tar.gz
ports-15c86847a0af526ce2f95acbb1c6d2e9c4ec3872.zip
devel/aws-c-compression: Add new port
This is a cross-platform C99 implementation of compression algorithms such as gzip, and huffman encoding/decoding.
-rw-r--r--devel/aws-c-compression/Makefile25
-rw-r--r--devel/aws-c-compression/distinfo3
-rw-r--r--devel/aws-c-compression/pkg-descr4
-rw-r--r--devel/aws-c-compression/pkg-plist8
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/aws-c-compression/Makefile b/devel/aws-c-compression/Makefile
new file mode 100644
index 000000000000..f5d93e3cbc9d
--- /dev/null
+++ b/devel/aws-c-compression/Makefile
@@ -0,0 +1,25 @@
+# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
+
+PORTNAME= aws-c-compression
+PORTVERSION= 0.2.14
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= danilo@FreeBSD.org
+COMMENT= C99 implementation of compression algorithms
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libaws-c-common.so:devel/aws-c-common
+
+USES= cmake compiler:c11
+
+USE_GITHUB= yes
+GH_ACCOUNT= awslabs
+
+CMAKE_ARGS+= -DBUILD_TESTING=OFF -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_PREFIX_PATH=${LOCALBASE}
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/aws-c-compression/distinfo b/devel/aws-c-compression/distinfo
new file mode 100644
index 000000000000..77fd7dcdf0ad
--- /dev/null
+++ b/devel/aws-c-compression/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1634977434
+SHA256 (awslabs-aws-c-compression-v0.2.14_GH0.tar.gz) = 8737863ced57d92f5a0bdde554bf0fe70eaa76aae118fec09a6c361dfc55d0d5
+SIZE (awslabs-aws-c-compression-v0.2.14_GH0.tar.gz) = 32960
diff --git a/devel/aws-c-compression/pkg-descr b/devel/aws-c-compression/pkg-descr
new file mode 100644
index 000000000000..31fb873a4a44
--- /dev/null
+++ b/devel/aws-c-compression/pkg-descr
@@ -0,0 +1,4 @@
+This is a cross-platform C99 implementation of compression
+algorithms such as gzip, and huffman encoding/decoding.
+
+WWW: https://github.com/awslabs/aws-c-compression
diff --git a/devel/aws-c-compression/pkg-plist b/devel/aws-c-compression/pkg-plist
new file mode 100644
index 000000000000..e1dca80147f2
--- /dev/null
+++ b/devel/aws-c-compression/pkg-plist
@@ -0,0 +1,8 @@
+include/aws/compression/compression.h
+include/aws/compression/exports.h
+include/aws/compression/huffman.h
+lib/aws-c-compression/cmake/aws-c-compression-config.cmake
+lib/aws-c-compression/cmake/shared/aws-c-compression-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/aws-c-compression/cmake/shared/aws-c-compression-targets.cmake
+lib/libaws-c-compression.so
+lib/libaws-c-compression.so.1.0.0