aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Duchateau <duchateau.oliver@gmail.com>2022-11-06 17:33:49 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-11-06 17:33:49 +0000
commit15d8808cc1f3b41d541e86e9071028024df5125c (patch)
treea23d5adc847fdc0fa8fd535b1352e72c944d0ebd
parent5806297032ba25442bb20d1fc6cdb9d6c296b7f1 (diff)
downloadports-15d8808cc1f3b41d541e86e9071028024df5125c.tar.gz
ports-15d8808cc1f3b41d541e86e9071028024df5125c.zip
x11/elementary-terminal: Update to 6.1.1
PR: 267402 MFH: 2022Q4
-rw-r--r--x11/elementary-terminal/Makefile2
-rw-r--r--x11/elementary-terminal/distinfo6
-rw-r--r--x11/elementary-terminal/files/patch-src_Widgets_TerminalWidget.vala15
3 files changed, 12 insertions, 11 deletions
diff --git a/x11/elementary-terminal/Makefile b/x11/elementary-terminal/Makefile
index 3b0ae5dee5c1..e3e1e2933753 100644
--- a/x11/elementary-terminal/Makefile
+++ b/x11/elementary-terminal/Makefile
@@ -1,5 +1,5 @@
PORTNAME= terminal
-DISTVERSION= 6.1.0
+DISTVERSION= 6.1.1
CATEGORIES= x11
PKGNAMEPREFIX= elementary-
diff --git a/x11/elementary-terminal/distinfo b/x11/elementary-terminal/distinfo
index e453005e572b..9c40e4fd6fe9 100644
--- a/x11/elementary-terminal/distinfo
+++ b/x11/elementary-terminal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1660337780
-SHA256 (elementary-terminal-6.1.0_GH0.tar.gz) = ed930dded4f51bc59ebc6213bc21d0a5eca156ddc58c919d33735921a950bbb2
-SIZE (elementary-terminal-6.1.0_GH0.tar.gz) = 1015594
+TIMESTAMP = 1666967246
+SHA256 (elementary-terminal-6.1.1_GH0.tar.gz) = 22d86fd35735195a5b93b74697e11569339447887ae121c654a86f486a8ed48b
+SIZE (elementary-terminal-6.1.1_GH0.tar.gz) = 1037361
diff --git a/x11/elementary-terminal/files/patch-src_Widgets_TerminalWidget.vala b/x11/elementary-terminal/files/patch-src_Widgets_TerminalWidget.vala
index ab10a93473b2..74442c7f4f2b 100644
--- a/x11/elementary-terminal/files/patch-src_Widgets_TerminalWidget.vala
+++ b/x11/elementary-terminal/files/patch-src_Widgets_TerminalWidget.vala
@@ -1,4 +1,4 @@
---- src/Widgets/TerminalWidget.vala.orig 2021-12-13 18:31:36 UTC
+--- src/Widgets/TerminalWidget.vala.orig 2022-10-27 16:47:44 UTC
+++ src/Widgets/TerminalWidget.vala
@@ -68,13 +68,6 @@ namespace Terminal {
}
@@ -9,15 +9,16 @@
- "/io/elementary/terminal " +
- "io.elementary.terminal.ProcessFinished " +
- "string:$PANTHEON_TERMINAL_ID " +
-- "string:\"$(history 1 | cut -c 8-)\" " +
+- "string:\"$(fc -nl -1 | cut -c 3-)\" " +
- "int32:\$__bp_last_ret_value >/dev/null 2>&1";
/* Following strings are used to build RegEx for matching URIs */
const string USERCHARS = "-[:alnum:]";
-@@ -364,14 +357,7 @@ namespace Terminal {
+@@ -351,15 +344,7 @@ namespace Terminal {
+ shell = Vte.get_user_shell ();
envv = {
- // Export ID so we can identify the terminal for which the process completion is reported
+- // Export ID so we can identify the terminal for which the process completion is reported
- "PANTHEON_TERMINAL_ID=" + terminal_id,
-
- // Export callback command a BASH-specific variable, see "man bash" for details
@@ -30,7 +31,7 @@
};
/* We need opening uri to be available asap when constructing window with working directory
-@@ -454,12 +440,49 @@ namespace Terminal {
+@@ -436,12 +421,49 @@ namespace Terminal {
return this.match_check_event (event, null);
}
@@ -47,14 +48,14 @@
+
public string get_shell_location () {
+ string[] spawn_env = GLib.Environ.get ();
-+ string[] procstat_cmd = {"/usr/bin/pwdx", "--libxo:T",};
++ string[] procstat_cmd = { "/usr/bin/pwdx", "--libxo:T", };
+ string standard_output = null;
+ bool res;
+ string cwd = null;
+
int pid = (!) (this.child_pid);
-+ /* Update procstat(1) argument */
++ // Update procstat(1) argument
+ procstat_cmd += pid.to_string ();
+
try {