aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-08-02 04:30:12 +0000
committerMikael Urankar <mikael@FreeBSD.org>2022-09-09 06:50:12 +0000
commit15ea9b69ec020042ca2e7a10be4d6d67dc9223d6 (patch)
treef97f26345f4602965b919c14db78a2a76fff04b4
parent06abef6a63ed801093e025d6daddedb9f725cef1 (diff)
downloadports-15ea9b69ec020042ca2e7a10be4d6d67dc9223d6.tar.gz
ports-15ea9b69ec020042ca2e7a10be4d6d67dc9223d6.zip
devel/directfb: Use GNU as to assemble files on armv6/armv7
Clang's integrated assembler can't handle the old split syntax used in this project's assembly files. Assembly with GNU as instead. PR: 265566
-rw-r--r--devel/directfb/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index a3c58bdd23fe..8400f03758cb 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -22,7 +22,7 @@ OPTIONS_SUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= cpe gmake jpeg libtool ncurses pathfix perl5 pkgconfig
+USES= compiler cpe gmake jpeg libtool ncurses pathfix perl5 pkgconfig
USE_LDCONFIG= yes
USE_PERL5= build
PORTDOCS= *
@@ -57,6 +57,14 @@ SDL_CONFIGURE_ENABLE= sdl
UNIQUE_CONFIGURE_ENABLE= unique
TEST_CONFIGURE_WITH= tests
+.include <bsd.port.pre.mk>
+
+# assembly files use old split syntax which clang doesn't like
+.if ${ARCH:Marmv?} && ${COMPILER_TYPE} == "clang"
+BUILD_DEPENDS+= as:devel/binutils
+CFLAGS+= -fno-integrated-as
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
'/need_libc_r=yes/d ; \
@@ -74,4 +82,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/html
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>