aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 17:18:44 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 18:44:48 +0000
commit166e14390d2de465e2ebf5e2db0d4b316b873ee3 (patch)
tree6ad60da1e465521c09768b7bc76812724b082ed2
parentd49d943d813bbbddad19243b96a2bfcf6882d969 (diff)
downloadports-166e14390d2de465e2ebf5e2db0d4b316b873ee3.tar.gz
ports-166e14390d2de465e2ebf5e2db0d4b316b873ee3.zip
www/py-quilt3: Change RUN_DEPENDS from py-jsonschema3 to py-jsonschema
- Bump PORTREVISION for dependency change Obtained from: https://github.com/quiltdata/quilt/commit/a7dedefc1ba88bd0db970bbfc530d77f7044da8e
-rw-r--r--www/py-quilt3/Makefile4
-rw-r--r--www/py-quilt3/files/patch-setup.py8
2 files changed, 7 insertions, 5 deletions
diff --git a/www/py-quilt3/Makefile b/www/py-quilt3/Makefile
index 462f48be753a..6720ec318b14 100644
--- a/www/py-quilt3/Makefile
+++ b/www/py-quilt3/Makefile
@@ -2,7 +2,7 @@
PORTNAME= quilt3
PORTVERSION= 3.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.4.0:devel/py-appdirs@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}Flask-Cors>=0:www/py-flask-cors@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flask-json>=0:www/py-flask-json@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jsonlines>=1.2.0:devel/py-jsonlines@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jsonschema3>=3.0<4:devel/py-jsonschema3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0<5:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=5.1:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.12.4:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-futures>=1.0.0:www/py-requests-futures@${PY_FLAVOR} \
diff --git a/www/py-quilt3/files/patch-setup.py b/www/py-quilt3/files/patch-setup.py
index fad9e9091aad..8e83be53a15a 100644
--- a/www/py-quilt3/files/patch-setup.py
+++ b/www/py-quilt3/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2021-09-07 10:31:49 UTC
+--- setup.py.orig 2021-10-15 18:41:22 UTC
+++ setup.py
-@@ -64,12 +64,12 @@ setup(
+@@ -64,13 +64,13 @@ setup(
'flask',
'flask_cors',
'flask_json',
@@ -11,7 +11,9 @@
'tenacity>=5.1.1',
'tqdm>=4.32',
- 'requests_futures==1.0.0',
+- 'jsonschema==3.*',
+ 'requests_futures>=1.0.0',
- 'jsonschema==3.*',
++ 'jsonschema>=3,<5',
],
extras_require={
+ 'pyarrow': [