aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZsolt Udvari <uzsolt@FreeBSD.org>2024-11-29 07:35:59 +0000
committerZsolt Udvari <uzsolt@FreeBSD.org>2024-11-29 07:37:10 +0000
commit16d9343e332cff43b2f42fe611c705901037bac6 (patch)
treebc8698ddedf04ac5d2f1c45aa0bc600cea0db883
parentb611b1c91171d73976fd259955b5d70e8fdb508e (diff)
downloadports-16d9343e332cff43b2f42fe611c705901037bac6.tar.gz
ports-16d9343e332cff43b2f42fe611c705901037bac6.zip
graphics/R-cran-qpdf: new port, transformations of PDF files
Content-preserving transformations of PDF files such as split, combine, and compress. This package interfaces directly to the 'qpdf' C++ library <https://qpdf.sourceforge.io/> and does not require any command line utilities.
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/R-cran-qpdf/Makefile24
-rw-r--r--graphics/R-cran-qpdf/distinfo3
-rw-r--r--graphics/R-cran-qpdf/pkg-descr7
4 files changed, 35 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 408f7e7ab83a..4ed74e7d4530 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -29,6 +29,7 @@
SUBDIR += R-cran-pixmap
SUBDIR += R-cran-png
SUBDIR += R-cran-qcc
+ SUBDIR += R-cran-qpdf
SUBDIR += R-cran-ragg
SUBDIR += R-cran-s2
SUBDIR += R-cran-scales
diff --git a/graphics/R-cran-qpdf/Makefile b/graphics/R-cran-qpdf/Makefile
new file mode 100644
index 000000000000..d9a87afaeb5e
--- /dev/null
+++ b/graphics/R-cran-qpdf/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= qpdf
+DISTVERSION= 1.3.4
+CATEGORIES= graphics
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= uzsolt@FreeBSD.org
+COMMENT= Content-preserving transformations of PDF files
+WWW= https://cran.r-project.org/package=qpdf
+
+LICENSE= APACHE20
+
+CRAN_DEPENDS= R-cran-askpass>0:security/R-cran-askpass \
+ R-cran-curl>0:ftp/R-cran-curl \
+ R-cran-Rcpp>0:devel/R-cran-Rcpp
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+LIB_DEPENDS= libqpdf.so:print/qpdf
+RUN_DEPENDS= ${CRAN_DEPENDS}
+TEST_DEPENDS= R-cran-testthat>0:devel/R-cran-testthat
+
+USES= compiler:c++17-lang cran:auto-plist,compiles jpeg pkgconfig
+
+MAKE_ENV+= EXTERNAL_QPDF=yes
+
+.include <bsd.port.mk>
diff --git a/graphics/R-cran-qpdf/distinfo b/graphics/R-cran-qpdf/distinfo
new file mode 100644
index 000000000000..290e71671703
--- /dev/null
+++ b/graphics/R-cran-qpdf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1732858722
+SHA256 (qpdf_1.3.4.tar.gz) = b93aaf0733725781a41c4186db0133c918b55a42d669c36ef009a06aff79cae4
+SIZE (qpdf_1.3.4.tar.gz) = 322563
diff --git a/graphics/R-cran-qpdf/pkg-descr b/graphics/R-cran-qpdf/pkg-descr
new file mode 100644
index 000000000000..7771f1836adb
--- /dev/null
+++ b/graphics/R-cran-qpdf/pkg-descr
@@ -0,0 +1,7 @@
+Content-preserving transformations of PDF files such as split, combine, and
+compress.
+This package interfaces directly to the 'qpdf' C++ library
+<https://qpdf.sourceforge.io/> and does not require any command line
+utilities.
+Note that 'qpdf' does not read actual content from PDF files: to extract text
+and data you need the 'pdftools' package.