aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2022-08-04 21:46:32 +0000
committerDiane Bruce <db@FreeBSD.org>2022-08-04 21:46:32 +0000
commit1731b077ffd7478f98d032ab3ed65167a102d276 (patch)
tree3e7720cc74c9c2914b1e208c2b914b5df314e6f9
parent31ce3b2afe866714696dae58b5bb6ba927193119 (diff)
downloadports-1731b077ffd7478f98d032ab3ed65167a102d276.tar.gz
ports-1731b077ffd7478f98d032ab3ed65167a102d276.zip
comms/freedv: Update to v1.7.0
Unbreaks port upstream notes: Bugfixes: Resolves issue with waterfall appearing garbled on some systems. (PR #205) Resolves issue with Restore Defaults restoring previous settings on exit. (PR #207) Resolves issue with some sound valid sound devices causing PortAudio errors during startup checks. (PR #192) Enhancements: Removes requirement to restart FreeDV after using Restore Defaults. (PR #207) Hides frequency display on main window unless PSK Reporter reporting is turned on. (PR #207) Scales per-mode squelch settings when in multi-RX mode to reduce unwanted noise. (PR #186) Single-thread mode is now the default when multi-RX is turned on. (PR #175) Makes multi-RX mode the default. (PR #175) Mic In/Speaker Out volume controls added to Filter window. (PR #208) Cleans up UI for filters and makes the dialog non-modal. (PR #208) Adds optional support for PulseAudio on Linux systems. (PR #194) Documentation: Resolves issue with PDF image placement. (PR #203) Build System: Uses more portable way of referring to Bash in build scripts. (PR #200) User manual now installed along with executable. (PR #187) macOS app bundle generated by CMake instead of manually. (PR #184) Fail as soon as a step in the build script fails. (PR #183) PR: ports/264769 Reported by: castilloeduardo@outlook.com.ar Tested by: castilloeduardo@outlook.com.ar
-rw-r--r--comms/freedv/Makefile19
-rw-r--r--comms/freedv/distinfo6
-rw-r--r--comms/freedv/files/patch-CMakeLists.txt18
-rw-r--r--comms/freedv/files/patch-src__fdmdv2_main.cpp15
-rw-r--r--comms/freedv/pkg-descr2
5 files changed, 15 insertions, 45 deletions
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
index e6e5a4ea808b..2a66cf1203e9 100644
--- a/comms/freedv/Makefile
+++ b/comms/freedv/Makefile
@@ -1,27 +1,30 @@
PORTNAME= freedv
-DISTVERSION= 1.3.1
-PORTREVISION= 6
+DISTVERSIONPREFIX=v
+DISTVERSION= 1.7.0
CATEGORIES= comms hamradio
-MASTER_SITES= https://hobbes1069.fedorapeople.org/freetel/freedv/
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Narrow band digital voice
LICENSE= LGPL21
-BROKEN= Needs update due to Hamlib changes
-
LIB_DEPENDS= libcodec2.so:audio/codec2 \
libportaudio.so:audio/portaudio \
+ libgsm.so:audio/gsm \
libhamlib.so:comms/hamlib \
libsamplerate.so:audio/libsamplerate \
libsox.so:audio/sox \
libsndfile.so:audio/libsndfile \
libspeex.so:audio/speex \
- libspeexdsp.so:audio/speexdsp
+ libspeexdsp.so:audio/speexdsp \
+ liblpcnetfreedv.so:audio/lpcnet
+
+USES= cmake compiler:c++11-lib tar:xz
+USE_WX= 3.0+
+USE_GITHUB= yes
+GH_ACCOUNT= drowe67
+GH_PROJECT= freedv-gui
-USES= cmake compiler:c++11-lib gnome tar:xz
-USE_WX= 3.0+
CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
-DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
-DUSE_STATIC_CODEC2=FALSE \
diff --git a/comms/freedv/distinfo b/comms/freedv/distinfo
index 0d01d70db8fa..6a86d71feac0 100644
--- a/comms/freedv/distinfo
+++ b/comms/freedv/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1535511699
-SHA256 (freedv-1.3.1.tar.xz) = 9365459d4c8d478d32d91629f6fdf0cb6bd27cbb71ddc5a09b37e10df03dff65
-SIZE (freedv-1.3.1.tar.xz) = 536864
+TIMESTAMP = 1655664601
+SHA256 (drowe67-freedv-gui-v1.7.0_GH0.tar.gz) = 20ead8b37b0d42710226d2902f7fc0898de631fb28353ab6b018556117121ca8
+SIZE (drowe67-freedv-gui-v1.7.0_GH0.tar.gz) = 9477053
diff --git a/comms/freedv/files/patch-CMakeLists.txt b/comms/freedv/files/patch-CMakeLists.txt
deleted file mode 100644
index 987e1f2f8b7b..000000000000
--- a/comms/freedv/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,18 +0,0 @@
---- CMakeLists.txt.orig 2017-07-19 13:22:47 UTC
-+++ CMakeLists.txt
-@@ -391,6 +391,7 @@ endif()
- #
- # Find libdl for dlopen/dlclose
- #
-+if(DUMMYFLAG)
- if(UNIX)
- message(STATUS "Looking for dl library.")
- find_library(DL_LIBRARY dl)
-@@ -405,6 +406,7 @@ On Linux systems try installing:
- )
- endif()
- endif(UNIX)
-+endif(DUMMYFLAG)
-
-
- #Freedv
diff --git a/comms/freedv/files/patch-src__fdmdv2_main.cpp b/comms/freedv/files/patch-src__fdmdv2_main.cpp
deleted file mode 100644
index 2b9cfbec7d95..000000000000
--- a/comms/freedv/files/patch-src__fdmdv2_main.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/fdmdv2_main.cpp.orig 2018-05-29 05:38:34 UTC
-+++ src/fdmdv2_main.cpp
-@@ -1198,10 +1198,12 @@ void MainFrame::OnTimer(wxTimerEvent &ev
- sprintf(ber, "BER: %4.3f", b); wxString ber_string(ber); m_textBER->SetLabel(ber_string);
- sprintf(resyncs, "Resyncs: %d", g_resyncs); wxString resyncs_string(resyncs); m_textResyncs->SetLabel(resyncs_string);
-
-+/*
- sprintf(freqoffset, "FrqOff: %3.1f", g_stats.foff);
- wxString freqoffset_string(freqoffset); m_textFreqOffset->SetLabel(freqoffset_string);
- sprintf(syncmetric, "Sync: %3.2f", g_stats.sync_metric);
- wxString syncmetric_string(syncmetric); m_textSyncMetric->SetLabel(syncmetric_string);
-+*/
-
- if (g_State) {
-
diff --git a/comms/freedv/pkg-descr b/comms/freedv/pkg-descr
index 329dfdac6b8b..6aedee24b59d 100644
--- a/comms/freedv/pkg-descr
+++ b/comms/freedv/pkg-descr
@@ -6,4 +6,4 @@ is received by an SSB radio, then demodulated and decoded by FreeDV. FreeDV
700(B) rivals SSB in it's low SNR performance. At high SNRs FreeDV 1600
sounds like FM, with no annoying analog HF radio noise.
-WWW: https://freedv.org/
+WWW: http://freedv.org/