aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2019-01-15 18:59:11 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2019-01-15 18:59:11 +0000
commit1763ef103341156c1658e83f0b8d4a48e12f1442 (patch)
treedf01c9a025c5fcfcac7686f915477781413655a1
parent1b54784efc6d03c7e0a3a89423179b8da68f0dc4 (diff)
downloadports-1763ef103341156c1658e83f0b8d4a48e12f1442.tar.gz
ports-1763ef103341156c1658e83f0b8d4a48e12f1442.zip
Update geoipupdate to 4.0.0
It is now written in go, for reasons I guess.
Notes
Notes: svn path=/head/; revision=490399
-rw-r--r--net/geoipupdate/Makefile44
-rw-r--r--net/geoipupdate/distinfo6
-rw-r--r--net/geoipupdate/pkg-plist8
3 files changed, 36 insertions, 22 deletions
diff --git a/net/geoipupdate/Makefile b/net/geoipupdate/Makefile
index 7bf0c63844ce..d7b6645aede3 100644
--- a/net/geoipupdate/Makefile
+++ b/net/geoipupdate/Makefile
@@ -2,26 +2,48 @@
# $FreeBSD$
PORTNAME= geoipupdate
-PORTVERSION= 3.1.1
+PORTVERSION= 4.0.0
+DISTVERSIONPREFIX= v
CATEGORIES= net geography
-MASTER_SITES= https://github.com/maxmind/geoipupdate/releases/download/v${PORTVERSION}/
MAINTAINER= adamw@FreeBSD.org
-COMMENT= Fetch the latest copies of the paid GeoIP2 databases
+COMMENT= Fetch the latest copies of the GeoIP2 databases
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE= APACHE20 MIT
+LICENSE_COMB= dual
+LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
-LIB_DEPENDS= libcurl.so:ftp/curl
+BUILD_DEPENDS= go:lang/go
+RUN_DEPENDS= ca_root_nss>=3:security/ca_root_nss
-USES= libtool localbase pathfix
-GNU_CONFIGURE= yes
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= maxmind
+
+MAKE_ENV+= GOPATH=${WRKSRC}
OPTIONS_DEFINE= DOCS
-post-install:
+PLIST_FILES= bin/geoipupdate \
+ '@sample etc/GeoIP.conf.sample' \
+ '@dir share/GeoIP'
+PORTDOCS= GeoIP.conf.md geoipupdate.md
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/Makefile
+
+do-build:
+ ${MV} ${WRKSRC}/vendor ${WRKSRC}/src
+ ${DO_MAKE_BUILD} -C ${WRKSRC}
+
+do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/GeoIP
- ${MV} ${STAGEDIR}${DOCSDIR}/GeoIP.conf.default \
- ${STAGEDIR}${PREFIX}/etc/GeoIP.conf.sample
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/geoipupdate ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/build/GeoIP.conf ${STAGEDIR}${PREFIX}/etc/GeoIP.conf.sample
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/build && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net/geoipupdate/distinfo b/net/geoipupdate/distinfo
index 87387312661e..45d937e128a9 100644
--- a/net/geoipupdate/distinfo
+++ b/net/geoipupdate/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536615979
-SHA256 (geoipupdate-3.1.1.tar.gz) = 3de22e3fe3282024288a00807bbea9a1ffa2d1e8fe9c611f4b14a5b4d8ebe08a
-SIZE (geoipupdate-3.1.1.tar.gz) = 366789
+TIMESTAMP = 1547578530
+SHA256 (maxmind-geoipupdate-v4.0.0_GH0.tar.gz) = 89e86d6e54d26d4482f4b5f1c75409e23b4f202ad1f4425e6f97341ea7731e61
+SIZE (maxmind-geoipupdate-v4.0.0_GH0.tar.gz) = 105955
diff --git a/net/geoipupdate/pkg-plist b/net/geoipupdate/pkg-plist
deleted file mode 100644
index bf33fccf7e23..000000000000
--- a/net/geoipupdate/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/geoipupdate
-@sample etc/GeoIP.conf.sample
-man/man1/geoipupdate.1.gz
-man/man5/GeoIP.conf.5.gz
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.md
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTDOCS%%%%DOCSDIR%%/README.md
-@dir share/GeoIP