aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-10-30 21:34:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-10-31 00:09:30 +0000
commit176fe177754bf8e71a7546dec46ec00ef25231fc (patch)
tree83525fa9c97dab27fc6dbb924ae7b535f47fce86
parent97338d7a36953cd094bbc58eff0e4e1ede6073d0 (diff)
downloadports-176fe177754bf8e71a7546dec46ec00ef25231fc.tar.gz
ports-176fe177754bf8e71a7546dec46ec00ef25231fc.zip
devel/git-workspace: Fix build on i386
Reported by: fallout
-rw-r--r--devel/git-workspace/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/git-workspace/Makefile b/devel/git-workspace/Makefile
index 0d0672ed6f94..7af50a17764a 100644
--- a/devel/git-workspace/Makefile
+++ b/devel/git-workspace/Makefile
@@ -17,6 +17,8 @@ USES= cargo localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= orf
+RUSTFLAGS= ${ARCH:S/i386/YES/:C/^[a-z].*//:S/YES/-C target-feature=+sse,+sse2/} # add sse sse2 target-features only on i386
+
CARGO_CRATES= adler-1.0.2 \
aho-corasick-1.1.3 \
alloc-no-stdlib-2.0.4 \