aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2022-04-24 20:47:54 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2022-05-12 14:20:05 +0000
commit17c5a7b05cf58a37530a8fa623b271a68a6cbc49 (patch)
treef51d7e50c545e8e6196a9d8ef9d5bca5743c73fc
parent53c59951224eece2f7cee46b36aee912120aa4d3 (diff)
downloadports-17c5a7b05cf58a37530a8fa623b271a68a6cbc49.tar.gz
ports-17c5a7b05cf58a37530a8fa623b271a68a6cbc49.zip
security/rubygem-haiti-hash: Add new port
Haiti is a CLI tool (and library) to identify hash types (hash type identifier). Features: - 442+ hash types detected - Modern algorithms supported (SHA3, Keccak, Blake2, etc.) - Hashcat and John the Ripper references - CLI tool and library - Hackable WWW: https://noraj.github.io/haiti/ Reviewed by: danfe, ruby (sunpoet) Approved by: gerald (mentor) Differential Revision: https://reviews.freebsd.org/D35032
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-haiti-hash/Makefile23
-rw-r--r--security/rubygem-haiti-hash/distinfo3
-rw-r--r--security/rubygem-haiti-hash/pkg-descr11
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 22eee1bdf706..0bbae56783c1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1046,6 +1046,7 @@
SUBDIR += rubygem-gpgme
SUBDIR += rubygem-gpgr
SUBDIR += rubygem-gssapi
+ SUBDIR += rubygem-haiti-hash
SUBDIR += rubygem-hkdf
SUBDIR += rubygem-hkdf0
SUBDIR += rubygem-hrr_rb_ssh
diff --git a/security/rubygem-haiti-hash/Makefile b/security/rubygem-haiti-hash/Makefile
new file mode 100644
index 000000000000..050cdc3c8d04
--- /dev/null
+++ b/security/rubygem-haiti-hash/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= haiti-hash
+DISTVERSION= 1.3.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= salvadore@FreeBSD.org
+COMMENT= Hash type identifier (CLI tool and library)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-docopt>=0.6<1:devel/rubygem-docopt \
+ rubygem-paint>=2.2<3:devel/rubygem-paint
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PLIST_FILES= bin/haiti \
+ bin/haiti_console
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-haiti-hash/distinfo b/security/rubygem-haiti-hash/distinfo
new file mode 100644
index 000000000000..a827ed0eced6
--- /dev/null
+++ b/security/rubygem-haiti-hash/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1650639835
+SHA256 (rubygem/haiti-hash-1.3.0.gem) = d2a2808cc1626bc5bb24c34a211645c2b3749af6f7d595a9a2d65d1be0d72a9f
+SIZE (rubygem/haiti-hash-1.3.0.gem) = 35840
diff --git a/security/rubygem-haiti-hash/pkg-descr b/security/rubygem-haiti-hash/pkg-descr
new file mode 100644
index 000000000000..13d98efc87a3
--- /dev/null
+++ b/security/rubygem-haiti-hash/pkg-descr
@@ -0,0 +1,11 @@
+Haiti is a CLI tool (and library) to identify hash types (hash type
+identifier).
+
+Features:
+- 442+ hash types detected
+- Modern algorithms supported (SHA3, Keccak, Blake2, etc.)
+- Hashcat and John the Ripper references
+- CLI tool and library
+- Hackable
+
+WWW: https://noraj.github.io/haiti/