aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Hein <jcfyecrayz@liamekaens.com>2023-07-18 15:14:05 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2023-07-18 15:15:45 +0000
commit184c1d6d8bea06f2942c63ace2df4449626dc419 (patch)
treec268d0a528e6059dbee42eae81c7b9d9f71da3b1
parent7187c760db69985124457decf7aa7997fa141fc0 (diff)
downloadports-184c1d6d8bea06f2942c63ace2df4449626dc419.tar.gz
ports-184c1d6d8bea06f2942c63ace2df4449626dc419.zip
devel/tig: Update to 2.5.8
Apart from the update, the patch also fixes a missing dependency. If pcre2 (or pcre) is detected during 'configure', it will enable the pcre library during the build. If so, 'make stage-qa' will complain: > Error: /usr/local/bin/tig is linked to /usr/local/lib/libpcre2-posix.so.3 from devel/pcre2 but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libpcre2-posix.so:devel/pcre2 The patch also adds a PCRE option that explicity enables / disables pcre as desired. The default state of the PCRE option is off which is just like how packages are build in a package builder environment where the pcre package is not installed. But I have no problem with having it on by default (committer's discretion). The advantage is that it allows users to search via regexp which is a useful tool. The pcre libs have a friendly BSD3CLAUSE license. While here, tweak some sorting / formatting as hinted by portfmt/portclippy. PR: 270362
-rw-r--r--devel/tig/Makefile14
-rw-r--r--devel/tig/distinfo6
2 files changed, 11 insertions, 9 deletions
diff --git a/devel/tig/Makefile b/devel/tig/Makefile
index 5c7e2c602d65..a8290a64b462 100644
--- a/devel/tig/Makefile
+++ b/devel/tig/Makefile
@@ -1,5 +1,5 @@
PORTNAME= tig
-DISTVERSION= 2.5.5
+DISTVERSION= 2.5.8
CATEGORIES= devel
MASTER_SITES= https://github.com/jonas/tig/releases/download/${DISTNAME}/
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= git:devel/git
-USES= iconv gmake ncurses readline
+USES= gmake iconv ncurses readline
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
MAKE_ARGS= V=1
@@ -22,8 +22,8 @@ INSTALL_TARGET= install install-doc-man
# Tests fail when running as part of a non-interactive Poudriere
# build, but using script(1) seems to be a good enough workaround and
# allows them to run successfully anyway.
-TEST_TARGET= test
-DO_MAKE_TEST= /usr/bin/script -q /dev/null ${SETENV} ${TEST_ENV} ${GMAKE}
+TEST_TARGET= test-address-sanitizer
+DO_MAKE_TEST= script -q /dev/null ${SETENV} ${TEST_ENV} ${GMAKE}
PLIST_FILES= bin/tig \
'@sample etc/tigrc.sample' \
@@ -31,12 +31,14 @@ PLIST_FILES= bin/tig \
man/man5/tigrc.5.gz \
man/man7/tigmanual.7.gz
-OPTIONS_DEFINE= GIT
+OPTIONS_DEFINE= GIT PCRE
GIT_DESC= Install devel/git as runtime dependency
GIT_RUN_DEPENDS= git:devel/git
-GIT_VARS_OFF= PKGMESSAGE="${.CURDIR}/pkg-message-git"
+GIT_VARS_OFF= PKGMESSAGE="${.CURDIR}/pkg-message-git"
+PCRE_LIB_DEPENDS= lpcre2-posix.so:devel/pcre2
+PCRE_CONFIGURE_WITH= pcre
post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/tigrc ${STAGEDIR}${PREFIX}/etc/tigrc.sample
diff --git a/devel/tig/distinfo b/devel/tig/distinfo
index 104aea6ed57a..4a03b083b858 100644
--- a/devel/tig/distinfo
+++ b/devel/tig/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1642672607
-SHA256 (tig-2.5.5.tar.gz) = 24ba2c8beae889e6002ea7ced0e29851dee57c27fde8480fb9c64d5eb8765313
-SIZE (tig-2.5.5.tar.gz) = 1175752
+TIMESTAMP = 1678964725
+SHA256 (tig-2.5.8.tar.gz) = b70e0a42aed74a4a3990ccfe35262305917175e3164330c0889bd70580406391
+SIZE (tig-2.5.8.tar.gz) = 1179844