aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-06-28 02:53:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-06-28 02:53:56 +0000
commit191c41f4f5b363d5a9b012dd7fda09ebc060c463 (patch)
treea5bf805396fb6a9899846b061f727772dcb1e03a
parent5a72986dcc8658926988f2c8d17f13f1aec81771 (diff)
devel/py-decli: new port had been added (+)
Decli is minimal wrapper around argparse. It is useful when writing big applications that have many arguments and subcommands, this way it will be more clear. It is a minimal library to rapidly create an interface separated from your program. WWW: https://pypi.org/project/decli/
-rw-r--r--devel/Makefile3
-rw-r--r--devel/py-decli/Makefile19
-rw-r--r--devel/py-decli/distinfo3
-rw-r--r--devel/py-decli/pkg-descr4
4 files changed, 28 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3f864f0d5069..d4ef9bb42e60 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4672,6 +4672,7 @@
SUBDIR += py-debtcollector
SUBDIR += py-debugpy
SUBDIR += py-debugtools
+ SUBDIR += py-decli
SUBDIR += py-decopatch
SUBDIR += py-decorator
SUBDIR += py-decoratortools
@@ -7139,7 +7140,6 @@
SUBDIR += rubygem-googleapis-common-protos-types
SUBDIR += rubygem-graf
SUBDIR += rubygem-grape
- SUBDIR += rubygem-grape20
SUBDIR += rubygem-grape-entity
SUBDIR += rubygem-grape-path-helpers
SUBDIR += rubygem-grape-route-helpers
@@ -7147,6 +7147,7 @@
SUBDIR += rubygem-grape-swagger-entity
SUBDIR += rubygem-grape-swagger20
SUBDIR += rubygem-grape1
+ SUBDIR += rubygem-grape20
SUBDIR += rubygem-grape_logging
SUBDIR += rubygem-graphiql-rails
SUBDIR += rubygem-graphlient
diff --git a/devel/py-decli/Makefile b/devel/py-decli/Makefile
new file mode 100644
index 000000000000..438c5b74bbe5
--- /dev/null
+++ b/devel/py-decli/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= decli
+PORTVERSION= 0.6.2
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Minimal, easy-to-use, declarative CLI tool
+WWW= https://pypi.org/project/decli/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>0:devel/py-poetry-core@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist pep517
+
+.include <bsd.port.mk>
diff --git a/devel/py-decli/distinfo b/devel/py-decli/distinfo
new file mode 100644
index 000000000000..4c0d92b8a158
--- /dev/null
+++ b/devel/py-decli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1714326067
+SHA256 (decli-0.6.2.tar.gz) = 36f71eb55fd0093895efb4f416ec32b7f6e00147dda448e3365cf73ceab42d6f
+SIZE (decli-0.6.2.tar.gz) = 7424
diff --git a/devel/py-decli/pkg-descr b/devel/py-decli/pkg-descr
new file mode 100644
index 000000000000..d5f53ce4479f
--- /dev/null
+++ b/devel/py-decli/pkg-descr
@@ -0,0 +1,4 @@
+Decli is minimal wrapper around argparse. It is useful when writing
+big applications that have many arguments and subcommands, this way
+it will be more clear. It is a minimal library to rapidly create an
+interface separated from your program.