aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-21 22:11:40 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-21 22:11:40 +0000
commit1b0219a745d323b91beb8ca0fbda41a01b13fac5 (patch)
treefd5dbef0de78964068dbcdf7ed17ee5e99be3576
parentd35afbe77dc0115a813ea0cf3fcae75bf5affe1f (diff)
downloadports-1b0219a745d323b91beb8ca0fbda41a01b13fac5.tar.gz
ports-1b0219a745d323b91beb8ca0fbda41a01b13fac5.zip
devel/p5-Convert-Scalar: Add p5-Convert-Scalar 1.12
Convert::Scalar exports various internal perl methods that change the internal representation or state of a perl scalar. All of these work in-place, that is, they modify their scalar argument. No functions are exported by default. WWW: https://metacpan.org/dist/Convert-Scalar
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Convert-Scalar/Makefile21
-rw-r--r--devel/p5-Convert-Scalar/distinfo3
-rw-r--r--devel/p5-Convert-Scalar/files/patch-Makefile.PL17
-rw-r--r--devel/p5-Convert-Scalar/pkg-descr5
-rw-r--r--devel/p5-Convert-Scalar/pkg-plist3
6 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0b9fcc57f485..ac0c77befc5a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2017,6 +2017,7 @@
SUBDIR += p5-Const-Fast
SUBDIR += p5-Context-Preserve
SUBDIR += p5-Contextual-Return
+ SUBDIR += p5-Convert-Scalar
SUBDIR += p5-Coro
SUBDIR += p5-Curses
SUBDIR += p5-Curses-Application
diff --git a/devel/p5-Convert-Scalar/Makefile b/devel/p5-Convert-Scalar/Makefile
new file mode 100644
index 000000000000..7ce51f5f356a
--- /dev/null
+++ b/devel/p5-Convert-Scalar/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= Convert-Scalar
+PORTVERSION= 1.12
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Convert between different representations of perl scalars
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Convert/Scalar/Scalar.so
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Convert-Scalar/distinfo b/devel/p5-Convert-Scalar/distinfo
new file mode 100644
index 000000000000..66ac8e9232d7
--- /dev/null
+++ b/devel/p5-Convert-Scalar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632227458
+SHA256 (Convert-Scalar-1.12.tar.gz) = 1fcee7019b7ffd5081d685d2ac8407adfc5be011902826668903dc8abcb3c890
+SIZE (Convert-Scalar-1.12.tar.gz) = 8502
diff --git a/devel/p5-Convert-Scalar/files/patch-Makefile.PL b/devel/p5-Convert-Scalar/files/patch-Makefile.PL
new file mode 100644
index 000000000000..f0be09047199
--- /dev/null
+++ b/devel/p5-Convert-Scalar/files/patch-Makefile.PL
@@ -0,0 +1,17 @@
+--- Makefile.PL.orig 2017-08-15 05:57:22 UTC
++++ Makefile.PL
+@@ -1,6 +1,5 @@
+ use ExtUtils::MakeMaker;
+
+-use Canary::Stability Convert::Scalar => 1, 5.008;
+
+ WriteMakefile(
+ dist => {
+@@ -12,7 +11,6 @@ WriteMakefile(
+ VERSION_FROM => "Scalar.pm",
+ CONFIGURE_REQUIRES => {
+ "ExtUtils::MakeMaker" => 6.6,
+- "Canary::Stability" => 0,
+ },
+ BUILD_REQUIRES => {
+ ExtUtils::ParseXS => 3.28,
diff --git a/devel/p5-Convert-Scalar/pkg-descr b/devel/p5-Convert-Scalar/pkg-descr
new file mode 100644
index 000000000000..fe4646f9b0a5
--- /dev/null
+++ b/devel/p5-Convert-Scalar/pkg-descr
@@ -0,0 +1,5 @@
+Convert::Scalar exports various internal perl methods that change the internal
+representation or state of a perl scalar. All of these work in-place, that is,
+they modify their scalar argument. No functions are exported by default.
+
+WWW: https://metacpan.org/dist/Convert-Scalar
diff --git a/devel/p5-Convert-Scalar/pkg-plist b/devel/p5-Convert-Scalar/pkg-plist
new file mode 100644
index 000000000000..8899410686b9
--- /dev/null
+++ b/devel/p5-Convert-Scalar/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_ARCH%%/Convert/Scalar.pm
+%%SITE_ARCH%%/auto/Convert/Scalar/Scalar.so
+%%PERL5_MAN3%%/Convert::Scalar.3.gz