aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-22 05:15:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-22 05:24:30 +0000
commit1b662c94f414342c208fb888540dd58da6ccccb4 (patch)
tree94dc568e5e5fdbba25806810b270c3924eefe799
parent5604b7e8de7bc6a05a8d02ab246b9815cc354162 (diff)
downloadports-1b662c94f414342c208fb888540dd58da6ccccb4.tar.gz
ports-1b662c94f414342c208fb888540dd58da6ccccb4.zip
New port: misc/frugally-deep: C++ header-only library to use Keras models in C++ with ease
-rw-r--r--misc/Makefile1
-rw-r--r--misc/frugally-deep/Makefile33
-rw-r--r--misc/frugally-deep/distinfo3
-rw-r--r--misc/frugally-deep/pkg-descr4
-rw-r--r--misc/frugally-deep/pkg-plist64
5 files changed, 105 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 12decefb1fd9..3473b35d1647 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -129,6 +129,7 @@
SUBDIR += freebsd-doc-zh_tw
SUBDIR += freebsd-release-manifests
SUBDIR += freeguide
+ SUBDIR += frugally-deep
SUBDIR += ftdi-eeprom
SUBDIR += fxload
SUBDIR += gcstar
diff --git a/misc/frugally-deep/Makefile b/misc/frugally-deep/Makefile
new file mode 100644
index 000000000000..411f2ab41336
--- /dev/null
+++ b/misc/frugally-deep/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= frugally-deep
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.15.2-p0
+CATEGORIES= misc # deep-learning
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ header-only library to use Keras models in C++ with ease
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+HPP_DEPENDS= functionalplus>0:devel/functionalplus \
+ nlohmann-json>0:devel/nlohmann-json
+BUILD_DEPENDS= ${HPP_DEPENDS}
+RUN_DEPENDS= ${HPP_DEPENDS}
+TEST_DEPENDS= doctest>0:devel/doctest \
+ ${PYTHON_PKGNAMEPREFIX}keras>0:math/py-keras@${PY_FLAVOR}
+
+USES= cmake compiler:c++14-lang eigen:3,build,run python:3.6+,test
+
+USE_GITHUB= yes
+GH_ACCOUNT= Dobiasd
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-test: # tests are broken because they require tensorflow which is currently not available on FreeBSD
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DFDEEP_BUILD_UNITTEST:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/misc/frugally-deep/distinfo b/misc/frugally-deep/distinfo
new file mode 100644
index 000000000000..8bafd942782d
--- /dev/null
+++ b/misc/frugally-deep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619066238
+SHA256 (Dobiasd-frugally-deep-v0.15.2-p0_GH0.tar.gz) = 695c6b4e121406750d4f42c8df00703b7631156c380a09c7c77d3ae421c41112
+SIZE (Dobiasd-frugally-deep-v0.15.2-p0_GH0.tar.gz) = 200583
diff --git a/misc/frugally-deep/pkg-descr b/misc/frugally-deep/pkg-descr
new file mode 100644
index 000000000000..e738cc277ee5
--- /dev/null
+++ b/misc/frugally-deep/pkg-descr
@@ -0,0 +1,4 @@
+frugally-deep is a C++ header-only library for building/training
+Keras AI models.
+
+WWW: https://github.com/Dobiasd/frugally-deep
diff --git a/misc/frugally-deep/pkg-plist b/misc/frugally-deep/pkg-plist
new file mode 100644
index 000000000000..f1537ba9ecf6
--- /dev/null
+++ b/misc/frugally-deep/pkg-plist
@@ -0,0 +1,64 @@
+include/fdeep/base64.hpp
+include/fdeep/common.hpp
+include/fdeep/convolution.hpp
+include/fdeep/convolution_im2col.hpp
+include/fdeep/fdeep.hpp
+include/fdeep/filter.hpp
+include/fdeep/import_model.hpp
+include/fdeep/layers/activation_layer.hpp
+include/fdeep/layers/add_layer.hpp
+include/fdeep/layers/average_layer.hpp
+include/fdeep/layers/average_pooling_2d_layer.hpp
+include/fdeep/layers/batch_normalization_layer.hpp
+include/fdeep/layers/bidirectional_layer.hpp
+include/fdeep/layers/concatenate_layer.hpp
+include/fdeep/layers/conv_2d_layer.hpp
+include/fdeep/layers/cropping_2d_layer.hpp
+include/fdeep/layers/dense_layer.hpp
+include/fdeep/layers/depthwise_conv_2d_layer.hpp
+include/fdeep/layers/elu_layer.hpp
+include/fdeep/layers/embedding_layer.hpp
+include/fdeep/layers/flatten_layer.hpp
+include/fdeep/layers/global_average_pooling_1d_layer.hpp
+include/fdeep/layers/global_average_pooling_2d_layer.hpp
+include/fdeep/layers/global_max_pooling_1d_layer.hpp
+include/fdeep/layers/global_max_pooling_2d_layer.hpp
+include/fdeep/layers/global_pooling_layer.hpp
+include/fdeep/layers/gru_layer.hpp
+include/fdeep/layers/hard_sigmoid_layer.hpp
+include/fdeep/layers/input_layer.hpp
+include/fdeep/layers/layer.hpp
+include/fdeep/layers/leaky_relu_layer.hpp
+include/fdeep/layers/linear_layer.hpp
+include/fdeep/layers/lstm_layer.hpp
+include/fdeep/layers/max_pooling_2d_layer.hpp
+include/fdeep/layers/maximum_layer.hpp
+include/fdeep/layers/model_layer.hpp
+include/fdeep/layers/multiply_layer.hpp
+include/fdeep/layers/permute_layer.hpp
+include/fdeep/layers/pooling_2d_layer.hpp
+include/fdeep/layers/prelu_layer.hpp
+include/fdeep/layers/relu_layer.hpp
+include/fdeep/layers/reshape_layer.hpp
+include/fdeep/layers/selu_layer.hpp
+include/fdeep/layers/separable_conv_2d_layer.hpp
+include/fdeep/layers/sigmoid_layer.hpp
+include/fdeep/layers/softmax_layer.hpp
+include/fdeep/layers/softplus_layer.hpp
+include/fdeep/layers/subtract_layer.hpp
+include/fdeep/layers/tanh_layer.hpp
+include/fdeep/layers/time_distributed_layer.hpp
+include/fdeep/layers/upsampling_1d_layer.hpp
+include/fdeep/layers/upsampling_2d_layer.hpp
+include/fdeep/layers/zero_padding_2d_layer.hpp
+include/fdeep/model.hpp
+include/fdeep/node.hpp
+include/fdeep/recurrent_ops.hpp
+include/fdeep/shape2.hpp
+include/fdeep/tensor.hpp
+include/fdeep/tensor_pos.hpp
+include/fdeep/tensor_shape.hpp
+include/fdeep/tensor_shape_variable.hpp
+lib/cmake/frugally-deep/frugally-deepConfig.cmake
+lib/cmake/frugally-deep/frugally-deepConfigVersion.cmake
+lib/cmake/frugally-deep/frugally-deepTargets.cmake