aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2024-10-18 12:53:12 +0000
committerCharlie Li <vishwin@FreeBSD.org>2024-10-18 12:54:27 +0000
commit1c5ebef22acc2837ff8c576715fa208793dcecd9 (patch)
tree162f18b43725c8b28ce03ae039530cfe8e4acf17
parent17784cbc27aa4f335daa4664e519876d10472957 (diff)
devel/wasi-libc: chase missed _DEPENDS line changes after flavourisation
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/librewolf/Makefile2
-rw-r--r--www/tor-browser/Makefile2
-rw-r--r--www/waterfox/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 0aefe9bb5e87..1c7a9a808e98 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -55,7 +55,7 @@ OPTIONS_DEFAULT=CANBERRA
MOZ_OPTIONS+= --without-wasm-sandboxed-libraries
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx${LLVM_VERSION} \
- ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \
+ ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc@${LLVM_VERSION} \
wasi-compiler-rt${LLVM_VERSION}>0:devel/wasi-compiler-rt${LLVM_VERSION}
MOZ_OPTIONS+= --with-wasi-sysroot=${LOCALBASE}/share/wasi-sysroot
.endif
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index fc29ab326471..cc9a7ea8923e 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -51,7 +51,7 @@ MOZ_OPTIONS= --enable-application=browser \
MOZ_OPTIONS+= --without-wasm-sandboxed-libraries
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx${LLVM_VERSION} \
- ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \
+ ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc@${LLVM_VERSION} \
wasi-compiler-rt${LLVM_VERSION}>0:devel/wasi-compiler-rt${LLVM_VERSION}
MOZ_OPTIONS+= --with-wasi-sysroot=${LOCALBASE}/share/wasi-sysroot
.endif
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index bf31ec242ee0..9f4c1bfd9279 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -52,7 +52,7 @@ MOZ_OPTIONS= --enable-application=browser \
MOZ_OPTIONS+= --without-wasm-sandboxed-libraries
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx${LLVM_VERSION} \
- ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \
+ ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc@${LLVM_VERSION} \
wasi-compiler-rt${LLVM_VERSION}>0:devel/wasi-compiler-rt${LLVM_VERSION}
MOZ_OPTIONS+= --with-wasi-sysroot=${LOCALBASE}/share/wasi-sysroot
.endif
diff --git a/www/librewolf/Makefile b/www/librewolf/Makefile
index a2fe94cca6d6..bfd8931222eb 100644
--- a/www/librewolf/Makefile
+++ b/www/librewolf/Makefile
@@ -80,7 +80,7 @@ CFLAGS+= -DHWY_COMPILE_ONLY_SCALAR
MOZ_OPTIONS+= --without-wasm-sandboxed-libraries
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx${LLVM_VERSION} \
- ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \
+ ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc@${LLVM_VERSION} \
wasi-compiler-rt${LLVM_VERSION}>0:devel/wasi-compiler-rt${LLVM_VERSION}
MOZ_OPTIONS+= --with-wasi-sysroot=${LOCALBASE}/share/wasi-sysroot
.endif
diff --git a/www/tor-browser/Makefile b/www/tor-browser/Makefile
index 622d507a8de3..bb8668b7123a 100644
--- a/www/tor-browser/Makefile
+++ b/www/tor-browser/Makefile
@@ -89,7 +89,7 @@ MOZ_OPTIONS+= --enable-rust-simd
MOZ_OPTIONS+= --without-wasm-sandboxed-libraries
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx${LLVM_VERSION} \
- ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \
+ ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc@${LLVM_VERSION} \
wasi-compiler-rt${LLVM_VERSION}>0:devel/wasi-compiler-rt${LLVM_VERSION}
MOZILLA_PLIST_DIRS= bin lib share/pixmaps share/applications share/tor-browser
MOZ_OPTIONS+= --with-wasi-sysroot=${LOCALBASE}/share/wasi-sysroot
diff --git a/www/waterfox/Makefile b/www/waterfox/Makefile
index f696918ba8a3..0f0b106882b8 100644
--- a/www/waterfox/Makefile
+++ b/www/waterfox/Makefile
@@ -84,7 +84,7 @@ CFLAGS+= -DHWY_COMPILE_ONLY_SCALAR
MOZ_OPTIONS+= --without-wasm-sandboxed-libraries
.else
BUILD_DEPENDS+= ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc++abi.a:devel/wasi-libcxx${LLVM_VERSION} \
- ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc \
+ ${LOCALBASE}/share/wasi-sysroot/lib/wasm32-wasi/libc.a:devel/wasi-libc@${LLVM_VERSION} \
wasi-compiler-rt${LLVM_VERSION}>0:devel/wasi-compiler-rt${LLVM_VERSION}
MOZ_OPTIONS+= --with-wasi-sysroot=${LOCALBASE}/share/wasi-sysroot
.endif