aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDries Michiels <driesm@FreeBSD.org>2021-12-16 09:40:40 +0000
committerDries Michiels <driesm@FreeBSD.org>2021-12-20 10:55:49 +0000
commit1cc3eec7c35d3aad0b6ce749d1a4d83d685c2d8e (patch)
treeea524ad8d35781ea82ed7c8b86e0ddd1abaeba9e
parent802a483bd624b450317b361ac951ef847dbd2446 (diff)
downloadports-1cc3eec7c35d3aad0b6ce749d1a4d83d685c2d8e.tar.gz
ports-1cc3eec7c35d3aad0b6ce749d1a4d83d685c2d8e.zip
games/neo: New port
cmatrix clone with 32-bit color and Unicode support. Approved by: 0mp (mentor) Differential Revision: https://reviews.freebsd.org/D33507
-rw-r--r--games/Makefile1
-rw-r--r--games/neo/Makefile37
-rw-r--r--games/neo/distinfo5
-rw-r--r--games/neo/pkg-descr8
4 files changed, 51 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index de9804cbe34b..a1a058722041 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -638,6 +638,7 @@
SUBDIR += nazghul
SUBDIR += nbsdgames
SUBDIR += nehquake
+ SUBDIR += neo
SUBDIR += neo-cowsay
SUBDIR += nethack32
SUBDIR += nethack33
diff --git a/games/neo/Makefile b/games/neo/Makefile
new file mode 100644
index 000000000000..b788ae239334
--- /dev/null
+++ b/games/neo/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= neo
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6
+CATEGORIES= games
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
+PATCHFILES= 4dd64a0.patch:-p1 # https://github.com/st3w/neo/issues/8
+
+MAINTAINER= driesm@FreeBSD.org
+COMMENT= cmatrix clone with 32-bit color and Unicode support
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
+
+USES= autoreconf compiler:c++11-lang ncurses
+USE_GITHUB= yes
+GH_ACCOUNT= st3w
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/neo \
+ share/man/man6/neo.6.gz
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/neo ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/neo.6 ${STAGEDIR}${MANPREFIX}/share/man/man6
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/neo/distinfo b/games/neo/distinfo
new file mode 100644
index 000000000000..4ed7e1ac01d3
--- /dev/null
+++ b/games/neo/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1639652670
+SHA256 (st3w-neo-v0.6_GH0.tar.gz) = c044dcb79665cb7de7b93cbec471383916aa01df3d05116ee3a47400ec471c9e
+SIZE (st3w-neo-v0.6_GH0.tar.gz) = 1134802
+SHA256 (4dd64a0.patch) = e657f88df87984b7b7a1fe008f3c2917bead5bd52bf58ed0015507b34e10ba4f
+SIZE (4dd64a0.patch) = 2914
diff --git a/games/neo/pkg-descr b/games/neo/pkg-descr
new file mode 100644
index 000000000000..4a0a5db14f8c
--- /dev/null
+++ b/games/neo/pkg-descr
@@ -0,0 +1,8 @@
+Simulates the digital rain from "The Matrix".
+cmatrix clone with 32-bit color and Unicode support.
+
+neo recreates the digital rain effect from "The Matrix".
+Streams of random characters will endlessly scroll
+down your terminal screen.
+
+WWW: https://github.com/st3w/neo