aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2023-05-13 10:41:24 +0000
committerChris Rees <crees@FreeBSD.org>2023-05-13 10:45:05 +0000
commit1fe33abd0b0111c87b0b50bf902e777c948aa03c (patch)
tree0fc686f5030282343c1adf34c97748ed1a503a00
parenta4e5f793266ed0a57759be09312a7fc8677b205e (diff)
downloadports-1fe33abd0b0111c87b0b50bf902e777c948aa03c.tar.gz
ports-1fe33abd0b0111c87b0b50bf902e777c948aa03c.zip
audio/ampache: Update to 5.6.0
Fix the .htaccess issues with newer Apache-- see patchfile. Submitted upstream as pull request 3526 https://github.com/ampache/ampache/pull/3526 Changelog: https://github.com/ampache/ampache/blob/develop/docs/CHANGELOG.md
-rw-r--r--audio/ampache/Makefile3
-rw-r--r--audio/ampache/distinfo6
-rw-r--r--audio/ampache/files/patch-htaccess53
-rw-r--r--audio/ampache/pkg-plist9
4 files changed, 65 insertions, 6 deletions
diff --git a/audio/ampache/Makefile b/audio/ampache/Makefile
index 61e671212b91..e58884b582fa 100644
--- a/audio/ampache/Makefile
+++ b/audio/ampache/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ampache
-PORTVERSION= 5.5.7
-PORTREVISION= 1
+PORTVERSION= 5.6.0
DISTVERSIONSUFFIX= _all
CATEGORIES= audio www
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/
diff --git a/audio/ampache/distinfo b/audio/ampache/distinfo
index 32ab5dc391b4..efdf403ca6eb 100644
--- a/audio/ampache/distinfo
+++ b/audio/ampache/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679911015
-SHA256 (ampache-5.5.7_all.zip) = d0b2241dc4ed74beea80d58612afab108a955d4814fd009221515813d7e52095
-SIZE (ampache-5.5.7_all.zip) = 58923907
+TIMESTAMP = 1683967385
+SHA256 (ampache-5.6.0_all.zip) = a3b6d8fe9179f49d0b2b3578b0ea02f9d38259d1d9584af81b26fa6cf98859ca
+SIZE (ampache-5.6.0_all.zip) = 58936006
diff --git a/audio/ampache/files/patch-htaccess b/audio/ampache/files/patch-htaccess
new file mode 100644
index 000000000000..ac721dff0d6f
--- /dev/null
+++ b/audio/ampache/files/patch-htaccess
@@ -0,0 +1,53 @@
+Since Apache r1908095 [1], it has become far less forgiving of 'invalid characters' in Rewrite patterns, for example patterns with spaces.
+
+Songs often have spaces in the filenames, so it is necessary to pass them.
+
+[1] https://svn.apache.org/viewvc?view=revision&revision=1908095
+
+[2] https://webmasters.stackexchange.com/questions/141837/ah10411-rewritten-query-string-contains-control-characters-or-spaces
+
+diff --git a/public/daap/.htaccess b/public/daap/.htaccess
+index b1e0ee01b..0d8fc6e69 100644
+--- public/daap/.htaccess
++++ public/daap/.htaccess
+@@ -2,5 +2,5 @@
+ RewriteEngine On
+ RewriteCond %{REQUEST_FILENAME} !-d
+ RewriteCond %{REQUEST_FILENAME} !-s
+- RewriteRule ^(.+)$ /index.php?action=$1 [PT,L,QSA]
+-</IfModule>
+\ No newline at end of file
++ RewriteRule ^(.+)$ /index.php?action=$1 "[PT,L,QSA,B= ?,BNP]"
++</IfModule>
+diff --git a/public/play/.htaccess.dist b/public/play/.htaccess.dist
+index e1320aaae..6a11825a9 100644
+--- public/play/.htaccess.dist
++++ public/play/.htaccess.dist
+@@ -2,8 +2,8 @@
+ RewriteEngine On
+ RewriteCond %{REQUEST_FILENAME} !-d
+ RewriteCond %{REQUEST_FILENAME} !-s
+- RewriteRule ^art/([^/]+)/([^/]+)/([0-9]+)/thumb([0-9]*)\.([a-z]+)$ /image.php?object_type=$2&object_id=$3&auth=$1&thumb=$4&name=art.jpg [L]
+- RewriteRule ^([^/]+)/([^/]+)/([^/]+)/([^/]+)(/.*)?$ /play/$5?$1=$2&$3=$4 [N,QSA]
+- RewriteRule ^([^/]+)/([^/]+)(/.*)?$ /play/$3?$1=$2 [N,QSA]
+- RewriteRule ^(/[^/]+|[^/]+/|/?)$ /play/index.php [L,QSA]
++ RewriteRule ^art/([^/]+)/([^/]+)/([0-9]+)/thumb([0-9]*)\.([a-z]+)$ /image.php?object_type=$2&object_id=$3&auth=$1&thumb=$4&name=art.jpg "[L,B= ?,BNP]"
++ RewriteRule ^([^/]+)/([^/]+)/([^/]+)/([^/]+)(/.*)?$ /play/$5?$1=$2&$3=$4 "[N,QSA,B= ?,BNP]"
++ RewriteRule ^([^/]+)/([^/]+)(/.*)?$ /play/$3?$1=$2 "[N,QSA,B= ?,BNP]"
++ RewriteRule ^(/[^/]+|[^/]+/|/?)$ /play/index.php "[L,QSA,B= ?,BNP]"
+ </IfModule>
+diff --git a/public/rest/.htaccess.dist b/public/rest/.htaccess.dist
+index 182930219..65cff9e4f 100644
+--- public/rest/.htaccess.dist
++++ public/rest/.htaccess.dist
+@@ -2,6 +2,6 @@
+ RewriteEngine On
+ RewriteCond %{REQUEST_FILENAME} !-d
+ RewriteCond %{REQUEST_FILENAME} !-s
+- RewriteRule ^(.+)\.view$ /rest/index.php?ssaction=$1 [PT,L,QSA]
+- RewriteRule ^fake/(.+)$ /play/$1 [PT,L,QSA]
+-</IfModule>
+\ No newline at end of file
++ RewriteRule ^(.+)\.view$ /rest/index.php?ssaction=$1 "[PT,L,QSA,B= ?,BNP]"
++ RewriteRule ^fake/(.+)$ /play/$1 "[PT,L,QSA,B= ?,BNP]"
++</IfModule>
diff --git a/audio/ampache/pkg-plist b/audio/ampache/pkg-plist
index e80b0dd173d3..8bbf2b85492b 100644
--- a/audio/ampache/pkg-plist
+++ b/audio/ampache/pkg-plist
@@ -5916,6 +5916,7 @@ man/man1/ampache.1.gz
%%WWWDIR%%/vendor/myclabs/deep-copy/src/DeepCopy/DeepCopy.php
%%WWWDIR%%/vendor/myclabs/deep-copy/src/DeepCopy/Exception/CloneException.php
%%WWWDIR%%/vendor/myclabs/deep-copy/src/DeepCopy/Exception/PropertyException.php
+%%WWWDIR%%/vendor/myclabs/deep-copy/src/DeepCopy/Filter/ChainableFilter.php
%%WWWDIR%%/vendor/myclabs/deep-copy/src/DeepCopy/Filter/Doctrine/DoctrineCollectionFilter.php
%%WWWDIR%%/vendor/myclabs/deep-copy/src/DeepCopy/Filter/Doctrine/DoctrineEmptyCollectionFilter.php
%%WWWDIR%%/vendor/myclabs/deep-copy/src/DeepCopy/Filter/Doctrine/DoctrineProxyFilter.php
@@ -7359,7 +7360,7 @@ man/man1/ampache.1.gz
%%WWWDIR%%/vendor/phpmailer/phpmailer/src/PHPMailer.php
%%WWWDIR%%/vendor/phpmailer/phpmailer/src/POP3.php
%%WWWDIR%%/vendor/phpmailer/phpmailer/src/SMTP.php
-%%WWWDIR%%/vendor/phpunit/php-code-coverage/ChangeLog.md
+%%WWWDIR%%/vendor/phpunit/php-code-coverage/ChangeLog-9.2.md
%%WWWDIR%%/vendor/phpunit/php-code-coverage/LICENSE
%%WWWDIR%%/vendor/phpunit/php-code-coverage/README.md
%%WWWDIR%%/vendor/phpunit/php-code-coverage/composer.json
@@ -10117,6 +10118,8 @@ man/man1/ampache.1.gz
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.1.inc.fixed
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.2.inc
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.2.inc.fixed
+%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.3.inc
+%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.3.inc.fixed
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.css
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.css.fixed
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/WhiteSpace/DisallowTabIndentUnitTest.js
@@ -11081,6 +11084,10 @@ man/man1/ampache.1.gz
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/FinallyTest.php
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/GotoLabelTest.inc
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/GotoLabelTest.php
+%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/HeredocNowdocCloserTest.inc
+%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/HeredocNowdocCloserTest.php
+%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/HeredocStringTest.inc
+%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/HeredocStringTest.php
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/NamedFunctionCallArgumentsTest.inc
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/NamedFunctionCallArgumentsTest.php
%%WWWDIR%%/vendor/squizlabs/php_codesniffer/tests/Core/Tokenizer/NullsafeObjectOperatorTest.inc