aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 09:52:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-07 09:52:16 +0000
commit1fe815b0addf6496b1988c43d928297053ea82b9 (patch)
tree5399a9e569f90d650c66854c55a20646a97d8b2f
parent08365d4a0b7b6b43b9687bdad6048ed8166e9188 (diff)
downloadports-1fe815b0addf6496b1988c43d928297053ea82b9.tar.gz
ports-1fe815b0addf6496b1988c43d928297053ea82b9.zip
Import libcdr01
Ensure it does not conflicts with libcdr
Notes
Notes: svn path=/head/; revision=370283
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libcdr/Makefile5
-rw-r--r--graphics/libcdr/pkg-plist8
-rw-r--r--graphics/libcdr01/Makefile29
-rw-r--r--graphics/libcdr01/distinfo2
-rw-r--r--graphics/libcdr01/pkg-descr4
-rw-r--r--graphics/libcdr01/pkg-plist14
7 files changed, 54 insertions, 9 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 33527801c592..ddb62e17725b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -485,6 +485,7 @@
SUBDIR += libboard
SUBDIR += libcaca
SUBDIR += libcdr
+ SUBDIR += libcdr01
SUBDIR += libchamplain
SUBDIR += libdmtx
SUBDIR += libdrm
diff --git a/graphics/libcdr/Makefile b/graphics/libcdr/Makefile
index ed0c31ff13a4..fed7d3e8a1f8 100644
--- a/graphics/libcdr/Makefile
+++ b/graphics/libcdr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libcdr
PORTVERSION= 0.0.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics devel
MASTER_SITES= http://dev-www.libreoffice.org/src/
@@ -27,4 +27,7 @@ INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -Wno-long-long
+post-stage:
+ ${RM} -f ${STAGEDIR}${PREFIX}/bin/c*
+
.include <bsd.port.mk>
diff --git a/graphics/libcdr/pkg-plist b/graphics/libcdr/pkg-plist
index 0cc979af2b75..60b3b5265296 100644
--- a/graphics/libcdr/pkg-plist
+++ b/graphics/libcdr/pkg-plist
@@ -1,9 +1,3 @@
-bin/cdr2raw
-bin/cdr2text
-bin/cdr2xhtml
-bin/cmx2raw
-bin/cmx2text
-bin/cmx2xhtml
include/libcdr-0.0/libcdr/CDRDocument.h
include/libcdr-0.0/libcdr/CDRStringVector.h
include/libcdr-0.0/libcdr/CMXDocument.h
@@ -12,5 +6,3 @@ lib/libcdr-0.0.so
lib/libcdr-0.0.so.0
lib/libcdr-0.0.so.0.0.16
libdata/pkgconfig/libcdr-0.0.pc
-@dirrm include/libcdr-0.0/libcdr
-@dirrm include/libcdr-0.0
diff --git a/graphics/libcdr01/Makefile b/graphics/libcdr01/Makefile
new file mode 100644
index 000000000000..efa10d000751
--- /dev/null
+++ b/graphics/libcdr01/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= libcdr
+PORTVERSION= 0.1.0
+CATEGORIES= graphics devel
+MASTER_SITES= http://dev-www.libreoffice.org/src/
+PKGNAMESUIFFIX= 01
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library and tools for parsing Corel Draw file format
+
+LICENSE= LGPL21 MPL GPLv2
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/optional.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libicui18n.so:${PORTSDIR}/devel/icu \
+ librevenge-0.0.so:${PORTSDIR}/textproc/librevenge \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-werror --without-docs
+USES= libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+CPPFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -Wno-long-long
+
+.include <bsd.port.mk>
diff --git a/graphics/libcdr01/distinfo b/graphics/libcdr01/distinfo
new file mode 100644
index 000000000000..e063d5da20cc
--- /dev/null
+++ b/graphics/libcdr01/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcdr-0.1.0.tar.xz) = a9bd1faca049cf1e2285b27da213a499434591919227beb209b191ad1bb240e8
+SIZE (libcdr-0.1.0.tar.xz) = 562240
diff --git a/graphics/libcdr01/pkg-descr b/graphics/libcdr01/pkg-descr
new file mode 100644
index 000000000000..541673260695
--- /dev/null
+++ b/graphics/libcdr01/pkg-descr
@@ -0,0 +1,4 @@
+Library and tools providing ability to interpret and import Corel Draw drawings
+into various applications.
+
+WWW: http://www.freedesktop.org/wiki/Software/libcdr/
diff --git a/graphics/libcdr01/pkg-plist b/graphics/libcdr01/pkg-plist
new file mode 100644
index 000000000000..ff5aa228920d
--- /dev/null
+++ b/graphics/libcdr01/pkg-plist
@@ -0,0 +1,14 @@
+bin/cdr2raw
+bin/cdr2text
+bin/cdr2xhtml
+bin/cmx2raw
+bin/cmx2text
+bin/cmx2xhtml
+include/libcdr-0.1/libcdr/CDRDocument.h
+include/libcdr-0.1/libcdr/CMXDocument.h
+include/libcdr-0.1/libcdr/libcdr.h
+include/libcdr-0.1/libcdr/libcdr_api.h
+lib/libcdr-0.1.so
+lib/libcdr-0.1.so.1
+lib/libcdr-0.1.so.1.0.0
+libdata/pkgconfig/libcdr-0.1.pc