aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-12-31 13:43:37 +0000
committerRene Ladan <rene@FreeBSD.org>2021-12-31 13:43:37 +0000
commit20191665b2ed12d11c32fb7db5047a37ad8a32a9 (patch)
tree091bc9d4d603ea61b3c1ec03303f5a3fe3df9983
parent75b955057c8e0c7cf9f47d4070802312e8427d34 (diff)
downloadports-20191665b2ed12d11c32fb7db5047a37ad8a32a9.tar.gz
ports-20191665b2ed12d11c32fb7db5047a37ad8a32a9.zip
cleanup: deprecate a bunch of ports depending on expired ports.
-rw-r--r--devel/gitblit/Makefile3
-rw-r--r--devel/py-pytest-relaxed/Makefile3
-rw-r--r--graphics/barbecue/Makefile3
-rw-r--r--graphics/deegree-csw/Makefile3
-rw-r--r--graphics/deegree-igeoportal/Makefile3
-rw-r--r--graphics/deegree-wcs/Makefile3
-rw-r--r--graphics/deegree-wfs/Makefile3
-rw-r--r--graphics/deegree-wms/Makefile3
-rw-r--r--graphics/deegree-wps/Makefile3
-rw-r--r--graphics/deegree-wpvs/Makefile3
-rw-r--r--graphics/tinyows/Makefile3
-rw-r--r--multimedia/py-moviepy/Makefile3
-rw-r--r--sysutils/rubygem-smart_proxy_chef/Makefile3
-rw-r--r--www/jspwiki/Makefile3
-rw-r--r--www/py-instabot/Makefile3
-rw-r--r--www/sakai/Makefile3
16 files changed, 48 insertions, 0 deletions
diff --git a/devel/gitblit/Makefile b/devel/gitblit/Makefile
index 17708d4847d0..fcab52852880 100644
--- a/devel/gitblit/Makefile
+++ b/devel/gitblit/Makefile
@@ -13,6 +13,9 @@ COMMENT= Open-source servlet for Git repositories
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/WEB-INF/LICENSE
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
CONFLICTS= ${PORTNAME}-go
NO_ARCH= yes
diff --git a/devel/py-pytest-relaxed/Makefile b/devel/py-pytest-relaxed/Makefile
index 7fef8a4a2441..809a29e3b4a7 100644
--- a/devel/py-pytest-relaxed/Makefile
+++ b/devel/py-pytest-relaxed/Makefile
@@ -11,6 +11,9 @@ COMMENT= Relaxed test discovery/organization for pytest
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Depends on expired devel/py-decorator4
+EXPIRATION_DATE=2022-03-31
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3<5:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1<2:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}decorator4>=4<5:devel/py-decorator4@${PY_FLAVOR}
diff --git a/graphics/barbecue/Makefile b/graphics/barbecue/Makefile
index 8dc91e83e839..d7a3b6984e03 100644
--- a/graphics/barbecue/Makefile
+++ b/graphics/barbecue/Makefile
@@ -12,6 +12,9 @@ COMMENT= Java barcode generator
LICENSE= BSD3CLAUSE
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
RUN_DEPENDS= ${JAVALIBDIR}/jdom.jar:java/jdom
USE_JAVA= yes
diff --git a/graphics/deegree-csw/Makefile b/graphics/deegree-csw/Makefile
index a6bb18a26fc2..ba9ca0f5d3bf 100644
--- a/graphics/deegree-csw/Makefile
+++ b/graphics/deegree-csw/Makefile
@@ -13,6 +13,9 @@ COMMENT= Deegree Catalogue Service(CSW)
LICENSE= LGPL21+
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= zip
USE_JAVA= yes
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index e7972acf10af..3f7c3267ad9b 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -13,6 +13,9 @@ COMMENT= Browser based client handling WMS, WFS, and proxy service
LICENSE= LGPL21+
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= zip
USE_JAVA= yes
diff --git a/graphics/deegree-wcs/Makefile b/graphics/deegree-wcs/Makefile
index 127a1c2762f6..12a0d77c957f 100644
--- a/graphics/deegree-wcs/Makefile
+++ b/graphics/deegree-wcs/Makefile
@@ -13,6 +13,9 @@ COMMENT= Deegree Web Coverage Service(WCS)
LICENSE= LGPL21+
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= zip
USE_JAVA= yes
diff --git a/graphics/deegree-wfs/Makefile b/graphics/deegree-wfs/Makefile
index 3559e9904a76..f9b9f107c929 100644
--- a/graphics/deegree-wfs/Makefile
+++ b/graphics/deegree-wfs/Makefile
@@ -13,6 +13,9 @@ COMMENT= Deegree Web Feature Service(WFS)
LICENSE= LGPL21+
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= zip
USE_JAVA= yes
diff --git a/graphics/deegree-wms/Makefile b/graphics/deegree-wms/Makefile
index a5c0e4f7c10b..9b25abdb7fe6 100644
--- a/graphics/deegree-wms/Makefile
+++ b/graphics/deegree-wms/Makefile
@@ -11,6 +11,9 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Deegree Web Map Service(WMS)
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= zip
USE_JAVA= yes
diff --git a/graphics/deegree-wps/Makefile b/graphics/deegree-wps/Makefile
index ef5cd629181a..11bfb24c5a1d 100644
--- a/graphics/deegree-wps/Makefile
+++ b/graphics/deegree-wps/Makefile
@@ -11,6 +11,9 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Deegree Web Processing Service(WPS)
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= zip
USE_JAVA= yes
diff --git a/graphics/deegree-wpvs/Makefile b/graphics/deegree-wpvs/Makefile
index d847ded6c978..75ef468fc909 100644
--- a/graphics/deegree-wpvs/Makefile
+++ b/graphics/deegree-wpvs/Makefile
@@ -13,6 +13,9 @@ COMMENT= Deegree Web Terrain Service(WTS)/Web Perspective View Service(WPVS)
LICENSE= LGPL21+
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= zip
USE_JAVA= yes
diff --git a/graphics/tinyows/Makefile b/graphics/tinyows/Makefile
index d3bffcf3d073..b35bf6217dc0 100644
--- a/graphics/tinyows/Makefile
+++ b/graphics/tinyows/Makefile
@@ -9,6 +9,9 @@ MASTER_SITES= https://download.osgeo.org/mapserver/
MAINTAINER= joris.dedieu@gmail.com
COMMENT= High Performance WFS-T server
+DEPRECATED= Depends on expired databases/postgis25
+EXPIRATION_DATE=2022-03-31
+
LIB_DEPENDS= libxml2.so:textproc/libxml2 \
liblwgeom.so:databases/postgis25
diff --git a/multimedia/py-moviepy/Makefile b/multimedia/py-moviepy/Makefile
index 7ab5e42d5e2a..e215d82eef76 100644
--- a/multimedia/py-moviepy/Makefile
+++ b/multimedia/py-moviepy/Makefile
@@ -11,6 +11,9 @@ COMMENT= Video editing with Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENCE.txt
+DEPRECATED= Depends on expired devel/py-decorator4
+EXPIRATION_DATE=2022-03-31
+
RUN_DEPENDS= ffmpeg:multimedia/ffmpeg \
${PYTHON_PKGNAMEPREFIX}decorator4>=4.0.2<5.0:devel/py-decorator4@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}imageio>=2.5<3.0:graphics/py-imageio@${PY_FLAVOR} \
diff --git a/sysutils/rubygem-smart_proxy_chef/Makefile b/sysutils/rubygem-smart_proxy_chef/Makefile
index b4696269068f..898a1b2952e7 100644
--- a/sysutils/rubygem-smart_proxy_chef/Makefile
+++ b/sysutils/rubygem-smart_proxy_chef/Makefile
@@ -11,6 +11,9 @@ COMMENT= Chef Plug-In for Foreman\'s Smart Proxy
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Depends on expired sysutils/rubygem-chef-api
+EXPIRATION_DATE=2022-03-31
+
RUN_DEPENDS= foreman-proxy>=1.8.0:net/foreman-proxy \
rubygem-chef-api>=0:sysutils/rubygem-chef-api
diff --git a/www/jspwiki/Makefile b/www/jspwiki/Makefile
index 575f00025300..c16fd587bf3d 100644
--- a/www/jspwiki/Makefile
+++ b/www/jspwiki/Makefile
@@ -13,6 +13,9 @@ COMMENT= Feature-rich and extensible Wiki engine built around J2EE
LICENSE= APACHE20
LICENSE_FILE= ${WRKDIR}/jspwiki/LICENSE
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
USES= cpe zip
USE_JAVA= yes
NO_BUILD= yes
diff --git a/www/py-instabot/Makefile b/www/py-instabot/Makefile
index 334cf534b068..e24a8412a2f3 100644
--- a/www/py-instabot/Makefile
+++ b/www/py-instabot/Makefile
@@ -12,6 +12,9 @@ COMMENT= Instagram bot scripts and API wrapper
LICENSE= APACHE20
+DEPRECATED= Depends on expired devel/py-decorator4
+EXPIRATION_DATE=2022-03-31
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=2019.11.28:security/py-certifi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}chardet>=3.0.4,1:textproc/py-chardet@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}future>=0.18.2:devel/py-future@${PY_FLAVOR} \
diff --git a/www/sakai/Makefile b/www/sakai/Makefile
index 4d3cd82c92fe..dec3dc75efb2 100644
--- a/www/sakai/Makefile
+++ b/www/sakai/Makefile
@@ -14,6 +14,9 @@ LICENSE_NAME= Educational Community License version 2
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+DEPRECATED= Depends on expired www/tomcat7
+EXPIRATION_DATE=2022-03-31
+
RUN_DEPENDS= ${LOCALBASE}/apache-tomcat-7.0/bin/bootstrap.jar:www/tomcat7
IGNORE= does not work correctly