aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 18:48:32 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 18:53:45 +0000
commit20450aa4df007de8981831bc5b28c3662d9aa83b (patch)
tree4c2a609db3883573b31bff4c4ee5e91b93ff1719
parent2d0d945a5884215b6aa1195b265a4f854e0bb759 (diff)
downloadports-20450aa4df007de8981831bc5b28c3662d9aa83b.tar.gz
ports-20450aa4df007de8981831bc5b28c3662d9aa83b.zip
x11/florence: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--x11/florence/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/x11/florence/Makefile b/x11/florence/Makefile
index b777b10f8022..be1b2286fbd9 100644
--- a/x11/florence/Makefile
+++ b/x11/florence/Makefile
@@ -14,12 +14,15 @@ LICENSE_COMB= multi
LIB_DEPENDS= libnotify.so:devel/libnotify
USES= gmake gnome gstreamer iconv libtool pathfix pkgconfig tar:bzip2 xorg
-USE_XORG= xtst xext
USE_GNOME= gtk30 cairo intlhack librsvg2
+USE_LDCONFIG= yes
+USE_XORG= xtst xext
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --without-docs
-USE_LDCONFIG= yes
+
GLIB_SCHEMAS= org.florence.gschema.xml
+
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
@@ -32,6 +35,12 @@ OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|^Categories=.*|Categories=Application;Accessibility;System;|' \
${WRKSRC}/data/florence.desktop.in.in