aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-10 04:58:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-10 04:59:40 +0000
commit2047cad563933a282463f713e47d58ccc09fb645 (patch)
tree3940540e1a9bf05bd618d434967c58789be927f0
parent06adb14f7c14ce3a6b1b79212ecb5e669a39425a (diff)
lang/ruby33: Update to 3.3.4
-rw-r--r--Mk/Uses/ruby.mk2
-rw-r--r--lang/ruby33/Makefile3
-rw-r--r--lang/ruby33/distinfo6
-rw-r--r--lang/ruby33/files/patch-tool_rbinstall.rb24
4 files changed, 20 insertions, 15 deletions
diff --git a/Mk/Uses/ruby.mk b/Mk/Uses/ruby.mk
index 032f8ff2fbda..f4e3ce92d388 100644
--- a/Mk/Uses/ruby.mk
+++ b/Mk/Uses/ruby.mk
@@ -162,7 +162,7 @@ RUBY_PORTREVISION= 0
#
# Ruby 3.3
#
-RUBY_DISTVERSION= 3.3.3
+RUBY_DISTVERSION= 3.3.4
RUBY_PORTREVISION= 0
# When adding a version, please keep the comment in
diff --git a/lang/ruby33/Makefile b/lang/ruby33/Makefile
index c861bdf7f083..0fd86ed469b7 100644
--- a/lang/ruby33/Makefile
+++ b/lang/ruby33/Makefile
@@ -1,6 +1,5 @@
PORTNAME= ruby
-DISTVERSION= ${RUBY_DISTVERSION}
-PORTREVISION= ${RUBY_PORTREVISION}
+PORTVERSION= ${RUBY_DISTVERSION}
PORTEPOCH= ${RUBY_PORTEPOCH}
CATEGORIES= lang ruby
MASTER_SITES= RUBY/${MASTER_SITE_SUBDIR_RUBY}
diff --git a/lang/ruby33/distinfo b/lang/ruby33/distinfo
index 1c9241239dfc..035beec17d76 100644
--- a/lang/ruby33/distinfo
+++ b/lang/ruby33/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1718163101
-SHA256 (ruby/ruby-3.3.3.tar.xz) = 83c0995388399c9555bad87e70af069755b5a9d84bbaa74aa22d1e37ff70fc1e
-SIZE (ruby/ruby-3.3.3.tar.xz) = 16361160
+TIMESTAMP = 1720536562
+SHA256 (ruby/ruby-3.3.4.tar.xz) = 1caaee9a5a6befef54bab67da68ace8d985e4fb59cd17ce23c28d9ab04f4ddad
+SIZE (ruby/ruby-3.3.4.tar.xz) = 16366580
diff --git a/lang/ruby33/files/patch-tool_rbinstall.rb b/lang/ruby33/files/patch-tool_rbinstall.rb
index bc9ed5129c9a..2c414079bb59 100644
--- a/lang/ruby33/files/patch-tool_rbinstall.rb
+++ b/lang/ruby33/files/patch-tool_rbinstall.rb
@@ -1,6 +1,6 @@
---- tool/rbinstall.rb.orig 2024-05-30 00:23:11 UTC
+--- tool/rbinstall.rb.orig 2024-07-08 23:28:22 UTC
+++ tool/rbinstall.rb
-@@ -970,169 +970,6 @@ end
+@@ -970,175 +970,6 @@ end
# :startdoc:
@@ -121,16 +121,22 @@
- File.foreach("#{srcdir}/gems/bundled_gems") do |name|
- next if /^\s*(?:#|$)/ =~ name
- next unless /^(\S+)\s+(\S+).*/ =~ name
+- gem = $1
- gem_name = "#$1-#$2"
-- # Try to find the gemspec file for C ext gems
-- # ex .bundle/gems/debug-1.7.1/debug-1.7.1.gemspec
-- # This gemspec keep the original dependencies
-- path = "#{srcdir}/.bundle/gems/#{gem_name}/#{gem_name}.gemspec"
+- # Try to find the original gemspec file
+- path = "#{srcdir}/.bundle/gems/#{gem_name}/#{gem}.gemspec"
- unless File.exist?(path)
-- path = "#{srcdir}/.bundle/specifications/#{gem_name}.gemspec"
+- # Try to find the gemspec file for C ext gems
+- # ex .bundle/gems/debug-1.7.1/debug-1.7.1.gemspec
+- # This gemspec keep the original dependencies
+- path = "#{srcdir}/.bundle/gems/#{gem_name}/#{gem_name}.gemspec"
- unless File.exist?(path)
-- skipped[gem_name] = "gemspec not found"
-- next
+- # Try to find the gemspec file for gems that hasn't own gemspec
+- path = "#{srcdir}/.bundle/specifications/#{gem_name}.gemspec"
+- unless File.exist?(path)
+- skipped[gem_name] = "gemspec not found"
+- next
+- end
- end
- end
- spec = load_gemspec(path, "#{srcdir}/.bundle/gems/#{gem_name}")