aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-08-10 11:19:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-08-10 11:19:00 +0000
commit20c44243c483cda921aba0a776c90ab3f3a284b0 (patch)
tree030c7e595924ef55436d4ba433926575a297f623
parent33fb6bd864f5f7b24a56fea47024830f3e6079f6 (diff)
downloadports-20c44243c483cda921aba0a776c90ab3f3a284b0.tar.gz
ports-20c44243c483cda921aba0a776c90ab3f3a284b0.zip
misc/mc{,-nox11}: slightly improve the ports' Makefiles (+)
- Do not globally pollute -I/-L with ${LOCALBASE} when handling the NLS option and pass it as the --with-libintl-prefix instead - Drop no longer supported --with-slang-includes configure switch, correct paths are obtained via pkgconf(1) these days - Set PKGNAMESUFFIX together with CONFLICTS_INSTALL in the master so they are always coherent (previously, when the main port is built with X11 option unset it would conflict with itself)
-rw-r--r--misc/mc-nox11/Makefile1
-rw-r--r--misc/mc/Makefile11
2 files changed, 5 insertions, 7 deletions
diff --git a/misc/mc-nox11/Makefile b/misc/mc-nox11/Makefile
index 1a74dea58767..6f1710a2814a 100644
--- a/misc/mc-nox11/Makefile
+++ b/misc/mc-nox11/Makefile
@@ -1,5 +1,4 @@
MASTERDIR= ${.CURDIR}/../mc
-PKGNAMESUFFIX= -nox11
OPTIONS_EXCLUDE= X11
.include "${MASTERDIR}/Makefile"
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 5e3d88d214c6..1bee416199cd 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -53,16 +53,15 @@ ICONV_CONFIGURE_ENABLE= charset
NCURSES_CONFIGURE_ON= --with-screen=ncurses
NCURSES_CFLAGS+= -DNCURSES_WIDECHAR
-NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --disable-nls
NLS_USES= gettext
-NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib
SFTP_LIB_DEPENDS= libssh2.so:security/libssh2
SFTP_CONFIGURE_ENABLE= vfs-sftp
SLANG_LIB_DEPENDS= libslang.so:devel/libslang2
-SLANG_CONFIGURE_ON= --with-screen=slang --with-slang-includes=${LOCALBASE}/include
+SLANG_CONFIGURE_ON= --with-screen=slang
SUBSHELL_CONFIGURE_WITH=subshell
SUBSHELL_SUB_FILES= pkg-message
@@ -70,8 +69,8 @@ SUBSHELL_SUB_FILES= pkg-message
X11_CONFIGURE_WITH= x
X11_USES= xorg
X11_USE= xorg=x11,xext
-X11_VARS= CONFLICTS_INSTALL+="mc-nox11"
-X11_VARS_OFF= CONFLICTS_INSTALL+="mc"
+X11_VARS= CONFLICTS_INSTALL=mc-nox11
+X11_VARS_OFF= CONFLICTS_INSTALL=mc PKGNAMESUFFIX=-nox11
post-patch:
@${REINPLACE_CMD} -e 's|clang||' ${WRKSRC}/configure