aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2022-09-21 22:27:59 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2022-09-22 00:04:20 +0000
commit2119296169cbb2147e71ee926bbdfa985756446b (patch)
treebd2f03480e58c7a9cfe2b7f4062174ab2da0305a
parent1e9566c8f3561fe361734f46562824fe99d27c59 (diff)
audio/spotify-player: Move CARGO_CRATES list to Makefile.crates
Mk/Uses/cargo.mk looks for Makefile.crates in MASTERDIR, so move the list of CARGO_CRATES there to have a smaller and cleaner Makefile and to make updates easier with make cargo-crates > Makefile.crates. Reported by: eduardo Approved by: jfree (maintainer) Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D36662
-rw-r--r--audio/spotify-player/Makefile458
-rw-r--r--audio/spotify-player/Makefile.crates457
2 files changed, 457 insertions, 458 deletions
diff --git a/audio/spotify-player/Makefile b/audio/spotify-player/Makefile
index dd0c04866888..4d82185f03c9 100644
--- a/audio/spotify-player/Makefile
+++ b/audio/spotify-player/Makefile
@@ -17,464 +17,6 @@ USES= cargo ssl
USE_GITHUB= yes
GH_ACCOUNT= aome510
-CARGO_CRATES= addr2line-0.17.0 \
- adler-1.0.2 \
- adler32-1.2.0 \
- aes-0.6.0 \
- aes-ctr-0.6.0 \
- aes-soft-0.6.4 \
- aesni-0.10.0 \
- ahash-0.7.6 \
- aho-corasick-0.7.18 \
- alsa-0.6.0 \
- alsa-sys-0.3.1 \
- android_system_properties-0.1.5 \
- ansi_colours-1.1.1 \
- ansi_term-0.12.1 \
- anyhow-1.0.63 \
- array-init-2.0.1 \
- arrayref-0.3.6 \
- arrayvec-0.5.2 \
- async-stream-0.3.3 \
- async-stream-impl-0.3.3 \
- async-trait-0.1.57 \
- atty-0.2.14 \
- autocfg-1.1.0 \
- backtrace-0.3.66 \
- base64-0.13.0 \
- bindgen-0.59.2 \
- bit_field-0.10.1 \
- bitflags-1.3.2 \
- block-0.1.6 \
- block-buffer-0.9.0 \
- block-buffer-0.10.2 \
- bumpalo-3.11.0 \
- bytemuck-1.12.1 \
- byteorder-1.4.3 \
- bytes-1.2.1 \
- calloop-0.10.1 \
- cassowary-0.3.0 \
- cc-1.0.73 \
- cesu8-1.1.0 \
- cexpr-0.6.0 \
- cfg-expr-0.10.3 \
- cfg-if-1.0.0 \
- chrono-0.4.22 \
- cipher-0.2.5 \
- clang-sys-1.3.3 \
- clap-3.2.19 \
- clap_lex-0.2.4 \
- cmake-0.1.48 \
- cocoa-0.24.0 \
- cocoa-foundation-0.1.0 \
- color_quant-1.1.0 \
- combine-4.6.6 \
- config_parser2-0.1.3 \
- config_parser_derive-0.1.1 \
- console-0.15.1 \
- core-foundation-0.9.3 \
- core-foundation-sys-0.8.3 \
- core-graphics-0.22.3 \
- core-graphics-types-0.1.1 \
- core-text-19.2.0 \
- coreaudio-rs-0.10.0 \
- coreaudio-sys-0.2.10 \
- cpal-0.13.5 \
- cpufeatures-0.2.4 \
- crc32fast-1.3.2 \
- crossbeam-channel-0.5.6 \
- crossbeam-deque-0.8.2 \
- crossbeam-epoch-0.9.10 \
- crossbeam-utils-0.8.11 \
- crossfont-0.5.0 \
- crossterm-0.23.2 \
- crossterm-0.25.0 \
- crossterm_winapi-0.9.0 \
- crypto-common-0.1.6 \
- crypto-mac-0.11.1 \
- ctr-0.6.0 \
- cty-0.2.2 \
- darling-0.13.4 \
- darling_core-0.13.4 \
- darling_macro-0.13.4 \
- dbus-0.9.6 \
- dbus-crossroads-0.5.1 \
- deflate-1.0.0 \
- digest-0.9.0 \
- digest-0.10.3 \
- dirs-next-2.0.0 \
- dirs-sys-next-0.1.2 \
- dispatch-0.2.0 \
- dlib-0.5.0 \
- downcast-rs-1.2.0 \
- dwrote-0.11.0 \
- either-1.8.0 \
- encode_unicode-0.3.6 \
- encoding_rs-0.8.31 \
- env_logger-0.9.0 \
- expat-sys-2.1.6 \
- exr-1.5.0 \
- fastrand-1.8.0 \
- fixedbitset-0.4.2 \
- flate2-1.0.24 \
- flume-0.10.14 \
- fnv-1.0.7 \
- foreign-types-0.3.2 \
- foreign-types-0.5.0 \
- foreign-types-macros-0.2.2 \
- foreign-types-shared-0.1.1 \
- foreign-types-shared-0.3.1 \
- form_urlencoded-1.0.1 \
- freetype-rs-0.26.0 \
- freetype-sys-0.13.1 \
- futf-0.1.5 \
- futures-0.3.24 \
- futures-channel-0.3.24 \
- futures-core-0.3.24 \
- futures-executor-0.3.24 \
- futures-io-0.3.24 \
- futures-macro-0.3.24 \
- futures-sink-0.3.24 \
- futures-task-0.3.24 \
- futures-util-0.3.24 \
- generic-array-0.14.6 \
- getrandom-0.1.16 \
- getrandom-0.2.7 \
- gif-0.11.4 \
- gimli-0.26.2 \
- glib-0.15.12 \
- glib-macros-0.15.11 \
- glib-sys-0.15.10 \
- glob-0.3.0 \
- gobject-sys-0.15.10 \
- gstreamer-0.18.8 \
- gstreamer-app-0.18.7 \
- gstreamer-app-sys-0.18.0 \
- gstreamer-audio-0.18.7 \
- gstreamer-audio-sys-0.18.3 \
- gstreamer-base-0.18.0 \
- gstreamer-base-sys-0.18.0 \
- gstreamer-sys-0.18.0 \
- h2-0.3.14 \
- half-1.8.2 \
- hashbrown-0.12.3 \
- headers-0.3.7 \
- headers-core-0.2.0 \
- heck-0.4.0 \
- hermit-abi-0.1.19 \
- hmac-0.11.0 \
- hostname-0.3.1 \
- html5ever-0.25.2 \
- http-0.2.8 \
- http-body-0.4.5 \
- httparse-1.8.0 \
- httpdate-1.0.2 \
- humantime-2.1.0 \
- hyper-0.14.20 \
- hyper-proxy-0.9.1 \
- hyper-tls-0.5.0 \
- iana-time-zone-0.1.47 \
- ident_case-1.0.1 \
- idna-0.2.3 \
- if-addrs-0.7.0 \
- image-0.24.3 \
- indexmap-1.9.1 \
- instant-0.1.12 \
- ipnet-2.5.0 \
- itoa-1.0.3 \
- jack-0.8.3 \
- jack-0.10.0 \
- jack-sys-0.2.2 \
- jack-sys-0.4.0 \
- jni-0.19.0 \
- jni-sys-0.3.0 \
- jobserver-0.1.24 \
- jpeg-decoder-0.2.6 \
- js-sys-0.3.59 \
- lazy_static-1.4.0 \
- lazycell-1.3.0 \
- lebe-0.5.2 \
- lewton-0.10.2 \
- libc-0.2.132 \
- libdbus-sys-0.2.2 \
- libloading-0.6.7 \
- libloading-0.7.3 \
- libm-0.2.5 \
- libmdns-0.7.1 \
- libpulse-binding-2.26.0 \
- libpulse-simple-binding-2.25.0 \
- libpulse-simple-sys-1.19.2 \
- libpulse-sys-1.19.3 \
- librespot-audio-0.4.2 \
- librespot-connect-0.4.2 \
- librespot-core-0.4.2 \
- librespot-discovery-0.4.2 \
- librespot-metadata-0.4.2 \
- librespot-playback-0.4.2 \
- librespot-protocol-0.4.2 \
- lock_api-0.4.8 \
- log-0.4.17 \
- lru-0.7.8 \
- mac-0.1.1 \
- mach-0.3.2 \
- malloc_buf-0.0.6 \
- markup5ever-0.10.1 \
- markup5ever_rcdom-0.1.0 \
- match_cfg-0.1.0 \
- matchers-0.1.0 \
- matches-0.1.9 \
- maybe-async-0.2.6 \
- memchr-2.5.0 \
- memmap2-0.5.7 \
- memoffset-0.6.5 \
- mime-0.3.16 \
- minimal-lexical-0.2.1 \
- miniz_oxide-0.5.3 \
- mio-0.8.4 \
- muldiv-1.0.0 \
- multimap-0.8.3 \
- nanorand-0.7.0 \
- native-tls-0.2.10 \
- ndk-0.6.0 \
- ndk-0.7.0 \
- ndk-context-0.1.1 \
- ndk-glue-0.6.2 \
- ndk-glue-0.7.0 \
- ndk-macro-0.3.0 \
- ndk-sys-0.3.0 \
- ndk-sys-0.4.0 \
- new_debug_unreachable-1.0.4 \
- nix-0.23.1 \
- nix-0.24.2 \
- nom-7.1.1 \
- num-bigint-0.4.3 \
- num-derive-0.3.3 \
- num-integer-0.1.45 \
- num-rational-0.4.1 \
- num-traits-0.2.15 \
- num_cpus-1.13.1 \
- num_enum-0.5.7 \
- num_enum_derive-0.5.7 \
- objc-0.2.7 \
- object-0.29.0 \
- oboe-0.4.6 \
- oboe-sys-0.4.5 \
- ogg-0.8.0 \
- once_cell-1.13.1 \
- opaque-debug-0.3.0 \
- openssl-0.10.41 \
- openssl-macros-0.1.0 \
- openssl-probe-0.1.5 \
- openssl-sys-0.9.75 \
- option-operations-0.4.1 \
- os_str_bytes-6.3.0 \
- parking_lot-0.11.2 \
- parking_lot-0.12.1 \
- parking_lot_core-0.8.5 \
- parking_lot_core-0.9.3 \
- paste-1.0.9 \
- pbkdf2-0.8.0 \
- peeking_take_while-0.1.2 \
- percent-encoding-2.1.0 \
- petgraph-0.6.2 \
- phf-0.8.0 \
- phf_codegen-0.8.0 \
- phf_generator-0.8.0 \
- phf_generator-0.10.0 \
- phf_shared-0.8.0 \
- phf_shared-0.10.0 \
- pin-project-1.0.12 \
- pin-project-internal-1.0.12 \
- pin-project-lite-0.2.9 \
- pin-utils-0.1.0 \
- pkg-config-0.3.25 \
- png-0.17.5 \
- portaudio-rs-0.3.2 \
- portaudio-sys-0.1.1 \
- ppv-lite86-0.2.16 \
- precomputed-hash-0.1.1 \
- pretty-hex-0.3.0 \
- priority-queue-1.2.3 \
- proc-macro-crate-1.2.1 \
- proc-macro-error-1.0.4 \
- proc-macro-error-attr-1.0.4 \
- proc-macro2-1.0.43 \
- protobuf-2.27.1 \
- protobuf-codegen-2.27.1 \
- protobuf-codegen-pure-2.27.1 \
- quote-1.0.21 \
- rand-0.7.3 \
- rand-0.8.5 \
- rand_chacha-0.2.2 \
- rand_chacha-0.3.1 \
- rand_core-0.5.1 \
- rand_core-0.6.3 \
- rand_distr-0.4.3 \
- rand_hc-0.2.0 \
- rand_pcg-0.2.1 \
- raw-window-handle-0.4.3 \
- raw-window-handle-0.5.0 \
- rayon-1.5.3 \
- rayon-core-1.9.3 \
- redox_syscall-0.2.16 \
- redox_users-0.4.3 \
- regex-1.6.0 \
- regex-automata-0.1.10 \
- regex-syntax-0.6.27 \
- remove_dir_all-0.5.3 \
- reqwest-0.11.11 \
- rgb-0.8.33 \
- rodio-0.15.0 \
- rpassword-7.0.0 \
- rspotify-0.11.5 \
- rspotify-http-0.11.5 \
- rspotify-macros-0.11.5 \
- rspotify-model-0.11.5 \
- rustc-demangle-0.1.21 \
- rustc-hash-1.1.0 \
- rustc-serialize-0.3.24 \
- rustc_version-0.4.0 \
- rustversion-1.0.9 \
- ryu-1.0.11 \
- safe_arch-0.5.2 \
- same-file-1.0.6 \
- schannel-0.1.20 \
- scoped-tls-1.0.0 \
- scoped_threadpool-0.1.9 \
- scopeguard-1.1.0 \
- sctk-adwaita-0.4.2 \
- sdl2-0.35.2 \
- sdl2-sys-0.35.2 \
- security-framework-2.7.0 \
- security-framework-sys-2.6.1 \
- semver-1.0.13 \
- serde-1.0.144 \
- serde_derive-1.0.144 \
- serde_json-1.0.85 \
- serde_urlencoded-0.7.1 \
- servo-fontconfig-0.5.1 \
- servo-fontconfig-sys-5.1.0 \
- sha-1-0.9.8 \
- sha-1-0.10.0 \
- sha2-0.10.3 \
- shannon-0.2.0 \
- sharded-slab-0.1.4 \
- shell-words-1.1.0 \
- shlex-1.1.0 \
- signal-hook-0.3.14 \
- signal-hook-mio-0.2.3 \
- signal-hook-registry-1.4.0 \
- siphasher-0.3.10 \
- slab-0.4.7 \
- slotmap-1.0.6 \
- smallvec-1.9.0 \
- smithay-client-toolkit-0.16.0 \
- socket2-0.4.7 \
- souvlaki-0.5.2 \
- spin-0.9.4 \
- stdweb-0.1.3 \
- string_cache-0.8.4 \
- string_cache_codegen-0.5.2 \
- strsim-0.10.0 \
- strum-0.24.1 \
- strum_macros-0.24.3 \
- subtle-2.4.1 \
- syn-1.0.99 \
- synstructure-0.12.6 \
- system-deps-6.0.2 \
- tempfile-3.3.0 \
- tendril-0.4.3 \
- termcolor-1.1.3 \
- terminal_size-0.1.17 \
- textwrap-0.15.0 \
- thiserror-1.0.33 \
- thiserror-impl-1.0.33 \
- thread-id-4.0.0 \
- thread_local-1.1.4 \
- threadpool-1.8.1 \
- tiff-0.7.3 \
- time-0.1.44 \
- tiny-skia-0.7.0 \
- tiny-skia-path-0.7.0 \
- tinyvec-1.6.0 \
- tinyvec_macros-0.1.0 \
- tokio-1.20.1 \
- tokio-macros-1.8.0 \
- tokio-native-tls-0.3.0 \
- tokio-socks-0.5.1 \
- tokio-stream-0.1.9 \
- tokio-util-0.7.3 \
- toml-0.5.9 \
- tower-service-0.3.2 \
- tracing-0.1.36 \
- tracing-attributes-0.1.22 \
- tracing-core-0.1.29 \
- tracing-log-0.1.3 \
- tracing-subscriber-0.3.15 \
- try-lock-0.2.3 \
- tui-0.19.0 \
- typenum-1.15.0 \
- unicode-bidi-0.3.8 \
- unicode-ident-1.0.3 \
- unicode-normalization-0.1.21 \
- unicode-segmentation-1.9.0 \
- unicode-width-0.1.9 \
- unicode-xid-0.2.3 \
- url-2.2.2 \
- utf-8-0.7.6 \
- uuid-1.1.2 \
- valuable-0.1.0 \
- vcpkg-0.2.15 \
- vec_map-0.8.2 \
- vergen-3.2.0 \
- version-compare-0.1.0 \
- version_check-0.9.4 \
- viuer-0.6.1 \
- walkdir-2.3.2 \
- want-0.3.0 \
- wasi-0.9.0+wasi-snapshot-preview1 \
- wasi-0.10.0+wasi-snapshot-preview1 \
- wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.82 \
- wasm-bindgen-backend-0.2.82 \
- wasm-bindgen-futures-0.4.32 \
- wasm-bindgen-macro-0.2.82 \
- wasm-bindgen-macro-support-0.2.82 \
- wasm-bindgen-shared-0.2.82 \
- wayland-client-0.29.5 \
- wayland-commons-0.29.5 \
- wayland-cursor-0.29.5 \
- wayland-protocols-0.29.5 \
- wayland-scanner-0.29.5 \
- wayland-sys-0.29.5 \
- web-sys-0.3.59 \
- weezl-0.1.7 \
- winapi-0.3.9 \
- winapi-i686-pc-windows-gnu-0.4.0 \
- winapi-util-0.1.5 \
- winapi-x86_64-pc-windows-gnu-0.4.0 \
- windows-0.39.0 \
- windows-sys-0.36.1 \
- windows_aarch64_msvc-0.36.1 \
- windows_aarch64_msvc-0.39.0 \
- windows_i686_gnu-0.36.1 \
- windows_i686_gnu-0.39.0 \
- windows_i686_msvc-0.36.1 \
- windows_i686_msvc-0.39.0 \
- windows_x86_64_gnu-0.36.1 \
- windows_x86_64_gnu-0.39.0 \
- windows_x86_64_msvc-0.36.1 \
- windows_x86_64_msvc-0.39.0 \
- winit-0.27.2 \
- winreg-0.10.1 \
- wio-0.2.2 \
- x11-dl-2.20.0 \
- xcursor-0.3.4 \
- xml-rs-0.8.4 \
- xml5ever-0.16.2 \
- zerocopy-0.6.1 \
- zerocopy-derive-0.3.1
-
CARGO_CARGOTOML= ${WRKSRC}/spotify_player/Cargo.toml
CARGO_FEATURES= --no-default-features
CARGO_INSTALL_PATH= ./spotify_player
diff --git a/audio/spotify-player/Makefile.crates b/audio/spotify-player/Makefile.crates
new file mode 100644
index 000000000000..23d757cfafeb
--- /dev/null
+++ b/audio/spotify-player/Makefile.crates
@@ -0,0 +1,457 @@
+CARGO_CRATES= addr2line-0.17.0 \
+ adler-1.0.2 \
+ adler32-1.2.0 \
+ aes-0.6.0 \
+ aes-ctr-0.6.0 \
+ aes-soft-0.6.4 \
+ aesni-0.10.0 \
+ ahash-0.7.6 \
+ aho-corasick-0.7.18 \
+ alsa-0.6.0 \
+ alsa-sys-0.3.1 \
+ android_system_properties-0.1.5 \
+ ansi_colours-1.1.1 \
+ ansi_term-0.12.1 \
+ anyhow-1.0.63 \
+ array-init-2.0.1 \
+ arrayref-0.3.6 \
+ arrayvec-0.5.2 \
+ async-stream-0.3.3 \
+ async-stream-impl-0.3.3 \
+ async-trait-0.1.57 \
+ atty-0.2.14 \
+ autocfg-1.1.0 \
+ backtrace-0.3.66 \
+ base64-0.13.0 \
+ bindgen-0.59.2 \
+ bit_field-0.10.1 \
+ bitflags-1.3.2 \
+ block-0.1.6 \
+ block-buffer-0.9.0 \
+ block-buffer-0.10.2 \
+ bumpalo-3.11.0 \
+ bytemuck-1.12.1 \
+ byteorder-1.4.3 \
+ bytes-1.2.1 \
+ calloop-0.10.1 \
+ cassowary-0.3.0 \
+ cc-1.0.73 \
+ cesu8-1.1.0 \
+ cexpr-0.6.0 \
+ cfg-expr-0.10.3 \
+ cfg-if-1.0.0 \
+ chrono-0.4.22 \
+ cipher-0.2.5 \
+ clang-sys-1.3.3 \
+ clap-3.2.19 \
+ clap_lex-0.2.4 \
+ cmake-0.1.48 \
+ cocoa-0.24.0 \
+ cocoa-foundation-0.1.0 \
+ color_quant-1.1.0 \
+ combine-4.6.6 \
+ config_parser2-0.1.3 \
+ config_parser_derive-0.1.1 \
+ console-0.15.1 \
+ core-foundation-0.9.3 \
+ core-foundation-sys-0.8.3 \
+ core-graphics-0.22.3 \
+ core-graphics-types-0.1.1 \
+ core-text-19.2.0 \
+ coreaudio-rs-0.10.0 \
+ coreaudio-sys-0.2.10 \
+ cpal-0.13.5 \
+ cpufeatures-0.2.4 \
+ crc32fast-1.3.2 \
+ crossbeam-channel-0.5.6 \
+ crossbeam-deque-0.8.2 \
+ crossbeam-epoch-0.9.10 \
+ crossbeam-utils-0.8.11 \
+ crossfont-0.5.0 \
+ crossterm-0.23.2 \
+ crossterm-0.25.0 \
+ crossterm_winapi-0.9.0 \
+ crypto-common-0.1.6 \
+ crypto-mac-0.11.1 \
+ ctr-0.6.0 \
+ cty-0.2.2 \
+ darling-0.13.4 \
+ darling_core-0.13.4 \
+ darling_macro-0.13.4 \
+ dbus-0.9.6 \
+ dbus-crossroads-0.5.1 \
+ deflate-1.0.0 \
+ digest-0.9.0 \
+ digest-0.10.3 \
+ dirs-next-2.0.0 \
+ dirs-sys-next-0.1.2 \
+ dispatch-0.2.0 \
+ dlib-0.5.0 \
+ downcast-rs-1.2.0 \
+ dwrote-0.11.0 \
+ either-1.8.0 \
+ encode_unicode-0.3.6 \
+ encoding_rs-0.8.31 \
+ env_logger-0.9.0 \
+ expat-sys-2.1.6 \
+ exr-1.5.0 \
+ fastrand-1.8.0 \
+ fixedbitset-0.4.2 \
+ flate2-1.0.24 \
+ flume-0.10.14 \
+ fnv-1.0.7 \
+ foreign-types-0.3.2 \
+ foreign-types-0.5.0 \
+ foreign-types-macros-0.2.2 \
+ foreign-types-shared-0.1.1 \
+ foreign-types-shared-0.3.1 \
+ form_urlencoded-1.0.1 \
+ freetype-rs-0.26.0 \
+ freetype-sys-0.13.1 \
+ futf-0.1.5 \
+ futures-0.3.24 \
+ futures-channel-0.3.24 \
+ futures-core-0.3.24 \
+ futures-executor-0.3.24 \
+ futures-io-0.3.24 \
+ futures-macro-0.3.24 \
+ futures-sink-0.3.24 \
+ futures-task-0.3.24 \
+ futures-util-0.3.24 \
+ generic-array-0.14.6 \
+ getrandom-0.1.16 \
+ getrandom-0.2.7 \
+ gif-0.11.4 \
+ gimli-0.26.2 \
+ glib-0.15.12 \
+ glib-macros-0.15.11 \
+ glib-sys-0.15.10 \
+ glob-0.3.0 \
+ gobject-sys-0.15.10 \
+ gstreamer-0.18.8 \
+ gstreamer-app-0.18.7 \
+ gstreamer-app-sys-0.18.0 \
+ gstreamer-audio-0.18.7 \
+ gstreamer-audio-sys-0.18.3 \
+ gstreamer-base-0.18.0 \
+ gstreamer-base-sys-0.18.0 \
+ gstreamer-sys-0.18.0 \
+ h2-0.3.14 \
+ half-1.8.2 \
+ hashbrown-0.12.3 \
+ headers-0.3.7 \
+ headers-core-0.2.0 \
+ heck-0.4.0 \
+ hermit-abi-0.1.19 \
+ hmac-0.11.0 \
+ hostname-0.3.1 \
+ html5ever-0.25.2 \
+ http-0.2.8 \
+ http-body-0.4.5 \
+ httparse-1.8.0 \
+ httpdate-1.0.2 \
+ humantime-2.1.0 \
+ hyper-0.14.20 \
+ hyper-proxy-0.9.1 \
+ hyper-tls-0.5.0 \
+ iana-time-zone-0.1.47 \
+ ident_case-1.0.1 \
+ idna-0.2.3 \
+ if-addrs-0.7.0 \
+ image-0.24.3 \
+ indexmap-1.9.1 \
+ instant-0.1.12 \
+ ipnet-2.5.0 \
+ itoa-1.0.3 \
+ jack-0.8.3 \
+ jack-0.10.0 \
+ jack-sys-0.2.2 \
+ jack-sys-0.4.0 \
+ jni-0.19.0 \
+ jni-sys-0.3.0 \
+ jobserver-0.1.24 \
+ jpeg-decoder-0.2.6 \
+ js-sys-0.3.59 \
+ lazy_static-1.4.0 \
+ lazycell-1.3.0 \
+ lebe-0.5.2 \
+ lewton-0.10.2 \
+ libc-0.2.132 \
+ libdbus-sys-0.2.2 \
+ libloading-0.6.7 \
+ libloading-0.7.3 \
+ libm-0.2.5 \
+ libmdns-0.7.1 \
+ libpulse-binding-2.26.0 \
+ libpulse-simple-binding-2.25.0 \
+ libpulse-simple-sys-1.19.2 \
+ libpulse-sys-1.19.3 \
+ librespot-audio-0.4.2 \
+ librespot-connect-0.4.2 \
+ librespot-core-0.4.2 \
+ librespot-discovery-0.4.2 \
+ librespot-metadata-0.4.2 \
+ librespot-playback-0.4.2 \
+ librespot-protocol-0.4.2 \
+ lock_api-0.4.8 \
+ log-0.4.17 \
+ lru-0.7.8 \
+ mac-0.1.1 \
+ mach-0.3.2 \
+ malloc_buf-0.0.6 \
+ markup5ever-0.10.1 \
+ markup5ever_rcdom-0.1.0 \
+ match_cfg-0.1.0 \
+ matchers-0.1.0 \
+ matches-0.1.9 \
+ maybe-async-0.2.6 \
+ memchr-2.5.0 \
+ memmap2-0.5.7 \
+ memoffset-0.6.5 \
+ mime-0.3.16 \
+ minimal-lexical-0.2.1 \
+ miniz_oxide-0.5.3 \
+ mio-0.8.4 \
+ muldiv-1.0.0 \
+ multimap-0.8.3 \
+ nanorand-0.7.0 \
+ native-tls-0.2.10 \
+ ndk-0.6.0 \
+ ndk-0.7.0 \
+ ndk-context-0.1.1 \
+ ndk-glue-0.6.2 \
+ ndk-glue-0.7.0 \
+ ndk-macro-0.3.0 \
+ ndk-sys-0.3.0 \
+ ndk-sys-0.4.0 \
+ new_debug_unreachable-1.0.4 \
+ nix-0.23.1 \
+ nix-0.24.2 \
+ nom-7.1.1 \
+ num-bigint-0.4.3 \
+ num-derive-0.3.3 \
+ num-integer-0.1.45 \
+ num-rational-0.4.1 \
+ num-traits-0.2.15 \
+ num_cpus-1.13.1 \
+ num_enum-0.5.7 \
+ num_enum_derive-0.5.7 \
+ objc-0.2.7 \
+ object-0.29.0 \
+ oboe-0.4.6 \
+ oboe-sys-0.4.5 \
+ ogg-0.8.0 \
+ once_cell-1.13.1 \
+ opaque-debug-0.3.0 \
+ openssl-0.10.41 \
+ openssl-macros-0.1.0 \
+ openssl-probe-0.1.5 \
+ openssl-sys-0.9.75 \
+ option-operations-0.4.1 \
+ os_str_bytes-6.3.0 \
+ parking_lot-0.11.2 \
+ parking_lot-0.12.1 \
+ parking_lot_core-0.8.5 \
+ parking_lot_core-0.9.3 \
+ paste-1.0.9 \
+ pbkdf2-0.8.0 \
+ peeking_take_while-0.1.2 \
+ percent-encoding-2.1.0 \
+ petgraph-0.6.2 \
+ phf-0.8.0 \
+ phf_codegen-0.8.0 \
+ phf_generator-0.8.0 \
+ phf_generator-0.10.0 \
+ phf_shared-0.8.0 \
+ phf_shared-0.10.0 \
+ pin-project-1.0.12 \
+ pin-project-internal-1.0.12 \
+ pin-project-lite-0.2.9 \
+ pin-utils-0.1.0 \
+ pkg-config-0.3.25 \
+ png-0.17.5 \
+ portaudio-rs-0.3.2 \
+ portaudio-sys-0.1.1 \
+ ppv-lite86-0.2.16 \
+ precomputed-hash-0.1.1 \
+ pretty-hex-0.3.0 \
+ priority-queue-1.2.3 \
+ proc-macro-crate-1.2.1 \
+ proc-macro-error-1.0.4 \
+ proc-macro-error-attr-1.0.4 \
+ proc-macro2-1.0.43 \
+ protobuf-2.27.1 \
+ protobuf-codegen-2.27.1 \
+ protobuf-codegen-pure-2.27.1 \
+ quote-1.0.21 \
+ rand-0.7.3 \
+ rand-0.8.5 \
+ rand_chacha-0.2.2 \
+ rand_chacha-0.3.1 \
+ rand_core-0.5.1 \
+ rand_core-0.6.3 \
+ rand_distr-0.4.3 \
+ rand_hc-0.2.0 \
+ rand_pcg-0.2.1 \
+ raw-window-handle-0.4.3 \
+ raw-window-handle-0.5.0 \
+ rayon-1.5.3 \
+ rayon-core-1.9.3 \
+ redox_syscall-0.2.16 \
+ redox_users-0.4.3 \
+ regex-1.6.0 \
+ regex-automata-0.1.10 \
+ regex-syntax-0.6.27 \
+ remove_dir_all-0.5.3 \
+ reqwest-0.11.11 \
+ rgb-0.8.33 \
+ rodio-0.15.0 \
+ rpassword-7.0.0 \
+ rspotify-0.11.5 \
+ rspotify-http-0.11.5 \
+ rspotify-macros-0.11.5 \
+ rspotify-model-0.11.5 \
+ rustc-demangle-0.1.21 \
+ rustc-hash-1.1.0 \
+ rustc-serialize-0.3.24 \
+ rustc_version-0.4.0 \
+ rustversion-1.0.9 \
+ ryu-1.0.11 \
+ safe_arch-0.5.2 \
+ same-file-1.0.6 \
+ schannel-0.1.20 \
+ scoped-tls-1.0.0 \
+ scoped_threadpool-0.1.9 \
+ scopeguard-1.1.0 \
+ sctk-adwaita-0.4.2 \
+ sdl2-0.35.2 \
+ sdl2-sys-0.35.2 \
+ security-framework-2.7.0 \
+ security-framework-sys-2.6.1 \
+ semver-1.0.13 \
+ serde-1.0.144 \
+ serde_derive-1.0.144 \
+ serde_json-1.0.85 \
+ serde_urlencoded-0.7.1 \
+ servo-fontconfig-0.5.1 \
+ servo-fontconfig-sys-5.1.0 \
+ sha-1-0.9.8 \
+ sha-1-0.10.0 \
+ sha2-0.10.3 \
+ shannon-0.2.0 \
+ sharded-slab-0.1.4 \
+ shell-words-1.1.0 \
+ shlex-1.1.0 \
+ signal-hook-0.3.14 \
+ signal-hook-mio-0.2.3 \
+ signal-hook-registry-1.4.0 \
+ siphasher-0.3.10 \
+ slab-0.4.7 \
+ slotmap-1.0.6 \
+ smallvec-1.9.0 \
+ smithay-client-toolkit-0.16.0 \
+ socket2-0.4.7 \
+ souvlaki-0.5.2 \
+ spin-0.9.4 \
+ stdweb-0.1.3 \
+ string_cache-0.8.4 \
+ string_cache_codegen-0.5.2 \
+ strsim-0.10.0 \
+ strum-0.24.1 \
+ strum_macros-0.24.3 \
+ subtle-2.4.1 \
+ syn-1.0.99 \
+ synstructure-0.12.6 \
+ system-deps-6.0.2 \
+ tempfile-3.3.0 \
+ tendril-0.4.3 \
+ termcolor-1.1.3 \
+ terminal_size-0.1.17 \
+ textwrap-0.15.0 \
+ thiserror-1.0.33 \
+ thiserror-impl-1.0.33 \
+ thread-id-4.0.0 \
+ thread_local-1.1.4 \
+ threadpool-1.8.1 \
+ tiff-0.7.3 \
+ time-0.1.44 \
+ tiny-skia-0.7.0 \
+ tiny-skia-path-0.7.0 \
+ tinyvec-1.6.0 \
+ tinyvec_macros-0.1.0 \
+ tokio-1.20.1 \
+ tokio-macros-1.8.0 \
+ tokio-native-tls-0.3.0 \
+ tokio-socks-0.5.1 \
+ tokio-stream-0.1.9 \
+ tokio-util-0.7.3 \
+ toml-0.5.9 \
+ tower-service-0.3.2 \
+ tracing-0.1.36 \
+ tracing-attributes-0.1.22 \
+ tracing-core-0.1.29 \
+ tracing-log-0.1.3 \
+ tracing-subscriber-0.3.15 \
+ try-lock-0.2.3 \
+ tui-0.19.0 \
+ typenum-1.15.0 \
+ unicode-bidi-0.3.8 \
+ unicode-ident-1.0.3 \
+ unicode-normalization-0.1.21 \
+ unicode-segmentation-1.9.0 \
+ unicode-width-0.1.9 \
+ unicode-xid-0.2.3 \
+ url-2.2.2 \
+ utf-8-0.7.6 \
+ uuid-1.1.2 \
+ valuable-0.1.0 \
+ vcpkg-0.2.15 \
+ vec_map-0.8.2 \
+ vergen-3.2.0 \
+ version-compare-0.1.0 \
+ version_check-0.9.4 \
+ viuer-0.6.1 \
+ walkdir-2.3.2 \
+ want-0.3.0 \
+ wasi-0.9.0+wasi-snapshot-preview1 \
+ wasi-0.10.0+wasi-snapshot-preview1 \
+ wasi-0.11.0+wasi-snapshot-preview1 \
+ wasm-bindgen-0.2.82 \
+ wasm-bindgen-backend-0.2.82 \
+ wasm-bindgen-futures-0.4.32 \
+ wasm-bindgen-macro-0.2.82 \
+ wasm-bindgen-macro-support-0.2.82 \
+ wasm-bindgen-shared-0.2.82 \
+ wayland-client-0.29.5 \
+ wayland-commons-0.29.5 \
+ wayland-cursor-0.29.5 \
+ wayland-protocols-0.29.5 \
+ wayland-scanner-0.29.5 \
+ wayland-sys-0.29.5 \
+ web-sys-0.3.59 \
+ weezl-0.1.7 \
+ winapi-0.3.9 \
+ winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.5 \
+ winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-0.39.0 \
+ windows-sys-0.36.1 \
+ windows_aarch64_msvc-0.36.1 \
+ windows_aarch64_msvc-0.39.0 \
+ windows_i686_gnu-0.36.1 \
+ windows_i686_gnu-0.39.0 \
+ windows_i686_msvc-0.36.1 \
+ windows_i686_msvc-0.39.0 \
+ windows_x86_64_gnu-0.36.1 \
+ windows_x86_64_gnu-0.39.0 \
+ windows_x86_64_msvc-0.36.1 \
+ windows_x86_64_msvc-0.39.0 \
+ winit-0.27.2 \
+ winreg-0.10.1 \
+ wio-0.2.2 \
+ x11-dl-2.20.0 \
+ xcursor-0.3.4 \
+ xml-rs-0.8.4 \
+ xml5ever-0.16.2 \
+ zerocopy-0.6.1 \
+ zerocopy-derive-0.3.1