aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-06 22:01:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-06 22:38:33 +0000
commit21f418e9aa447a296d36f17aee6837d899fa91c8 (patch)
tree8b93a11781d7c2e0dcb58aba557e27743b67beec
parente38e0e6063c33fc7cea17ca466902ebde17f772f (diff)
downloadports-21f418e9aa447a296d36f17aee6837d899fa91c8.tar.gz
ports-21f418e9aa447a296d36f17aee6837d899fa91c8.zip
devel/py-pytest4-flakes: preserve pytest4 counterpart of corresponding port
PR: 256624
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-flakes/Makefile2
-rw-r--r--devel/py-pytest4-flakes/Makefile23
-rw-r--r--devel/py-pytest4-flakes/distinfo3
-rw-r--r--devel/py-pytest4-flakes/pkg-descr3
5 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7ffd5c6b8c34..5a715245b759 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5111,6 +5111,7 @@
SUBDIR += py-pytest4-asyncio
SUBDIR += py-pytest4-cache
SUBDIR += py-pytest4-cov
+ SUBDIR += py-pytest4-flakes
SUBDIR += py-python-Levenshtein
SUBDIR += py-python-application
SUBDIR += py-python-bugzilla
diff --git a/devel/py-pytest-flakes/Makefile b/devel/py-pytest-flakes/Makefile
index a430cfdfdf9c..46477cfb87d3 100644
--- a/devel/py-pytest-flakes/Makefile
+++ b/devel/py-pytest-flakes/Makefile
@@ -10,6 +10,8 @@ COMMENT= Pytest plugin for efficiently checking python source with pyflakes
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest4-flakes
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+
diff --git a/devel/py-pytest4-flakes/Makefile b/devel/py-pytest4-flakes/Makefile
new file mode 100644
index 000000000000..635f8e37d738
--- /dev/null
+++ b/devel/py-pytest4-flakes/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= pytest4-flakes
+PORTVERSION= 4.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:C/4//}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pytest plugin for efficiently checking python source with pyflakes (legacy version for pytest4)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pytest-flakes
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4>=2.8.0:devel/py-pytest4@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+PYDISTUTILS_PKGNAME= ${PORTNAME:C/4//}
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest4-flakes/distinfo b/devel/py-pytest4-flakes/distinfo
new file mode 100644
index 000000000000..ccb735fc1fce
--- /dev/null
+++ b/devel/py-pytest4-flakes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596049059
+SHA256 (pytest-flakes-4.0.1.tar.gz) = 37113ac6c7ea5e0b648abf73937955a45f8b9214fe49413297c2ce6ce1808500
+SIZE (pytest-flakes-4.0.1.tar.gz) = 7146
diff --git a/devel/py-pytest4-flakes/pkg-descr b/devel/py-pytest4-flakes/pkg-descr
new file mode 100644
index 000000000000..49fc3104ee41
--- /dev/null
+++ b/devel/py-pytest4-flakes/pkg-descr
@@ -0,0 +1,3 @@
+pytest plugin to check source code with pyflakes.
+
+WWW: https://github.com/fschulze/pytest-flakes