aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2022-04-19 11:27:39 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2022-05-04 08:05:33 +0000
commit21f77dd22253ffbe6a16b0367fda3f17c94848ac (patch)
tree7ae675c6e1c70ea59e4307b36dbceb08c006b0d1
parent1c667cc5c2b8ed3e2f36a8912c35054fd8eb7d6d (diff)
downloadports-21f77dd22253ffbe6a16b0367fda3f17c94848ac.tar.gz
ports-21f77dd22253ffbe6a16b0367fda3f17c94848ac.zip
net/rsync: Update to 3.2.4
* Pet portclippy * Tidy up Makefile with portfmt ChangeLog: https://download.samba.org/pub/rsync/NEWS#3.2.4 PR: 263417 Approved by: maintainer timeout
-rw-r--r--net/rsync/Makefile69
-rw-r--r--net/rsync/distinfo10
-rw-r--r--net/rsync/files/patch-io.c27
3 files changed, 39 insertions, 67 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 0f9df25989e8..a558a11d612e 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -1,13 +1,12 @@
# Created by: David O'Brien (obrien@cs.ucdavis.edu)
PORTNAME= rsync
-DISTVERSION= 3.2.3
-PORTREVISION= 1
+DISTVERSION= 3.2.4
CATEGORIES= net
MASTER_SITES= https://www.mirrorservice.org/sites/rsync.samba.org/src/ \
- http://rsync.mirror.garr.it/src/ \
- http://www.mirrorservice.org/sites/rsync.samba.org/src/ \
- https://download.samba.org/pub/rsync/src/
+ http://rsync.mirror.garr.it/src/ \
+ http://www.mirrorservice.org/sites/rsync.samba.org/src/ \
+ https://download.samba.org/pub/rsync/src/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= rodrigo@FreeBSD.org
@@ -16,67 +15,67 @@ COMMENT= Network file distribution/synchronization utility
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libxxhash.so:devel/xxhash \
- libzstd.so:archivers/zstd \
- liblz4.so:archivers/liblz4
-
-USES= cpe shebangfix ssl
-SHEBANG_FILES= support/rrsync
+LIB_DEPENDS= liblz4.so:archivers/liblz4 \
+ libxxhash.so:devel/xxhash \
+ libzstd.so:archivers/zstd
+USES= cpe python shebangfix ssl
CPE_VENDOR= samba
CPE_PRODUCT= rsync
+USE_RC_SUBR= rsyncd
+
+SHEBANG_FILES= support/rrsync
-PATCH_STRIP= -p1
GNU_CONFIGURE= yes
-USE_RC_SUBR= rsyncd
-SUB_LIST= NAME=rsyncd
+CONFIGURE_ARGS= --disable-debug \
+ --enable-ipv6 \
+ --with-rsyncd-conf=${ETCDIR}/rsyncd.conf
INSTALL_TARGET= install-strip
TEST_TARGET= check
-CONFIGURE_ARGS= --disable-debug --enable-ipv6 \
- --with-rsyncd-conf=${ETCDIR}/rsyncd.conf
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+PATCH_STRIP= -p1
+SUB_LIST= NAME=rsyncd
+
PORTDOCS= NEWS.md README.md csprotocol.txt tech_report.tex
# define options
-OPTIONS_DEFINE= DOCS POPT_PORT ZLIB_BASE SSH ICONV
+OPTIONS_DEFINE= DOCS ICONV POPT_PORT SSH ZLIB_BASE
+OPTIONS_DEFAULT= FLAGS ICONV SSH ZLIB_BASE
OPTIONS_RADIO= PTS
-OPTIONS_RADIO_PTS= RENAMED FLAGS
+OPTIONS_RADIO_PTS= FLAGS RENAMED
# options provided upstream
+FLAGS_DESC= File system flags support patch, adds --fileflags
POPT_PORT_DESC= Use popt from devel/popt instead of bundled one
-ZLIB_BASE_DESC= Use zlib from base instead of bundled one
SSH_DESC= Use SSH instead of RSH
+ZLIB_BASE_DESC= Use zlib from base instead of bundled one
# options provided by patch (mutually exclusive)
PTS_DESC= Functionality provided by third party patches
RENAMED_DESC= Add support for renamed file detection
-FLAGS_DESC= File system flags support patch, adds --fileflags
-
-# define default options
-OPTIONS_DEFAULT=FLAGS ICONV SSH ZLIB_BASE
-ZLIB_BASE_CONFIGURE_ON= --with-included-zlib=no
-FLAGS_EXTRA_PATCHES= ${WRKSRC}/patches/fileflags.diff \
- ${FILESDIR}/extrapatch-main.c
-RENAMED_EXTRA_PATCHES= ${WRKSRC}/patches/detect-renamed.diff
+FLAGS_DISTFILES= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
+FLAGS_EXTRA_PATCHES= ${WRKSRC}/patches/fileflags.diff \
+ ${FILESDIR}/extrapatch-main.c
-ICONV_USES= iconv:translit
+ICONV_DISTFILES= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
+ICONV_USES= iconv:translit
ICONV_CONFIGURE_ENABLE= iconv iconv-open
-POPT_PORT_LIB_DEPENDS= libpopt.so:devel/popt
-
+POPT_PORT_LIB_DEPENDS= libpopt.so:devel/popt
POPT_PORT_CONFIGURE_OFF= --with-included-popt
+RENAMED_DISTFILES= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
+RENAMED_EXTRA_PATCHES= ${WRKSRC}/patches/detect-renamed.diff
+
SSH_CONFIGURE_ON= --with-rsh=ssh
SSH_CONFIGURE_OFF= --with-rsh=rsh
-FLAGS_DISTFILES= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
-ICONV_DISTFILES= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
-RENAMED_DISTFILES= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
+ZLIB_BASE_CONFIGURE_ON= --with-included-zlib=no
.if make(makesum)
DISTFILES+= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
@@ -84,8 +83,8 @@ DISTFILES+= ${PORTNAME}-patches-${DISTVERSION}${EXTRACT_SUFX}
.include <bsd.port.pre.mk>
-.if empty(ICONV_LIB) || ! ${PORT_OPTIONS:MICONV}
-CONFIGURE_ARGS+=ac_cv_search_libiconv_open=no
+.if empty(ICONV_LIB) || !${PORT_OPTIONS:MICONV}
+CONFIGURE_ARGS+= ac_cv_search_libiconv_open=no
.endif
post-patch:
diff --git a/net/rsync/distinfo b/net/rsync/distinfo
index 59d408723a6d..febadd2a8a24 100644
--- a/net/rsync/distinfo
+++ b/net/rsync/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1597589726
-SHA256 (rsync-3.2.3.tar.gz) = becc3c504ceea499f4167a260040ccf4d9f2ef9499ad5683c179a697146ce50e
-SIZE (rsync-3.2.3.tar.gz) = 1069784
-SHA256 (rsync-patches-3.2.3.tar.gz) = de6645b46967bd701b7d6f3e29cccb19d2b46a6fa2d26a9db165847dca0e42f2
-SIZE (rsync-patches-3.2.3.tar.gz) = 157092
+TIMESTAMP = 1650365056
+SHA256 (rsync-3.2.4.tar.gz) = 6f761838d08052b0b6579cf7f6737d93e47f01f4da04c5d24d3447b7f2a5fad1
+SIZE (rsync-3.2.4.tar.gz) = 1114853
+SHA256 (rsync-patches-3.2.4.tar.gz) = 70a597590af6c61cf3d05d663429ff9f60ffe24e44f9c73a4cdc69ebdc1322a4
+SIZE (rsync-patches-3.2.4.tar.gz) = 133580
diff --git a/net/rsync/files/patch-io.c b/net/rsync/files/patch-io.c
deleted file mode 100644
index 4e051d32c9c9..000000000000
--- a/net/rsync/files/patch-io.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- io.c.orig
-+++ io.c
-@@ -787,18 +787,19 @@
- if (msgs2stderr == 1 && DEBUG_GTE(IO, 2))
- rprintf(FINFO, "[%s] recv=%ld\n", who_am_i(), (long)n);
-
-- if (io_timeout || stop_at_utime) {
-+ if (io_timeout) {
- last_io_in = time(NULL);
-- if (stop_at_utime && last_io_in >= stop_at_utime) {
-- rprintf(FERROR, "stopping at requested limit\n");
-- exit_cleanup(RERR_TIMEOUT);
-- }
- if (io_timeout && flags & PIO_NEED_INPUT)
- maybe_send_keepalive(last_io_in, 0);
- }
- stats.total_read += n;
-
- iobuf.in.len += n;
-+ }
-+
-+ if (stop_at_utime && time(NULL) >= stop_at_utime) {
-+ rprintf(FERROR, "stopping at requested limit\n");
-+ exit_cleanup(RERR_TIMEOUT);
- }
-
- if (out && FD_ISSET(iobuf.out_fd, &w_fds)) {