aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-12-15 20:03:00 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-12-15 20:18:12 +0000
commit2207bafc0551b0955813b57b8779fa4a2116a348 (patch)
treee2c02fe6dc68dfe6d292493499159e0d57eb17b1
parentf4ff9af5ea28293fd57274a01b9207b3a0433f27 (diff)
downloadports-2207bafc0551b0955813b57b8779fa4a2116a348.tar.gz
ports-2207bafc0551b0955813b57b8779fa4a2116a348.zip
print/epson-inkjet-printer-201207w: Add new port
Linux CUPS filter program for some Epson printers (L110, L111, L210, L211, L300, L301, L303, L350, L351, L353, L355, L356, L550, L551, L555) PR: 234111
-rw-r--r--print/Makefile1
-rw-r--r--print/epson-inkjet-printer-201207w/Makefile51
-rw-r--r--print/epson-inkjet-printer-201207w/distinfo5
-rw-r--r--print/epson-inkjet-printer-201207w/pkg-descr20
-rw-r--r--print/epson-inkjet-printer-201207w/pkg-plist46
5 files changed, 123 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 76ff2ee50d10..d82d6d349d4a 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -36,6 +36,7 @@
SUBDIR += enscript-a4
SUBDIR += enscript-letter
SUBDIR += enscript-letterdj
+ SUBDIR += epson-inkjet-printer-201207w
SUBDIR += epson-inkjet-printer-201401w
SUBDIR += epson-inkjet-printer-201601w
SUBDIR += epson-inkjet-printer-escpr
diff --git a/print/epson-inkjet-printer-201207w/Makefile b/print/epson-inkjet-printer-201207w/Makefile
new file mode 100644
index 000000000000..a34c3b4929f7
--- /dev/null
+++ b/print/epson-inkjet-printer-201207w/Makefile
@@ -0,0 +1,51 @@
+PORTNAME= epson-inkjet-printer-201207w
+PORTVERSION= 1.0.0
+CATEGORIES= print
+MASTER_SITES= https://download.ebz.epson.net/dsc/op/stable/RPMS/x86_64/:amd64 \
+ https://download.ebz.epson.net/dsc/op/stable/RPMS/i486/:i386
+DISTFILES_amd64=${DISTNAME}-1lsb3.2.x86_64.rpm:amd64
+DISTFILES_i386= ${DISTNAME}-1lsb3.2.i486.rpm:i386
+
+MAINTAINER= ninjaskool@gmail.com
+COMMENT= CUPS filter for Seiko Epson Color Ink Jet Printers
+WWW= https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
+
+# License does not allow redistribution
+LICENSE= EPSON LGPL21
+LICENSE_COMB= multi
+LICENSE_NAME_EPSON= SEIKO EPSON CORPORATION SOFTWARE LICENSE AGREEMENT
+LICENSE_FILE_EPSON= ${WRKSRC}/opt/${PORTNAME}/doc/COPYING.EPSON
+LICENSE_FILE_LGPL21= ${WRKSRC}/opt/${PORTNAME}/doc/COPYING.LIB
+LICENSE_PERMS_EPSON= none
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/cups/filter/gstoraster:print/cups-filters
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PLIST_SUB= LINUXBASE=${LINUXBASE} \
+ PORTNAME=${PORTNAME}
+USES= linux
+USE_LINUX= cups-libs jpeg
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+PLIST_SUB+= LIBDIR=lib
+.elif ${ARCH} == amd64
+PLIST_SUB+= LIBDIR=lib64
+.endif
+
+post-extract:
+ @${GUNZIP_CMD} ${WRKSRC}/opt/${PORTNAME}/ppds/Epson/*.ppd.gz
+
+post-patch:
+ @${SED} -i '' '/^\*cupsFilter:/s,/opt/,${LINUXBASE}&,' \
+ ${WRKSRC}/opt/${PORTNAME}/ppds/Epson/*.ppd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${LINUXBASE}
+ ${CP} -Rp ${WRKSRC}/opt ${STAGEDIR}${LINUXBASE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cups/model/
+ ${LN} -sf ${LINUXBASE}/opt/${PORTNAME}/ppds/Epson ${STAGEDIR}${PREFIX}/share/cups/model/Epson-201207w
+
+.include <bsd.port.mk>
diff --git a/print/epson-inkjet-printer-201207w/distinfo b/print/epson-inkjet-printer-201207w/distinfo
new file mode 100644
index 000000000000..871f89e9e90c
--- /dev/null
+++ b/print/epson-inkjet-printer-201207w/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1545080624
+SHA256 (epson-inkjet-printer-201207w-1.0.0-1lsb3.2.i486.rpm) = ade78f02babeca8e9d38edb0e545671c4c04e5f158ea232924092ec096adc5f0
+SIZE (epson-inkjet-printer-201207w-1.0.0-1lsb3.2.i486.rpm) = 1841911
+SHA256 (epson-inkjet-printer-201207w-1.0.0-1lsb3.2.x86_64.rpm) = 5c795ad2b2c59e96ef1d481443e7f5f17a56d38be2fc816e3095b88063f3217f
+SIZE (epson-inkjet-printer-201207w-1.0.0-1lsb3.2.x86_64.rpm) = 1866127
diff --git a/print/epson-inkjet-printer-201207w/pkg-descr b/print/epson-inkjet-printer-201207w/pkg-descr
new file mode 100644
index 000000000000..fded7ef0336e
--- /dev/null
+++ b/print/epson-inkjet-printer-201207w/pkg-descr
@@ -0,0 +1,20 @@
+This software is a filter program used with Common UNIX Printing
+System (CUPS) from the Linux. This can supply the high quality print
+with Seiko Epson Color Ink Jet Printers.
+
+This printer driver is supporting the following printers.
+L110
+L111
+L210
+L211
+L300
+L301
+L303
+L350
+L351
+L353
+L355
+L356
+L550
+L551
+L555
diff --git a/print/epson-inkjet-printer-201207w/pkg-plist b/print/epson-inkjet-printer-201207w/pkg-plist
new file mode 100644
index 000000000000..0cec886e3518
--- /dev/null
+++ b/print/epson-inkjet-printer-201207w/pkg-plist
@@ -0,0 +1,46 @@
+%%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib/filter/epson_inkjet_printer_filter
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/AUTHORS
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING.EPSON
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/COPYING.LIB
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/Manual.txt
+%%LINUXBASE%%/opt/%%PORTNAME%%/doc/README
+%%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%/libEpson_201207w.MT.so.1.0.0
+%%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%/libEpson_201207w.so.1.0.0
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L110_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L210_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L300_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L350_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L355_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L550_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson/Epson-L555_Series-epson-driver.ppd
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201207w.1.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201207w.MT.1.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201207w.MT.2.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201207w.MT.3.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201207w.MT.4.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201207w.MT.5.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/resource/Epson_201207w.MT.6.data
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG00.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG01.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG02.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG03.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG04.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG05.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG06.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG07.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG08.EID
+%%LINUXBASE%%/opt/%%PORTNAME%%/watermark/WEPCG09.EID
+share/cups/model/Epson-201207w
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib/filter
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups/lib
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/cups
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/doc
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/%%LIBDIR%%
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/ppds/Epson
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/ppds
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/resource
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%/watermark
+@dir %%LINUXBASE%%/opt/%%PORTNAME%%
+@dir %%LINUXBASE%%/opt
+@dir %%LINUXBASE%%