aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-09 08:49:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-09 09:58:53 +0000
commit22434297bdc76a793b0ab34cc2aae6b4adfa3d14 (patch)
treeb8ed5ee6dd45525c2736a4a5e92e924a877cfb88
parentd61b9ff8a555937b38084a01b68bda156fd8c578 (diff)
downloadports-22434297bdc76a793b0ab34cc2aae6b4adfa3d14.tar.gz
ports-22434297bdc76a793b0ab34cc2aae6b4adfa3d14.zip
misc/py-numcodecs: New port: Package providing buffer compression and transformation codecs for use
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-numcodecs/Makefile29
-rw-r--r--misc/py-numcodecs/distinfo3
-rw-r--r--misc/py-numcodecs/pkg-descr2
4 files changed, 35 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index f9e2f2b6beed..61e7aa3de93f 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -413,6 +413,7 @@
SUBDIR += py-mffpy
SUBDIR += py-molequeue
SUBDIR += py-mxnet
+ SUBDIR += py-numcodecs
SUBDIR += py-onnx
SUBDIR += py-onnx-tf
SUBDIR += py-openpaperwork-core
diff --git a/misc/py-numcodecs/Makefile b/misc/py-numcodecs/Makefile
new file mode 100644
index 000000000000..53c02a5c73d2
--- /dev/null
+++ b/misc/py-numcodecs/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= numcodecs
+DISTVERSION= 0.11.0
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Package providing buffer compression and transformation codecs for use
+WWW= https://numcodecs.readthedocs.io/en/stable/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py-cpuinfo>0:sysutils/py-py-cpuinfo@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}entrypoints>0:devel/py-entrypoints@${PY_FLAVOR} \
+ ${PYNUMPY}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}msgpack>0:devel/py-msgpack@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zfp>0:devel/py-zfp@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= distutils cython autoplist pytest # tests fail to find the library in the staged directory for some reason
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_WRKSRC= ${WRKSRC}/numcodecs/tests
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/numcodecs/*${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/misc/py-numcodecs/distinfo b/misc/py-numcodecs/distinfo
new file mode 100644
index 000000000000..745c6b1e06a1
--- /dev/null
+++ b/misc/py-numcodecs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1673239168
+SHA256 (numcodecs-0.11.0.tar.gz) = 6c058b321de84a1729299b0eae4d652b2e48ea1ca7f9df0da65cb13470e635eb
+SIZE (numcodecs-0.11.0.tar.gz) = 4512454
diff --git a/misc/py-numcodecs/pkg-descr b/misc/py-numcodecs/pkg-descr
new file mode 100644
index 000000000000..0b3387874f0c
--- /dev/null
+++ b/misc/py-numcodecs/pkg-descr
@@ -0,0 +1,2 @@
+Numcodecs is a Python package providing buffer compression and transformation
+codecs for use in data storage and communication applications.