aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMina Galić <me@igalic.co>2022-06-22 03:30:20 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-06-22 03:30:20 +0000
commit2282a2c6c2deab8954df7b8c58f649b5cc8b8876 (patch)
treee808f59e0c30f93deaec2ae2c48a33f8edc2ae6b
parenta76f826dc05fdd6ed29b8b38b45e223562f1f21c (diff)
downloadports-2282a2c6c2deab8954df7b8c58f649b5cc8b8876.tar.gz
ports-2282a2c6c2deab8954df7b8c58f649b5cc8b8876.zip
net-im/gotosocial: Update to 0.3.6
PR: 264814
-rw-r--r--net-im/gotosocial/Makefile20
-rw-r--r--net-im/gotosocial/distinfo8
-rw-r--r--net-im/gotosocial/files/patch-example_config.yaml8
-rw-r--r--net-im/gotosocial/pkg-plist15
4 files changed, 30 insertions, 21 deletions
diff --git a/net-im/gotosocial/Makefile b/net-im/gotosocial/Makefile
index 554deabaaa92..525b2c7b9305 100644
--- a/net-im/gotosocial/Makefile
+++ b/net-im/gotosocial/Makefile
@@ -1,8 +1,9 @@
PORTNAME= gotosocial
DISTVERSIONPREFIX= v
-DISTVERSION= 0.3.4
-PORTREVISION= 1
+DISTVERSION= 0.3.6
CATEGORIES= net-im
+MASTER_SITES?= https://github.com/${GH_ACCOUNT}/${PORTNAME}/releases/download/v${DISTVERSION}/:web
+DISTFILES?= ${PORTNAME}_${DISTVERSION}_web-assets.tar.gz:web
MAINTAINER= me+freebsd@igalic.co
COMMENT= Golang fediverse server
@@ -15,20 +16,20 @@ ONLY_FOR_ARCHS= amd64
# Note: we don't use go:modules, because this project vendors all deps
USES= go
USE_RC_SUBR= ${PORTNAME}
+
USE_GITHUB= yes
GH_ACCOUNT= superseriousbusiness
-# When rebuilding yourself, please set this:
-#GH_TAGNAME= f848aaa81f04666dae29e0bb85ccf31d30574de7
+
+SUB_LIST= DBDIR="${DBDIR}" \
+ GROUP="${GROUPS}" \
+ USER="${USERS}" \
+ WWWDIR="${WWWDIR}"
USERS= gotosocial
GROUPS= gotosocial
DBDIR= /var/db/${PORTNAME}
-SUB_LIST= DBDIR="${DBDIR}" \
- GROUP="${GROUPS}" \
- USER="${USERS}" \
- WWWDIR="${WWWDIR}"
PLIST_SUB= WWWDIR="${WWWDIR}"
# patch sample config for people who set a custom prefix
@@ -53,7 +54,6 @@ do-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/example/config.yaml \
${STAGEDIR}${ETCDIR}/config.yaml.sample
- (cd ${WRKSRC}/web && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/ \
- "! ( -path */gotosocial-styling* )")
+ (cd ${WRKSRC}/../web && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/ )
.include <bsd.port.mk>
diff --git a/net-im/gotosocial/distinfo b/net-im/gotosocial/distinfo
index 6ab84459863c..ed35640df010 100644
--- a/net-im/gotosocial/distinfo
+++ b/net-im/gotosocial/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1653574184
-SHA256 (superseriousbusiness-gotosocial-v0.3.4_GH0.tar.gz) = 2bc7baadd3e79d79e6628314ddfb4c6ef135729bf7488384e804f66d67e45961
-SIZE (superseriousbusiness-gotosocial-v0.3.4_GH0.tar.gz) = 48532595
+TIMESTAMP = 1655843939
+SHA256 (gotosocial_0.3.6_web-assets.tar.gz) = 58bf5761238848b136f06abb56425af03bae29922e2ceb6a9af25a9ce8eafb54
+SIZE (gotosocial_0.3.6_web-assets.tar.gz) = 998627
+SHA256 (superseriousbusiness-gotosocial-v0.3.6_GH0.tar.gz) = ade65d0cb7ecbd6a0e95d7fdd2d802638fbaa9b1bcedb79e10023ad29b652e73
+SIZE (superseriousbusiness-gotosocial-v0.3.6_GH0.tar.gz) = 48824501
diff --git a/net-im/gotosocial/files/patch-example_config.yaml b/net-im/gotosocial/files/patch-example_config.yaml
index c82827ad9d16..beead207f516 100644
--- a/net-im/gotosocial/files/patch-example_config.yaml
+++ b/net-im/gotosocial/files/patch-example_config.yaml
@@ -1,6 +1,6 @@
---- example/config.yaml.orig 2022-02-03 11:30:06 UTC
+--- example/config.yaml.orig 2022-06-20 12:11:36 UTC
+++ example/config.yaml
-@@ -151,12 +151,12 @@ db-tls-ca-cert: ""
+@@ -158,12 +158,12 @@ db-tls-ca-cert: ""
# String. Directory from which gotosocial will attempt to load html templates (.tmpl files).
# Examples: ["/some/absolute/path/", "./relative/path/", "../../some/weird/path/"]
# Default: "./web/template/"
@@ -15,7 +15,7 @@
###########################
##### ACCOUNTS CONFIG #####
-@@ -222,7 +222,7 @@ storage-backend: "local"
+@@ -240,7 +240,7 @@ storage-backend: "local"
# this directory, and create new subdirectories and files within it.
# Examples: ["/home/gotosocial/storage", "/opt/gotosocial/datastorage"]
# Default: "/gotosocial/storage"
@@ -24,7 +24,7 @@
###########################
##### STATUSES CONFIG #####
-@@ -288,7 +288,7 @@ letsencrypt-port: 80
+@@ -306,7 +306,7 @@ letsencrypt-port: 80
# In any case, make sure GoToSocial has permissions to write to / read from this directory.
# Examples: ["/home/gotosocial/storage/certs", "/acmecerts"]
# Default: "/gotosocial/storage/certs"
diff --git a/net-im/gotosocial/pkg-plist b/net-im/gotosocial/pkg-plist
index 3ed021ac1e03..325d25f3a43d 100644
--- a/net-im/gotosocial/pkg-plist
+++ b/net-im/gotosocial/pkg-plist
@@ -1,6 +1,15 @@
@sample etc/gotosocial/config.yaml.sample
-%%WWWDIR%%/assets/base.css
-%%WWWDIR%%/assets/colors.css
+%%WWWDIR%%/assets/dist/_colors.css
+%%WWWDIR%%/assets/dist/admin-panel.js
+%%WWWDIR%%/assets/dist/base.css
+%%WWWDIR%%/assets/dist/bundle.js
+%%WWWDIR%%/assets/dist/frontend.js
+%%WWWDIR%%/assets/dist/panels-admin-style.css
+%%WWWDIR%%/assets/dist/profile.css
+%%WWWDIR%%/assets/dist/status.css
+%%WWWDIR%%/assets/dist/user-panel.js
+%%WWWDIR%%/assets/swagger.yaml
+%%WWWDIR%%/template/frontend.tmpl
%%WWWDIR%%/assets/Fork-Awesome/CONTRIBUTORS.md
%%WWWDIR%%/assets/Fork-Awesome/css/fork-awesome.css
%%WWWDIR%%/assets/Fork-Awesome/css/fork-awesome.min.css
@@ -15,7 +24,6 @@
%%WWWDIR%%/assets/Fork-Awesome/fonts/forkawesome-webfont.woff2
%%WWWDIR%%/assets/Fork-Awesome/LICENSES
%%WWWDIR%%/assets/logo.png
-%%WWWDIR%%/assets/status.css
%%WWWDIR%%/assets/tusky.svg
%%WWWDIR%%/assets/default_avatars/GoToSocial_icon1.svg
%%WWWDIR%%/assets/default_avatars/GoToSocial_icon2.svg
@@ -23,7 +31,6 @@
%%WWWDIR%%/assets/default_avatars/GoToSocial_icon4.svg
%%WWWDIR%%/assets/default_avatars/GoToSocial_icon5.svg
%%WWWDIR%%/assets/default_avatars/GoToSocial_icon6.svg
-%%WWWDIR%%/assets/profile.css
%%WWWDIR%%/template/profile.tmpl
%%WWWDIR%%/template/404.tmpl
%%WWWDIR%%/template/authorize.tmpl