aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-09-08 14:33:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-10-08 17:50:39 +0000
commit2331f637a405403428e1d8a954d9cbf620cbfc51 (patch)
tree69d39295525ca1691fe53620c6e3b6568857840c
parentc234a6223d97e1b9cd33d40c76d5fc00aae00677 (diff)
downloadports-2331f637a405403428e1d8a954d9cbf620cbfc51.tar.gz
ports-2331f637a405403428e1d8a954d9cbf620cbfc51.zip
x11/tofi: add new port
An extremely fast and simple dmenu / rofi replacement for wlroots-based Wayland compositors such as Sway. https://github.com/philj56/tofi
-rw-r--r--x11/Makefile1
-rw-r--r--x11/tofi/Makefile48
-rw-r--r--x11/tofi/distinfo3
-rw-r--r--x11/tofi/pkg-descr2
4 files changed, 54 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index fefa588a5884..146c0967ba70 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -377,6 +377,7 @@
SUBDIR += tilda
SUBDIR += tilix
SUBDIR += tint
+ SUBDIR += tofi
SUBDIR += trayer
SUBDIR += ulauncher
SUBDIR += urxvt-font-size
diff --git a/x11/tofi/Makefile b/x11/tofi/Makefile
new file mode 100644
index 000000000000..8464b1d23de9
--- /dev/null
+++ b/x11/tofi/Makefile
@@ -0,0 +1,48 @@
+PORTNAME= tofi
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.6.0
+CATEGORIES= x11 wayland
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Tiny dynamic menu for Wayland
+WWW= https://github.com/philj56/tofi
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols
+LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo pango
+GH_ACCOUNT= philj56
+PLIST_FILES= bin/${PORTNAME} \
+ bin/${PORTNAME}-drun \
+ bin/${PORTNAME}-run \
+ etc/xdg/${PORTNAME}/config \
+ share/bash-completion/completions/${PORTNAME} \
+ share/bash-completion/completions/${PORTNAME}-drun \
+ share/bash-completion/completions/${PORTNAME}-run
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT=MANPAGES
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}-drun.1.gz \
+ man/man1/${PORTNAME}-run.1.gz \
+ man/man1/${PORTNAME}.1.gz \
+ man/man5/${PORTNAME}.5.gz
+
+post-patch:
+# Respect PREFIX for system config and *.desktop
+ @${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
+ -e 's,/usr/share,${DATADIR:H},' \
+ ${WRKSRC}/doc/${PORTNAME}.1.scd \
+ ${WRKSRC}/src/drun.c
+
+.include <bsd.port.mk>
diff --git a/x11/tofi/distinfo b/x11/tofi/distinfo
new file mode 100644
index 000000000000..882b1dbd1118
--- /dev/null
+++ b/x11/tofi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1662647634
+SHA256 (philj56-tofi-v0.6.0_GH0.tar.gz) = 65a3ddd202ae7b8bedeee2efb92253a4cca929654119ecdfd76f7d4c67315016
+SIZE (philj56-tofi-v0.6.0_GH0.tar.gz) = 305234
diff --git a/x11/tofi/pkg-descr b/x11/tofi/pkg-descr
new file mode 100644
index 000000000000..9e1914e29af5
--- /dev/null
+++ b/x11/tofi/pkg-descr
@@ -0,0 +1,2 @@
+An extremely fast and simple dmenu / rofi replacement for
+wlroots-based Wayland compositors such as Sway.