aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-07-28 00:26:34 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-09-04 15:49:52 +0000
commit247d0c593812b12a121006971ec79fc61142313e (patch)
tree2b157f80b1212760280aaab042f7f0cbca94bf28
parentc1450a206daabee23c2e2596d9c042bb2c0a437c (diff)
downloadports-247d0c593812b12a121006971ec79fc61142313e.tar.gz
ports-247d0c593812b12a121006971ec79fc61142313e.zip
lang/php82: Update version 8.2.20=>8.2.21
- Add profile support in php-fpm rc script for running multiple php master process - Make the rc script jail ready [1] Changelog: https://www.php.net/ChangeLog-8.php#8.2.21 Reported by: netchild [1] (cherry picked from commit d6c16b39eaba13b0c240747534b8707056abb32b)
-rw-r--r--lang/php82/Makefile2
-rw-r--r--lang/php82/distinfo6
-rw-r--r--lang/php82/files/php-fpm.in54
3 files changed, 49 insertions, 13 deletions
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index 5d3f58f61ef8..50b7b1f6e7ba 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -1,5 +1,5 @@
PORTNAME= php82
-DISTVERSION= 8.2.20
+DISTVERSION= 8.2.21
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
diff --git a/lang/php82/distinfo b/lang/php82/distinfo
index 8badf8eb88ad..f8b6f532853c 100644
--- a/lang/php82/distinfo
+++ b/lang/php82/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1717709436
-SHA256 (php-8.2.20.tar.xz) = 4474cc430febef6de7be958f2c37253e5524d5c5331a7e1765cd2d2234881e50
-SIZE (php-8.2.20.tar.xz) = 12097568
+TIMESTAMP = 1722079018
+SHA256 (php-8.2.21.tar.xz) = 8cc44d51bb2506399ec176f70fe110f0c9e1f7d852a5303a2cd1403402199707
+SIZE (php-8.2.21.tar.xz) = 12106792
diff --git a/lang/php82/files/php-fpm.in b/lang/php82/files/php-fpm.in
index c234856b0e54..9f753ea485e9 100644
--- a/lang/php82/files/php-fpm.in
+++ b/lang/php82/files/php-fpm.in
@@ -6,8 +6,13 @@
#
# Add the following line to /etc/rc.conf to enable php-fpm:
-# php_fpm_enable="YES"
-#
+# php-fpm_enable (bool): Set to "NO" by default.
+# Set it to "YES" to enable php-fpm
+# php-fpm_profiles (str): Set to "" by default.
+# Define your profiles here.
+# php_fpm_pid_prefix (str): Set to "" by default.
+# When using profiles manually assign value to "php_fpm_"
+# for prevent collision with other PIDs names.
. /etc/rc.subr
@@ -17,23 +22,54 @@ rcvar=php_fpm_enable
start_precmd="php_fpm_prestart"
restart_precmd="php_fpm_checkconfig"
reload_precmd="php_fpm_checkconfig"
+command="%%PREFIX%%/sbin/php-fpm"
configtest_cmd="php_fpm_checkconfig"
+_pidprefix="/var/run"
+pidfile="${_pidprefix}/php-fpm.pid"
+required_files="%%PREFIX%%/etc/php-fpm.conf"
-load_rc_config "$name"
+load_rc_config "${name}"
: ${php_fpm_enable="NO"}
: ${php_fpm_umask=""}
+: ${php_fpm_svcj_options:="net_basic"}
-extra_commands="reload configtest logrotate"
+if [ -n "$2" ]; then
+ profile="$2"
+ if [ "x${php_fpm_profiles}" != "x" ]; then
+ pidfile="${_pidprefix}/${php_fpm_pid_prefix}php-fpm-${profile}.pid"
+ eval php_fpm_configfile="\${php_fpm_${profile}_configfile:-}"
+ if [ "x${php_fpm_configfile}" = "x" ]; then
+ echo "You must define a configuration file (php_fpm_${profile}_configfile)"
+ exit 1
+ fi
+ required_files="${php_fpm_configfile}"
+ eval php_fpm_enable="\${php_fpm_${profile}_enable:-${php_fpm_enable}}"
+ php_fpm_flags="-y ${php_fpm_configfile} -g ${pidfile}"
+ else
+ echo "$0: extra argument ignored"
+ fi
+else
+ if [ "x${php_fpm_profiles}" != "x" -a "x$1" != "x" ]; then
+ for profile in ${php_fpm_profiles}; do
+ echo "===> php_fpm profile: ${profile}"
+ /usr/local/etc/rc.d/php-fpm $1 ${profile}
+ retcode="$?"
+ if [ "0${retcode}" -ne 0 ]; then
+ failed="${profile} (${retcode}) ${failed:-}"
+ else
+ success="${profile} ${success:-}"
+ fi
+ done
+ exit 0
+ fi
+fi
-command="%%PREFIX%%/sbin/php-fpm"
-pidfile="/var/run/php-fpm.pid"
+extra_commands="reload configtest logrotate"
sig_stop="QUIT"
sig_reload="USR2"
logrotate_cmd="php_fpm_logrotate"
-required_files="%%PREFIX%%/etc/php-fpm.conf"
-
php_fpm_logrotate() {
if [ -z "$rc_pid" ]; then
_run_rc_notrunning
@@ -46,7 +82,7 @@ php_fpm_logrotate() {
php_fpm_checkconfig()
{
echo "Performing sanity check on php-fpm configuration:"
- eval ${command} -t
+ eval ${command} ${php_fpm_flags} -t
}
php_fpm_prestart()