aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-10 19:47:34 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-10 19:47:34 +0000
commit24bb4d98afeb4a4dd96874f8dfca087e225fb9ac (patch)
treeab4829abae917f65742833573e5ec5d1c8f344a7
parentf9ac96b9e2b28ed3dd8ee42d78a8c71e23c3bb8e (diff)
downloadports-24bb4d98afeb4a4dd96874f8dfca087e225fb9ac.tar.gz
ports-24bb4d98afeb4a4dd96874f8dfca087e225fb9ac.zip
devel/py-hacking: Allow build with py-flake8 7.0.0
- Bump PORTREVISION for package change
-rw-r--r--devel/py-hacking/Makefile3
-rw-r--r--devel/py-hacking/files/patch-requirements.txt5
2 files changed, 7 insertions, 1 deletions
diff --git a/devel/py-hacking/Makefile b/devel/py-hacking/Makefile
index 7ef6fc6b2904..426fcb09ffea 100644
--- a/devel/py-hacking/Makefile
+++ b/devel/py-hacking/Makefile
@@ -1,5 +1,6 @@
PORTNAME= hacking
PORTVERSION= 6.1.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>=6.1.0<6.2:devel/py-flake8@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flake8>=6.1.0:devel/py-flake8@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent pep517
diff --git a/devel/py-hacking/files/patch-requirements.txt b/devel/py-hacking/files/patch-requirements.txt
new file mode 100644
index 000000000000..e1ef2fbe6f2e
--- /dev/null
+++ b/devel/py-hacking/files/patch-requirements.txt
@@ -0,0 +1,5 @@
+--- requirements.txt.orig 2023-12-08 14:14:01 UTC
++++ requirements.txt
+@@ -1 +1 @@
+-flake8~=6.1.0 # MIT
++flake8>=6.1.0 # MIT