aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 20:46:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 20:46:05 +0000
commit24d16b246ae80fbf30ec1f02895d4757b2911ee3 (patch)
treebf21997e95f01c4b95fab50b87027dd4b1c0fd6a
parentba5a472818820ee560903d7a5509b19570ffa7ce (diff)
downloadports-24d16b246ae80fbf30ec1f02895d4757b2911ee3.tar.gz
ports-24d16b246ae80fbf30ec1f02895d4757b2911ee3.zip
textproc/py-youseedee: Update to 0.5.0
-rw-r--r--textproc/py-youseedee/Makefile6
-rw-r--r--textproc/py-youseedee/distinfo6
-rw-r--r--textproc/py-youseedee/files/patch-lib-youseedee-__init__.py16
3 files changed, 15 insertions, 13 deletions
diff --git a/textproc/py-youseedee/Makefile b/textproc/py-youseedee/Makefile
index 05be7bf08bdd..71611711b514 100644
--- a/textproc/py-youseedee/Makefile
+++ b/textproc/py-youseedee/Makefile
@@ -1,5 +1,5 @@
PORTNAME= youseedee
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5.0
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,7 +10,9 @@ WWW= https://github.com/simoncozens/youseedee
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}black>=0:devel/py-black@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}filelock>=0:sysutils/py-filelock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
UCD>=0:textproc/UCD
USES= python
diff --git a/textproc/py-youseedee/distinfo b/textproc/py-youseedee/distinfo
index fcd74390a6c9..b6d0cd6a96ab 100644
--- a/textproc/py-youseedee/distinfo
+++ b/textproc/py-youseedee/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1680726214
-SHA256 (youseedee-0.4.1.tar.gz) = 7dd23808151231b74a5b4aa0e32db6c23588e9b868b600e441d14c73d5f4d1ab
-SIZE (youseedee-0.4.1.tar.gz) = 13974
+TIMESTAMP = 1702543702
+SHA256 (youseedee-0.5.0.tar.gz) = 63bb17de47205c13fdd639975446af01df783494461cad1bb92033fcca01dc28
+SIZE (youseedee-0.5.0.tar.gz) = 14479
diff --git a/textproc/py-youseedee/files/patch-lib-youseedee-__init__.py b/textproc/py-youseedee/files/patch-lib-youseedee-__init__.py
index 94141fa40ac7..c98a5a787174 100644
--- a/textproc/py-youseedee/files/patch-lib-youseedee-__init__.py
+++ b/textproc/py-youseedee/files/patch-lib-youseedee-__init__.py
@@ -1,11 +1,11 @@
---- lib/youseedee/__init__.py.orig 2020-10-06 16:13:22 UTC
+--- lib/youseedee/__init__.py.orig 2023-12-13 13:22:08 UTC
+++ lib/youseedee/__init__.py
-@@ -9,7 +9,7 @@ import csv
- UCD_URL = "https://unicode.org/Public/UCD/latest/ucd/UCD.zip"
+@@ -23,7 +23,7 @@ UCD_URL = "https://unicode.org/Public/UCD/latest/ucd/U
+
def ucd_dir():
-- ucddir = os.path.expanduser("~/.youseedee")
-+ ucddir = "%%UCDDIR%%"
- if not os.path.isdir(ucddir):
- os.mkdir(ucddir)
- return ucddir
+- ucddir = os.path.expanduser("~/.youseedee")
++ ucddir = "%%UCDDIR%%"
+ if not os.path.isdir(ucddir):
+ os.mkdir(ucddir)
+ return ucddir