aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2021-04-13 07:17:52 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2021-04-15 14:00:09 +0000
commit24e45b05877f54fa45f4f9009e3fe2a4859dac8a (patch)
tree39dc8768c6db4e924910cb435a0f410adab05ec7
parent3d883faa9f453a30710473c75231f64ed6a9942b (diff)
downloadports-24e45b05877f54fa45f4f9009e3fe2a4859dac8a.tar.gz
ports-24e45b05877f54fa45f4f9009e3fe2a4859dac8a.zip
Erlang: replace CONFIGURE_ENABLE with CONFIGURE_ARGS.
CONFIGURE_ENABLE (by itself) does not actually exist.
-rw-r--r--lang/erlang-runtime20/Makefile4
-rw-r--r--lang/erlang-runtime21/Makefile4
-rw-r--r--lang/erlang-runtime22/Makefile4
-rw-r--r--lang/erlang-runtime23/Makefile4
-rw-r--r--lang/erlang/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/lang/erlang-runtime20/Makefile b/lang/erlang-runtime20/Makefile
index d1f73d2cb45f..19ba12e1c1ab 100644
--- a/lang/erlang-runtime20/Makefile
+++ b/lang/erlang-runtime20/Makefile
@@ -21,6 +21,8 @@ GH_PROJECT= otp
USE_PERL5= build
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-smp-support
+
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
@@ -60,8 +62,6 @@ OPENSSL_VARS= BROKEN_SSL=openssl
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
-CONFIGURE_ENABLE= smp-support
-
DIRTY_CONFIGURE_ENABLE= dirty-schedulers
DTRACE_CFLAGS= -fno-omit-frame-pointer
DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace
diff --git a/lang/erlang-runtime21/Makefile b/lang/erlang-runtime21/Makefile
index b62fa6cfbd6c..1b1ea46a085b 100644
--- a/lang/erlang-runtime21/Makefile
+++ b/lang/erlang-runtime21/Makefile
@@ -26,6 +26,8 @@ DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKSRC_otp}
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-smp-support
+
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
@@ -65,8 +67,6 @@ OPTIONS_EXCLUDE_i386= DTRACE HIPE NATIVE
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
-CONFIGURE_ENABLE= smp-support
-
DIRTY_CONFIGURE_ENABLE= dirty-schedulers
DTRACE_CFLAGS= -fno-omit-frame-pointer
DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace
diff --git a/lang/erlang-runtime22/Makefile b/lang/erlang-runtime22/Makefile
index fb3a60251764..f19c45530771 100644
--- a/lang/erlang-runtime22/Makefile
+++ b/lang/erlang-runtime22/Makefile
@@ -26,6 +26,8 @@ DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKSRC_otp}
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-smp-support
+
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
@@ -64,8 +66,6 @@ OPTIONS_EXCLUDE_i386= DTRACE HIPE NATIVE
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
-CONFIGURE_ENABLE= smp-support
-
DIRTY_CONFIGURE_ENABLE= dirty-schedulers
DTRACE_CFLAGS= -fno-omit-frame-pointer
DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace
diff --git a/lang/erlang-runtime23/Makefile b/lang/erlang-runtime23/Makefile
index 46b7e0045a54..fb5b5af17d0a 100644
--- a/lang/erlang-runtime23/Makefile
+++ b/lang/erlang-runtime23/Makefile
@@ -25,6 +25,8 @@ DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKSRC_otp}
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-smp-support
+
MAKE_JOBS_UNSAFE= yes
SUB_FILES= pkg-message
@@ -63,8 +65,6 @@ OPTIONS_EXCLUDE_i386= DTRACE HIPE NATIVE
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
-CONFIGURE_ENABLE= smp-support
-
DIRTY_CONFIGURE_ENABLE= dirty-schedulers
DTRACE_CFLAGS= -fno-omit-frame-pointer
DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 434b8ba33b56..f22a4511e07a 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -26,6 +26,8 @@ USE_RC_SUBR= epmd
WRKSRC= ${WRKSRC_otp}
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-smp-support
+
MAKE_JOBS_UNSAFE= yes
OPTIONS_SUB= yes
@@ -82,8 +84,6 @@ OPTIONS_EXCLUDE_riscv64= DTRACE
# probes fixed does not match the number of defined probes (54 != 132,
# respectively)" you probably misconfigured DTrace in some way.
-CONFIGURE_ENABLE= smp-support
-
DIRTY_CONFIGURE_ENABLE= dirty-schedulers
DTRACE_CFLAGS= -fno-omit-frame-pointer
DTRACE_CONFIGURE_WITH= dynamic-trace=dtrace