aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-11-04 19:15:42 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-11-05 05:07:40 +0000
commit2507b096e4fb31d83420dc9fe3681b5b73537d20 (patch)
tree448701e5b9c42932e4cb14d64e7cabc4e114d3a5
parent839ac634dd834992c3011fdaf553a5228f81d67e (diff)
KDE: reduce diff on KDE Gear updates
Some KDE Gear applications set a different version for the shared library than the rest of them. Those ports manually overwrote the variable used in the plist sub. Make them use a kde.mk defined value, so that only one place needs to be changed on updates.
-rw-r--r--Mk/Uses/kde.mk2
-rw-r--r--astro/kosmindoormap/Makefile2
-rw-r--r--sysutils/baloo-widgets/Makefile2
3 files changed, 4 insertions, 2 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 3b2cacc461e4..49f72b4398a0 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -85,6 +85,8 @@ KDE_FRAMEWORKS_BRANCH?= stable
# Current KDE applications.
KDE_APPLICATIONS_VERSION?= 21.08.3
KDE_APPLICATIONS_SHLIB_VER?= 5.18.3
+# G as in KDE Gear, and as in "don't make the variable name longer than required"
+KDE_APPLICATIONS_SHLIB_G_VER?= 21.8.3
KDE_APPLICATIONS_BRANCH?= stable
# Extended KDE universe applications.
diff --git a/astro/kosmindoormap/Makefile b/astro/kosmindoormap/Makefile
index c729fdcc3a79..c4bb3c747dfb 100644
--- a/astro/kosmindoormap/Makefile
+++ b/astro/kosmindoormap/Makefile
@@ -16,6 +16,6 @@ USE_QT= core declarative gui network quick3d \
OPTIONS_DEFINE= DOCS
# Override shared library version
-KDE_APPLICATIONS_SHLIB_VER= 21.8.3
+KDE_APPLICATIONS_SHLIB_VER= ${KDE_APPLICATIONS_SHLIB_G_VER}
.include <bsd.port.mk>
diff --git a/sysutils/baloo-widgets/Makefile b/sysutils/baloo-widgets/Makefile
index af766a422b23..d2ce9dfc2737 100644
--- a/sysutils/baloo-widgets/Makefile
+++ b/sysutils/baloo-widgets/Makefile
@@ -15,6 +15,6 @@ USE_QT= concurrent core dbus gui network testlib widgets xml \
USE_LDCONFIG= yes
# Override shared library version
-KDE_APPLICATIONS_SHLIB_VER= 21.8.3
+KDE_APPLICATIONS_SHLIB_VER= ${KDE_APPLICATIONS_SHLIB_G_VER}
.include <bsd.port.mk>