aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-02-03 15:39:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2025-02-03 15:54:27 +0000
commit2595dd7e6a4be47a9b04dc4a0eac4d346c856213 (patch)
tree5991739f389ae62e2708d9f34758a9b544ca35d1
parentd2a432e194ada20da947eef6679171f11d442a97 (diff)
devel/py-graphql-relay: Allow build with py-poetry-core 2.0.0+
- Clean up BUILD_DEPENDS: py-setuptools is not needed - Bump PORTREVISION for package change
-rw-r--r--devel/py-graphql-relay/Makefile5
-rw-r--r--devel/py-graphql-relay/files/patch-pyproject.toml9
2 files changed, 11 insertions, 3 deletions
diff --git a/devel/py-graphql-relay/Makefile b/devel/py-graphql-relay/Makefile
index 3b820610649f..19f6a25d9292 100644
--- a/devel/py-graphql-relay/Makefile
+++ b/devel/py-graphql-relay/Makefile
@@ -1,6 +1,6 @@
PORTNAME= graphql-relay
PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +12,7 @@ WWW= https://github.com/graphql-python/graphql-relay-py
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1<2:devel/py-poetry-core@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}setuptools>=59<70:devel/py-setuptools@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1:devel/py-poetry-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graphql-core>=3.2<4:devel/py-graphql-core@${PY_FLAVOR}
USES= python
diff --git a/devel/py-graphql-relay/files/patch-pyproject.toml b/devel/py-graphql-relay/files/patch-pyproject.toml
new file mode 100644
index 000000000000..8f9cd984dee1
--- /dev/null
+++ b/devel/py-graphql-relay/files/patch-pyproject.toml
@@ -0,0 +1,9 @@
+--- pyproject.toml.orig 2022-04-16 11:03:39 UTC
++++ pyproject.toml
+@@ -67,5 +67,5 @@ target-version = ['py36', 'py37', 'py38', 'py39', 'py3
+ target-version = ['py36', 'py37', 'py38', 'py39', 'py310']
+
+ [build-system]
+-requires = ["poetry_core>=1,<2", "setuptools>=59,<70"]
++requires = ["poetry_core>=1"]
+ build-backend = "poetry.core.masonry.api"