aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-07-02 17:13:10 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-07-02 17:22:16 +0000
commit2617740e97b47aac9e57bf4c3bd738868fbcff6a (patch)
tree3cf8d927b4487377e160014bc7e64f6aa9070403
parent6d57701bf90d40f55c0738c77bf0bcdcf2119a55 (diff)
downloadports-2617740e97b47aac9e57bf4c3bd738868fbcff6a.tar.gz
ports-2617740e97b47aac9e57bf4c3bd738868fbcff6a.zip
devel/gwenhywfar-fox16: Fix build with llvm16
theme.cpp:20:3: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister] register FXint rr,gg,bb,dr,dg,db,r1,g1,b1,r2,g2,b2,yl,yh,yy,dy,n,t; Reported by: pkg-fallout MFH: 2023Q3
-rw-r--r--devel/gwenhywfar/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index dff490879abb..49219bda5d38 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -64,6 +64,7 @@ INSTALL_WRKSRC= ${WRKSRC}/gui/${SLAVEPORT}
LIB_DEPENDS+= libFOX-1.6.so:x11-toolkits/fox16
CONFIGURE_ARGS+=--with-fox-includes=${LOCALBASE}/include/fox-1.6 \
--with-fox-libs=${LOCALBASE}/lib
+CXXFLAGS+= -Dregister=
. elif ${SLAVEPORT}=="gtk2"
LIB_DEPENDS+= libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz \