aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-08-15 20:11:21 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-08-15 20:22:45 +0000
commit261ad60e13b346e4c996f0089f4d90a0b22d9550 (patch)
tree539cfcf281ffc4723315da470f0dcd03dd7fe198
parente50ab2a372c55f19a654dadc8774f0fc38666a21 (diff)
downloadports-261ad60e13b346e4c996f0089f4d90a0b22d9550.tar.gz
ports-261ad60e13b346e4c996f0089f4d90a0b22d9550.zip
net/msoak: New port
Subscribe to different MQTT brokers and topics simultaneously, and soak up what they have to offer. WWW: https://github.com/jpmens/msoak PR: 243127 Reviewed by: Jan-Piet Mens <ports@jpmens.net> (maintainer)
-rw-r--r--net/Makefile1
-rw-r--r--net/msoak/Makefile28
-rw-r--r--net/msoak/distinfo3
-rw-r--r--net/msoak/pkg-descr10
-rw-r--r--net/msoak/pkg-plist4
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b5c621caca10..576b68a2caba 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -474,6 +474,7 @@
SUBDIR += mrouted
SUBDIR += mrtparse
SUBDIR += msend
+ SUBDIR += msoak
SUBDIR += mtr
SUBDIR += mtr-nox11
SUBDIR += multicat
diff --git a/net/msoak/Makefile b/net/msoak/Makefile
new file mode 100644
index 000000000000..35c5d3ae5208
--- /dev/null
+++ b/net/msoak/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= msoak
+DISTVERSION= 0.8
+CATEGORIES= net
+
+MAINTAINER= ports@jpmens.net
+COMMENT= Subscribe to different MQTT brokers and topics simultaneously
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libmosquitto.so:net/mosquitto \
+ libconfig.so:devel/libconfig
+
+USES= localbase:ldflags lua:53+
+USE_GITHUB= yes
+GH_ACCOUNT= jpmens
+
+CFLAGS+= -I${LUA_INCDIR}
+LDFLAGS+= -llua-${LUA_VER} -lmosquitto -lconfig
+MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ BINDIR=${PREFIX}/bin MANDIR=${MANPREFIX}/man
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/msoak
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/net/msoak/distinfo b/net/msoak/distinfo
new file mode 100644
index 000000000000..040790453e0b
--- /dev/null
+++ b/net/msoak/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578314385
+SHA256 (jpmens-msoak-0.8_GH0.tar.gz) = b9d7d25eb5203a7c5f2b6fa2ec19bca20ef589488562ac8901f54f3ca9056ace
+SIZE (jpmens-msoak-0.8_GH0.tar.gz) = 141831
diff --git a/net/msoak/pkg-descr b/net/msoak/pkg-descr
new file mode 100644
index 000000000000..2bc465f22f54
--- /dev/null
+++ b/net/msoak/pkg-descr
@@ -0,0 +1,10 @@
+msoak is a utility with which to simultaneously subscribe to an
+arbitrary number of topics on any number of MQTT brokers and
+optionally modify or normalize received payloads before printing
+them out. This utility was created to back up to a central location
+messages received by a handfull of brokers, instead of launching
+(and having to monitor success of) a large number of mosquitto_sub(1)
+programs.
+
+
+WWW: https://github.com/jpmens/msoak
diff --git a/net/msoak/pkg-plist b/net/msoak/pkg-plist
new file mode 100644
index 000000000000..e3d38a129cdb
--- /dev/null
+++ b/net/msoak/pkg-plist
@@ -0,0 +1,4 @@
+bin/msoak
+man/man1/msoak.1.gz
+%%EXAMPLESDIR%%/example.config
+%%EXAMPLESDIR%%/example.lua