aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-09-13 15:23:33 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-09-13 18:42:14 +0000
commit26972239945e17c70d6b6117dcbd827ce11c7c99 (patch)
tree60bcc03b7136b86dadbc03db24413011bfd05b70
parent53759559829b090edd36c8e858114fba2ae5a467 (diff)
sysutils/plasma5-ksystemstats: new port for system resource usage
Plasma Systemstats is a successor to (lib)KSysGuard in the way that Plasma System Monitor is a successor to KSysGuard. The background idea is that system statistics collection (resource usage) should be low-overhead and pluggable and the UI in the application flexible. KSysGuard achieved that with 2010-era technologies, but time and technology moves on. Note, though, that the backend -- the actual system-statistics- collection -- on FreeBSD is missing collection of network activity (entirely) and memory use (is wrong). System monitor is **not yet** a replacement for KSysGuard on FreeBSD, but the CPU monitoring -- which might be the most important and graphically appealing bit on a desktop machine -- is much improved. This commit introduces the new port, adds it to USE_KDE, and makes it a dependency of system-monitor, to ease the eventual replacement (once the issues mentioned above are cleared up) of old by new.
-rw-r--r--Mk/Uses/kde.mk5
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/plasma5-ksystemstats/Makefile15
-rw-r--r--sysutils/plasma5-ksystemstats/distinfo3
-rw-r--r--sysutils/plasma5-ksystemstats/pkg-descr7
-rw-r--r--sysutils/plasma5-ksystemstats/pkg-plist39
-rw-r--r--sysutils/plasma5-plasma-systemmonitor/Makefile4
7 files changed, 72 insertions, 2 deletions
diff --git a/Mk/Uses/kde.mk b/Mk/Uses/kde.mk
index 683d09858710..90cd5315954e 100644
--- a/Mk/Uses/kde.mk
+++ b/Mk/Uses/kde.mk
@@ -263,7 +263,7 @@ _USE_PLASMA_ALL= activitymanagerd breeze breeze-gtk \
decoration discover drkonqi hotkeys \
infocenter kde-cli-tools kde-gtk-config \
kdeplasma-addons kgamma5 kmenuedit kscreen \
- kscreenlocker ksshaskpass ksysguard kwallet-pam \
+ kscreenlocker ksshaskpass ksysguard ksystemstats kwallet-pam \
kwayland-integration kwin kwrited layer-shell-qt libkscreen \
libksysguard milou oxygen plasma-browser-integration \
plasma-desktop plasma-disks plasma-integration plasma-pa \
@@ -590,6 +590,9 @@ kde-ksshaskpass_PATH= ${KDE_PREFIX}/bin/ksshaskpass
kde-ksysguard_PORT= sysutils/plasma5-ksysguard
kde-ksysguard_PATH= ${KDE_PREFIX}/bin/ksysguard
+kde-ksystemstats_PORT= sysutils/plasma5-ksystemstats
+kde-ksysguard_PATH= ${KDE_PREFIX}/bin/ksystemstats
+
kde-kwallet-pam_PORT= security/plasma5-kwallet-pam
kde-kwallet-pam_PATH= ${KDE_PREFIX}/lib/pam_kwallet5.so
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 1fcf8d5a8940..76a8c6e33508 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -967,6 +967,7 @@
SUBDIR += plasma5-kinfocenter
SUBDIR += plasma5-kmenuedit
SUBDIR += plasma5-ksysguard
+ SUBDIR += plasma5-ksystemstats
SUBDIR += plasma5-libksysguard
SUBDIR += plasma5-plasma-disks
SUBDIR += plasma5-plasma-systemmonitor
diff --git a/sysutils/plasma5-ksystemstats/Makefile b/sysutils/plasma5-ksystemstats/Makefile
new file mode 100644
index 000000000000..ddf6bfe3e89a
--- /dev/null
+++ b/sysutils/plasma5-ksystemstats/Makefile
@@ -0,0 +1,15 @@
+PORTNAME= ksystemstats
+DISTVERSION= ${KDE_PLASMA_VERSION}
+CATEGORIES= sysutils kde kde-plasma
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Plasma5 library to report system activity
+
+LIB_DEPENDS+= libudev.so:devel/libudev-devd
+
+USES= cmake compiler:c++17-lang kde:5 qt:5 tar:xz
+USE_KDE= config coreaddons dbusaddons i18n kio libksysguard service solid
+USE_QT= concurrent core dbus gui network \
+ buildtools_build qmake_build testlib_build
+
+.include <bsd.port.mk>
diff --git a/sysutils/plasma5-ksystemstats/distinfo b/sysutils/plasma5-ksystemstats/distinfo
new file mode 100644
index 000000000000..4d4b5127d44d
--- /dev/null
+++ b/sysutils/plasma5-ksystemstats/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1631543244
+SHA256 (KDE/plasma/5.22.5/ksystemstats-5.22.5.tar.xz) = 683df0bb88d237a4dffe0b438c1796db4bb4d267d42d6363fc491a69f98265b1
+SIZE (KDE/plasma/5.22.5/ksystemstats-5.22.5.tar.xz) = 86240
diff --git a/sysutils/plasma5-ksystemstats/pkg-descr b/sysutils/plasma5-ksystemstats/pkg-descr
new file mode 100644
index 000000000000..117e4be382a3
--- /dev/null
+++ b/sysutils/plasma5-ksystemstats/pkg-descr
@@ -0,0 +1,7 @@
+KSystemStats is a daemon that collects statistics about the running system.
+
+On FreeBSD, KSystemStats implements low-overhead sysctl-based
+monitoring for KDE Plasma applications that report on system resource
+usage (e.g. ksysguard and system-monitor and widgets).
+
+WWW: https://invent.kde.org/plasma/ksystemstats
diff --git a/sysutils/plasma5-ksystemstats/pkg-plist b/sysutils/plasma5-ksystemstats/pkg-plist
new file mode 100644
index 000000000000..00b59216ef1c
--- /dev/null
+++ b/sysutils/plasma5-ksystemstats/pkg-plist
@@ -0,0 +1,39 @@
+bin/kstatsviewer
+bin/ksystemstats
+%%QT_PLUGINDIR%%/ksystemstats/ksystemstats_plugin_cpu.so
+%%QT_PLUGINDIR%%/ksystemstats/ksystemstats_plugin_disk.so
+%%QT_PLUGINDIR%%/ksystemstats/ksystemstats_plugin_gpu.so
+%%QT_PLUGINDIR%%/ksystemstats/ksystemstats_plugin_memory.so
+%%QT_PLUGINDIR%%/ksystemstats/ksystemstats_plugin_network.so
+%%QT_PLUGINDIR%%/ksystemstats/ksystemstats_plugin_osinfo.so
+%%QT_PLUGINDIR%%/ksystemstats/ksystemstats_plugin_power.so
+lib/systemd/user/plasma-ksystemstats.service
+share/dbus-1/services/org.kde.ksystemstats.service
+share/locale/az/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/ca/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/ca@valencia/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/cs/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/de/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/en_GB/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/es/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/et/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/eu/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/fi/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/fr/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/ia/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/id/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/it/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/ko/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/nl/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/nn/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/pa/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/pl/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/pt/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/pt_BR/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/ro/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/sk/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/sl/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/sv/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/uk/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/vi/LC_MESSAGES/ksystemstats_plugins.mo
+share/locale/zh_CN/LC_MESSAGES/ksystemstats_plugins.mo
diff --git a/sysutils/plasma5-plasma-systemmonitor/Makefile b/sysutils/plasma5-plasma-systemmonitor/Makefile
index b00915b3368f..f1650a564fc1 100644
--- a/sysutils/plasma5-plasma-systemmonitor/Makefile
+++ b/sysutils/plasma5-plasma-systemmonitor/Makefile
@@ -1,5 +1,6 @@
PORTNAME= plasma-systemmonitor
DISTVERSION= ${KDE_PLASMA_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
@@ -8,7 +9,8 @@ COMMENT= Plasma5 system monitor
USES= cmake compiler:c++11-lib desktop-file-utils gettext kde:5 \
localbase pathfix qt:5 tar:xz
USE_KDE= attica auth codecs config configwidgets coreaddons dbusaddons \
- ecm globalaccel i18n itemmodels kdeclarative kio libksysguard \
+ ecm globalaccel i18n itemmodels kdeclarative kio \
+ ksystemstats libksysguard \
newstuff package service widgetsaddons windowsystem xmlgui
USE_QT= concurrent core dbus declarative gui network quickcontrols2 \
widgets xml \