aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-03-16 09:22:34 +0000
committerRene Ladan <rene@FreeBSD.org>2022-03-16 09:22:34 +0000
commit26b2984ebe7ae384565c6ae763c5db5679111646 (patch)
treeb13bf9dd39ecd101ae060a9d313df5ccfb1ec4a6
parentb8d8c841d513e1235ac12c930681fcb1d49356b1 (diff)
downloadports-26b2984ebe7ae384565c6ae763c5db5679111646.tar.gz
ports-26b2984ebe7ae384565c6ae763c5db5679111646.zip
www/chromium: update to 98.0.4844.74 and fix manpage
PR: 258599 Reported by: pkubaj
-rw-r--r--www/chromium/Makefile5
-rw-r--r--www/chromium/distinfo10
-rw-r--r--www/chromium/files/patch-base_system_sys__info.h6
-rw-r--r--www/chromium/files/patch-base_system_sys__info__posix.cc4
-rw-r--r--www/chromium/files/patch-build_toolchain_gcc__toolchain.gni7
-rw-r--r--www/chromium/files/patch-chrome_browser_ui_webui_ntp_app__launcher__handler.cc8
-rw-r--r--www/chromium/files/patch-components_viz_service_frame__sinks_root__compositor__frame__sink__impl.cc4
-rw-r--r--www/chromium/files/patch-media_base_video__frame.h8
-rw-r--r--www/chromium/files/patch-media_gpu_buffer__validation.cc10
-rw-r--r--www/chromium/files/patch-net_BUILD.gn18
-rw-r--r--www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.asm6
-rw-r--r--www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.h6
12 files changed, 47 insertions, 45 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index eb7eaa265e2a..246377cf90a7 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,8 +1,7 @@
# Created by: Florent Thoumie <flz@FreeBSD.org>
PORTNAME= chromium
-PORTVERSION= 99.0.4844.51
-PORTREVISION= 3
+PORTVERSION= 99.0.4844.74
CATEGORIES= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:fonts
@@ -275,6 +274,8 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_MAN} ${WRKSRC}/chrome/app/resources/manpage.1.in \
${STAGEDIR}${MANPREFIX}/man/man1/chrome.1
+ @${SED} -ie 's,\@\@PACKAGE\@\@,chromium,g;s,\@\@MENUNAME\@\@,Chromium Web Browser,g' \
+ ${STAGEDIR}${MANPREFIX}/man/man1/chrome.1
${CP} ${WRKSRC}/chrome/app/theme/chromium/product_logo_22_mono.png ${WRKSRC}/chrome/app/theme/chromium/product_logo_22.png
.for s in 22 24 48 64 128 256
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}x${s}/apps
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index 7139f2f3df3c..10d39f810fad 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1646114129
-SHA256 (chromium-99.0.4844.51.tar.xz) = 97c52e57eca0dc8b752d274047f38c88aaa86036c0587b26b056efbd3fb2bae3
-SIZE (chromium-99.0.4844.51.tar.xz) = 1316125164
-SHA256 (chromium-99.0.4844.51-testdata.tar.xz) = 80e07d1684b07d0390fbb53115ba6a48e39781f2f805d4e17dac657a00a4363e
-SIZE (chromium-99.0.4844.51-testdata.tar.xz) = 258957904
+TIMESTAMP = 1647412274
+SHA256 (chromium-99.0.4844.74.tar.xz) = 2d5f464730fde0260d1b00db1b38210344952ec91a5b3c544c99c43e76ffbb98
+SIZE (chromium-99.0.4844.74.tar.xz) = 1316293332
+SHA256 (chromium-99.0.4844.74-testdata.tar.xz) = 9b3de3c3f2decc2481aa11dace73dcea150b84d0b69b095117f6caeac0c0ceb6
+SIZE (chromium-99.0.4844.74-testdata.tar.xz) = 258879148
SHA256 (test_fonts-cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb.tar.gz) = ec973eccd669d417fbf2d0a4dac730744a3174268ff062db5451b55c82bc3492
SIZE (test_fonts-cd96fc55dc243f6c6f4cb63ad117cad6cd48dceb.tar.gz) = 26759650
diff --git a/www/chromium/files/patch-base_system_sys__info.h b/www/chromium/files/patch-base_system_sys__info.h
index 0b5c5c8cefa4..4194bbc4732d 100644
--- a/www/chromium/files/patch-base_system_sys__info.h
+++ b/www/chromium/files/patch-base_system_sys__info.h
@@ -1,6 +1,6 @@
---- base/system/sys_info.h.orig 2022-02-28 16:54:41 UTC
+--- base/system/sys_info.h.orig 2022-03-16 08:38:25 UTC
+++ base/system/sys_info.h
-@@ -236,6 +236,8 @@ class BASE_EXPORT SysInfo {
+@@ -212,6 +212,8 @@ class BASE_EXPORT SysInfo {
// On Desktop this returns true when memory <= 2GB.
static bool IsLowEndDevice();
@@ -9,7 +9,7 @@
private:
FRIEND_TEST_ALL_PREFIXES(SysInfoTest, AmountOfAvailablePhysicalMemory);
FRIEND_TEST_ALL_PREFIXES(debug::SystemMetricsTest, ParseMeminfo);
-@@ -246,7 +248,7 @@ class BASE_EXPORT SysInfo {
+@@ -222,7 +224,7 @@ class BASE_EXPORT SysInfo {
static HardwareInfo GetHardwareInfoSync();
#if BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_CHROMEOS) || BUILDFLAG(IS_ANDROID) || \
diff --git a/www/chromium/files/patch-base_system_sys__info__posix.cc b/www/chromium/files/patch-base_system_sys__info__posix.cc
index 107e2da853a5..28bbf3b3559f 100644
--- a/www/chromium/files/patch-base_system_sys__info__posix.cc
+++ b/www/chromium/files/patch-base_system_sys__info__posix.cc
@@ -1,6 +1,6 @@
---- base/system/sys_info_posix.cc.orig 2022-02-07 13:39:41 UTC
+--- base/system/sys_info_posix.cc.orig 2022-03-16 08:38:25 UTC
+++ base/system/sys_info_posix.cc
-@@ -252,6 +252,8 @@ std::string SysInfo::OperatingSystemArchitecture() {
+@@ -239,6 +239,8 @@ std::string SysInfo::OperatingSystemArchitecture() {
arch = "x86";
} else if (arch == "amd64") {
arch = "x86_64";
diff --git a/www/chromium/files/patch-build_toolchain_gcc__toolchain.gni b/www/chromium/files/patch-build_toolchain_gcc__toolchain.gni
index fbdf61db220d..e941d6a67687 100644
--- a/www/chromium/files/patch-build_toolchain_gcc__toolchain.gni
+++ b/www/chromium/files/patch-build_toolchain_gcc__toolchain.gni
@@ -1,10 +1,11 @@
---- build/toolchain/gcc_toolchain.gni.orig 2022-03-06 09:37:52 UTC
+--- build/toolchain/gcc_toolchain.gni.orig 2022-03-16 08:38:25 UTC
+++ build/toolchain/gcc_toolchain.gni
-@@ -53,6 +53,12 @@ if (enable_resource_allowlist_generation) {
+@@ -53,6 +53,13 @@ if (enable_resource_allowlist_generation) {
"enable_resource_allowlist_generation=true does not work for target_os=$target_os")
}
+declare_args() {
++ extra_cflags = ""
+ extra_cppflags = ""
+ extra_cxxflags = ""
+ extra_ldflags = ""
@@ -13,7 +14,7 @@
# This template defines a toolchain for something that works like gcc
# (including clang).
#
-@@ -747,13 +753,12 @@ template("gcc_toolchain") {
+@@ -747,13 +754,12 @@ template("gcc_toolchain") {
# use_gold too.
template("clang_toolchain") {
gcc_toolchain(target_name) {
diff --git a/www/chromium/files/patch-chrome_browser_ui_webui_ntp_app__launcher__handler.cc b/www/chromium/files/patch-chrome_browser_ui_webui_ntp_app__launcher__handler.cc
index 7b809aede864..1c770743ed20 100644
--- a/www/chromium/files/patch-chrome_browser_ui_webui_ntp_app__launcher__handler.cc
+++ b/www/chromium/files/patch-chrome_browser_ui_webui_ntp_app__launcher__handler.cc
@@ -1,6 +1,6 @@
---- chrome/browser/ui/webui/ntp/app_launcher_handler.cc.orig 2022-02-28 16:54:41 UTC
+--- chrome/browser/ui/webui/ntp/app_launcher_handler.cc.orig 2022-03-16 08:38:25 UTC
+++ chrome/browser/ui/webui/ntp/app_launcher_handler.cc
-@@ -306,7 +306,7 @@ void AppLauncherHandler::CreateExtensionInfo(const Ext
+@@ -310,7 +310,7 @@ void AppLauncherHandler::CreateExtensionInfo(const Ext
base::CommandLine::ForCurrentProcess()->HasSwitch(switches::kKioskMode));
bool is_deprecated_app = false;
@@ -9,7 +9,7 @@
is_deprecated_app = extensions::IsExtensionUnsupportedDeprecatedApp(
extension_service_->GetBrowserContext(), extension->id());
#endif
-@@ -735,7 +735,7 @@ void AppLauncherHandler::HandleLaunchApp(const base::L
+@@ -739,7 +739,7 @@ void AppLauncherHandler::HandleLaunchApp(const base::L
Profile* profile = extension_service_->profile();
@@ -18,7 +18,7 @@
if (extensions::IsExtensionUnsupportedDeprecatedApp(profile, extension_id)) {
// TODO(crbug.com/1225779): Show the deprecated apps dialog.
return;
-@@ -1328,7 +1328,7 @@ void AppLauncherHandler::InstallOsHooks(const web_app:
+@@ -1332,7 +1332,7 @@ void AppLauncherHandler::InstallOsHooks(const web_app:
options.os_hooks[web_app::OsHookType::kUninstallationViaOsSettings] =
web_app->CanUserUninstallWebApp();
diff --git a/www/chromium/files/patch-components_viz_service_frame__sinks_root__compositor__frame__sink__impl.cc b/www/chromium/files/patch-components_viz_service_frame__sinks_root__compositor__frame__sink__impl.cc
index dc1ff46a2f47..766f57bd5ff3 100644
--- a/www/chromium/files/patch-components_viz_service_frame__sinks_root__compositor__frame__sink__impl.cc
+++ b/www/chromium/files/patch-components_viz_service_frame__sinks_root__compositor__frame__sink__impl.cc
@@ -1,4 +1,4 @@
---- components/viz/service/frame_sinks/root_compositor_frame_sink_impl.cc.orig 2022-02-28 16:54:41 UTC
+--- components/viz/service/frame_sinks/root_compositor_frame_sink_impl.cc.orig 2022-03-16 08:38:25 UTC
+++ components/viz/service/frame_sinks/root_compositor_frame_sink_impl.cc
@@ -61,7 +61,7 @@ RootCompositorFrameSinkImpl::Create(
@@ -9,7 +9,7 @@
// For X11, we need notify client about swap completion after resizing, so the
// client can use it for synchronize with X11 WM.
output_surface->SetNeedsSwapSizeNotifications(true);
-@@ -529,7 +529,7 @@ void RootCompositorFrameSinkImpl::DisplayDidCompleteSw
+@@ -526,7 +526,7 @@ void RootCompositorFrameSinkImpl::DisplayDidCompleteSw
display_client_->DidCompleteSwapWithSize(pixel_size);
// TODO(crbug.com/1052397): Revisit the macro expression once build flag switch
// of lacros-chrome is complete.
diff --git a/www/chromium/files/patch-media_base_video__frame.h b/www/chromium/files/patch-media_base_video__frame.h
index 7fa2e02afc05..08554c4f9a3a 100644
--- a/www/chromium/files/patch-media_base_video__frame.h
+++ b/www/chromium/files/patch-media_base_video__frame.h
@@ -1,4 +1,4 @@
---- media/base/video_frame.h.orig 2022-02-28 16:54:41 UTC
+--- media/base/video_frame.h.orig 2022-03-16 08:38:25 UTC
+++ media/base/video_frame.h
@@ -40,7 +40,7 @@
#include "base/mac/scoped_cftyperef.h"
@@ -18,7 +18,7 @@
// TODO(mcasas): Consider turning this type into STORAGE_NATIVE
// based on the idea of using this same enum value for both DMA
// buffers on Linux and CVPixelBuffers on Mac (which currently use
-@@ -276,7 +276,7 @@ class MEDIA_EXPORT VideoFrame : public base::RefCounte
+@@ -280,7 +280,7 @@ class MEDIA_EXPORT VideoFrame : public base::RefCounte
ReleaseMailboxAndGpuMemoryBufferCB mailbox_holder_and_gmb_release_cb,
base::TimeDelta timestamp);
@@ -27,7 +27,7 @@
// Wraps provided dmabufs
// (https://www.kernel.org/doc/html/latest/driver-api/dma-buf.html) with a
// VideoFrame. The frame will take ownership of |dmabuf_fds|, and will
-@@ -535,7 +535,7 @@ class MEDIA_EXPORT VideoFrame : public base::RefCounte
+@@ -539,7 +539,7 @@ class MEDIA_EXPORT VideoFrame : public base::RefCounte
// mailbox, the caller must wait for the included sync point.
const gpu::MailboxHolder& mailbox_holder(size_t texture_index) const;
@@ -36,7 +36,7 @@
// Returns a vector containing the backing DmaBufs for this frame. The number
// of returned DmaBufs will be equal or less than the number of planes of
// the frame. If there are less, this means that the last FD contains the
-@@ -742,7 +742,7 @@ class MEDIA_EXPORT VideoFrame : public base::RefCounte
+@@ -746,7 +746,7 @@ class MEDIA_EXPORT VideoFrame : public base::RefCounte
// GPU memory buffer, if this frame is STORAGE_GPU_MEMORY_BUFFER.
std::unique_ptr<gfx::GpuMemoryBuffer> gpu_memory_buffer_;
diff --git a/www/chromium/files/patch-media_gpu_buffer__validation.cc b/www/chromium/files/patch-media_gpu_buffer__validation.cc
index 13de2a41760f..d403f80d8f94 100644
--- a/www/chromium/files/patch-media_gpu_buffer__validation.cc
+++ b/www/chromium/files/patch-media_gpu_buffer__validation.cc
@@ -1,6 +1,6 @@
---- media/gpu/buffer_validation.cc.orig 2022-02-28 16:54:41 UTC
+--- media/gpu/buffer_validation.cc.orig 2022-03-16 08:38:25 UTC
+++ media/gpu/buffer_validation.cc
-@@ -12,7 +12,7 @@
+@@ -15,7 +15,7 @@
#include "ui/gfx/geometry/size.h"
#include "ui/gfx/gpu_memory_buffer.h"
@@ -9,7 +9,7 @@
#include <sys/types.h>
#include <unistd.h>
#endif // BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_CHROMEOS)
-@@ -20,7 +20,7 @@
+@@ -23,7 +23,7 @@
namespace media {
bool GetFileSize(const int fd, size_t* size) {
@@ -18,8 +18,8 @@
if (fd < 0) {
VLOGF(1) << "Invalid file descriptor";
return false;
-@@ -56,7 +56,7 @@ bool VerifyGpuMemoryBufferHandle(media::VideoPixelForm
- VLOGF(1) << "Unexpected GpuMemoryBufferType: " << gmb_handle.type;
+@@ -66,7 +66,7 @@ bool VerifyGpuMemoryBufferHandle(
+ << coded_size.ToString();
return false;
}
-#if BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_CHROMEOS)
diff --git a/www/chromium/files/patch-net_BUILD.gn b/www/chromium/files/patch-net_BUILD.gn
index 900b952800d5..b3348e6ae0ec 100644
--- a/www/chromium/files/patch-net_BUILD.gn
+++ b/www/chromium/files/patch-net_BUILD.gn
@@ -1,4 +1,4 @@
---- net/BUILD.gn.orig 2022-03-01 11:59:41 UTC
+--- net/BUILD.gn.orig 2022-03-16 08:38:25 UTC
+++ net/BUILD.gn
@@ -100,7 +100,7 @@ net_configs = [
"//build/config/compiler:wexit_time_destructors",
@@ -43,7 +43,7 @@
sources += [
"base/network_interfaces_getifaddrs.cc",
"base/network_interfaces_getifaddrs.h",
-@@ -2445,7 +2454,7 @@ if (is_linux || is_chromeos || is_mac) {
+@@ -2451,7 +2460,7 @@ if (is_linux || is_chromeos || is_mac) {
}
}
@@ -52,7 +52,7 @@
static_library("epoll_server") {
sources = [
"tools/epoll_server/platform/impl/epoll_bug_impl.h",
-@@ -4439,7 +4448,7 @@ test("net_unittests") {
+@@ -4445,7 +4454,7 @@ test("net_unittests") {
]
}
@@ -61,7 +61,7 @@
sources += [
"base/address_tracker_linux_unittest.cc",
"base/network_interfaces_linux_unittest.cc",
-@@ -4513,6 +4522,10 @@ test("net_unittests") {
+@@ -4519,6 +4528,10 @@ test("net_unittests") {
"//url:buildflags",
]
@@ -72,7 +72,7 @@
allow_circular_includes_from = [ "//net/third_party/quiche:quiche_tests" ]
if (enable_websockets) {
-@@ -4560,7 +4573,7 @@ test("net_unittests") {
+@@ -4566,7 +4579,7 @@ test("net_unittests") {
]
}
@@ -81,12 +81,12 @@
sources += [
"quic/platform/impl/quic_epoll_clock_test.cc",
"quic/platform/impl/quic_flags_test.cc",
-@@ -4706,7 +4719,7 @@ test("net_unittests") {
+@@ -4712,7 +4725,7 @@ test("net_unittests") {
}
- # Use getifaddrs() on POSIX platforms, except Linux and Android.
-- if (is_posix && !is_linux && !is_chromeos && !is_android) {
-+ if (is_posix && !is_linux && !is_chromeos && !is_android && !is_bsd) {
+ # Use getifaddrs() on POSIX platforms, except Linux.
+- if (is_posix && !is_linux && !is_chromeos) {
++ if (is_posix && !is_linux && !is_chromeos && !is_bsd) {
sources += [ "base/network_interfaces_getifaddrs_unittest.cc" ]
}
diff --git a/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.asm b/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.asm
index f644cda18bde..be395c6aa64f 100644
--- a/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.asm
+++ b/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.asm
@@ -1,4 +1,4 @@
---- third_party/ffmpeg/chromium/config/Chrome/openbsd/ia32/config.asm.orig 2022-02-28 16:54:41 UTC
+--- third_party/ffmpeg/chromium/config/Chrome/openbsd/ia32/config.asm.orig 2022-03-16 08:38:25 UTC
+++ third_party/ffmpeg/chromium/config/Chrome/openbsd/ia32/config.asm
@@ -0,0 +1,2727 @@
+; Automatically generated by configure - do not modify!
@@ -593,7 +593,7 @@
+%define CONFIG_THUMB 0
+%define CONFIG_VALGRIND_BACKTRACE 0
+%define CONFIG_XMM_CLOBBER_TEST 0
-+%define CONFIG_BSFS 1
++%define CONFIG_BSFS 0
+%define CONFIG_DECODERS 1
+%define CONFIG_ENCODERS 0
+%define CONFIG_HWACCELS 0
@@ -719,7 +719,7 @@
+%define CONFIG_MPEG4_UNPACK_BFRAMES_BSF 0
+%define CONFIG_MOV2TEXTSUB_BSF 0
+%define CONFIG_NOISE_BSF 0
-+%define CONFIG_NULL_BSF 1
++%define CONFIG_NULL_BSF 0
+%define CONFIG_OPUS_METADATA_BSF 0
+%define CONFIG_PCM_RECHUNK_BSF 0
+%define CONFIG_PRORES_METADATA_BSF 0
diff --git a/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.h b/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.h
index 65302b7298dd..a043c0432494 100644
--- a/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.h
+++ b/www/chromium/files/patch-third__party_ffmpeg_chromium_config_Chrome_openbsd_ia32_config.h
@@ -1,4 +1,4 @@
---- third_party/ffmpeg/chromium/config/Chrome/openbsd/ia32/config.h.orig 2022-02-28 16:54:41 UTC
+--- third_party/ffmpeg/chromium/config/Chrome/openbsd/ia32/config.h.orig 2022-03-16 08:38:25 UTC
+++ third_party/ffmpeg/chromium/config/Chrome/openbsd/ia32/config.h
@@ -0,0 +1,2744 @@
+/* Automatically generated by configure - do not modify! */
@@ -609,7 +609,7 @@
+#define CONFIG_THUMB 0
+#define CONFIG_VALGRIND_BACKTRACE 0
+#define CONFIG_XMM_CLOBBER_TEST 0
-+#define CONFIG_BSFS 1
++#define CONFIG_BSFS 0
+#define CONFIG_DECODERS 1
+#define CONFIG_ENCODERS 0
+#define CONFIG_HWACCELS 0
@@ -735,7 +735,7 @@
+#define CONFIG_MPEG4_UNPACK_BFRAMES_BSF 0
+#define CONFIG_MOV2TEXTSUB_BSF 0
+#define CONFIG_NOISE_BSF 0
-+#define CONFIG_NULL_BSF 1
++#define CONFIG_NULL_BSF 0
+#define CONFIG_OPUS_METADATA_BSF 0
+#define CONFIG_PCM_RECHUNK_BSF 0
+#define CONFIG_PRORES_METADATA_BSF 0