aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2024-11-09 13:10:26 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2024-11-09 13:10:26 +0000
commit26f212b0b220f96a2da7e5f3e2d32cb0c7ddbe9f (patch)
treecc0e619db3f1841e07586806f14ca8d1cdffee0d
parentb1c688a8406f34e49d3ee52765cd954e404f9396 (diff)
games/glob2: fix build with boost-1.85
(cherry picked from commit e0a38371e522dbed3341bf8ff8732ae416c80b26)
-rw-r--r--games/glob2/Makefile4
-rw-r--r--games/glob2/files/patch-libusl_src_native.h11
2 files changed, 12 insertions, 3 deletions
diff --git a/games/glob2/Makefile b/games/glob2/Makefile
index d04d8d5071b3..840ef78acd48 100644
--- a/games/glob2/Makefile
+++ b/games/glob2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= glob2
PORTVERSION= 0.9.5.0.g20240607
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MAINTAINER= makc@FreeBSD.org
@@ -10,8 +10,6 @@ WWW= https://globulation2.org/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build with boost-1.85
-
LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libportaudio.so:audio/portaudio \
libspeex.so:audio/speex \
diff --git a/games/glob2/files/patch-libusl_src_native.h b/games/glob2/files/patch-libusl_src_native.h
new file mode 100644
index 000000000000..af83767f6a65
--- /dev/null
+++ b/games/glob2/files/patch-libusl_src_native.h
@@ -0,0 +1,11 @@
+--- libusl/src/native.h.orig 2024-06-07 07:47:17 UTC
++++ libusl/src/native.h
+@@ -42,7 +42,7 @@ struct NativeValuePrototype: Prototype (private)
+ template<typename Function>
+ void addMethod(const std::string& name, const boost::function<Function>& function)
+ {
+- BOOST_MPL_ASSERT(( boost::is_same<This, typename boost::function<Function>::arg1_type> ));
++ BOOST_MPL_ASSERT(( boost::is_same<This, typename boost::function_traits<Function>::arg1_type> ));
+ NativeCode* native = new NativeFunction<Function>(name, function, true);
+ Prototype::addMethod(native);
+ }