aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 11:37:20 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-20 11:37:20 +0000
commit2701aa70f6254324ad8a0db29cc84f0f668418cd (patch)
tree6678d0b0288476d2253fd0af9424e8f70ac792a1
parentb43e6aaeee18e3c747fe8beb080a4d600072e706 (diff)
downloadports-2701aa70f6254324ad8a0db29cc84f0f668418cd.tar.gz
ports-2701aa70f6254324ad8a0db29cc84f0f668418cd.zip
devel/py-black: Add UVLOOP option
-rw-r--r--devel/py-black/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/py-black/Makefile b/devel/py-black/Makefile
index 5659cd1083bf..2c2728af0e3f 100644
--- a/devel/py-black/Makefile
+++ b/devel/py-black/Makefile
@@ -23,14 +23,16 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= COLORAMA D
+OPTIONS_DEFINE= COLORAMA D UVLOOP
OPTIONS_DEFAULT=COLORAMA
COLORAMA_DESC= Color support
D_DESC= Blackd HTTP server
+UVLOOP_DESC= Event loop support
COLORAMA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>=0.4.3:devel/py-colorama@${PY_FLAVOR}
D_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.6.0:www/py-aiohttp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}aiohttp_cors>=0.4.0:www/py-aiohttp_cors@${PY_FLAVOR}
+UVLOOP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}uvloop>=0.15.2:devel/py-uvloop@${PY_FLAVOR}
.include <bsd.port.pre.mk>