aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNamkhai B <me@forkbomb9.ch>2022-08-15 23:30:39 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-08-15 23:56:12 +0000
commit2716a56c993d2c31443eaeb878759c830de9df7f (patch)
tree4bcdf907fda06148dd546270909ec5a9e45c125d
parentee99418086d76768347fa8699fd32792b9fccb93 (diff)
net-mgmt/netdata: Fix DBENGINE=on & LTO=on builds
netdata's vendored judy uses the wrong version of ar when built with LTO
-rw-r--r--net-mgmt/netdata/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/netdata/Makefile b/net-mgmt/netdata/Makefile
index 6351d22f6707..dc7e966b7655 100644
--- a/net-mgmt/netdata/Makefile
+++ b/net-mgmt/netdata/Makefile
@@ -1,6 +1,7 @@
PORTNAME= netdata
DISTVERSIONPREFIX= v
DISTVERSION= 1.36.1
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/ \
https://github.com/forkbomb9/netdata/commit/:dashboard
@@ -28,6 +29,7 @@ USES= autoreconf cpe gmake pathfix pkgconfig:both python shebangfix \
ssl
USE_RC_SUBR= ${PORTNAME}
SHEBANG_GLOB= *
+BINARY_ALIAS= ar=llvm-ar ranlib=llvm-ranlib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-unit-tests
@@ -64,14 +66,12 @@ CLOUD_CONFIGURE_ON= --with-aclk-ng
CLOUD_CONFIGURE_OFF= --disable-cloud
CUPS_LIB_DEPENDS= libcups.so:print/cups
CUPS_CONFIGURE_ENABLE= plugin-cups
-DBENGINE_LIB_DEPENDS= libJudy.so:devel/judy \
- liblz4.so:archivers/liblz4
+DBENGINE_LIB_DEPENDS= liblz4.so:archivers/liblz4
DBENGINE_CONFIGURE_ENABLE= dbengine
FREEIPMI_LIB_DEPENDS= libfreeipmi.so:sysutils/freeipmi
FREEIPMI_CONFIGURE_ENABLE= plugin-freeipmi
GOPLUGIN_RUN_DEPENDS= ${LOCALBASE}/libexec/netdata/plugins.d/god.plugin:net-mgmt/netdata-go
LTO_USES= compiler:c11
-LTO_LIB_DEPENDS= libJudy.so:devel/judy
LTO_CONFIGURE_ENABLE= lto
.include <bsd.port.options.mk>