aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:41:30 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-09-04 03:42:05 +0000
commit273105d9aa568af8aa1cc8c139f71091a9909635 (patch)
tree499c178fe59f16d28251f9a5d08242fb9206e92c
parentea1db46ea2da642f9bbf5794c689ea0d92870940 (diff)
downloadports-273105d9aa568af8aa1cc8c139f71091a9909635.tar.gz
ports-273105d9aa568af8aa1cc8c139f71091a9909635.zip
devel/py-openapi-spec-validator04: Add py-openapi-spec-validator04 0.4.0 (copied from py-openapi-spec-validator)
- Add PORTSCOUT
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-openapi-spec-validator04/Makefile30
-rw-r--r--devel/py-openapi-spec-validator04/distinfo3
-rw-r--r--devel/py-openapi-spec-validator04/pkg-descr5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d0d1ca095ca7..f609da5ecadb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4851,6 +4851,7 @@
SUBDIR += py-openapi-schema-validator
SUBDIR += py-openapi-schema-validator02
SUBDIR += py-openapi-spec-validator
+ SUBDIR += py-openapi-spec-validator04
SUBDIR += py-opencensus
SUBDIR += py-opencensus-context
SUBDIR += py-opendht
diff --git a/devel/py-openapi-spec-validator04/Makefile b/devel/py-openapi-spec-validator04/Makefile
new file mode 100644
index 000000000000..59e4b6bccb59
--- /dev/null
+++ b/devel/py-openapi-spec-validator04/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= openapi-spec-validator
+PORTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 04
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Validator for OpenAPI 2.0 and 3.0.0 specification
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.0.0<5.0.0:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openapi-schema-validator02>=0.2.0<0.3.0:devel/py-openapi-schema-validator02@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=5.1:devel/py-yaml@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-flake8>=0:devel/py-pytest-flake8@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tox>=0:devel/py-tox@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^0\.4\.
+
+.include <bsd.port.mk>
diff --git a/devel/py-openapi-spec-validator04/distinfo b/devel/py-openapi-spec-validator04/distinfo
new file mode 100644
index 000000000000..62563bce6099
--- /dev/null
+++ b/devel/py-openapi-spec-validator04/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643971074
+SHA256 (openapi-spec-validator-0.4.0.tar.gz) = 97f258850afc97b048f7c2653855e0f88fa66ac103c2be5077c7960aca2ad49a
+SIZE (openapi-spec-validator-0.4.0.tar.gz) = 26679
diff --git a/devel/py-openapi-spec-validator04/pkg-descr b/devel/py-openapi-spec-validator04/pkg-descr
new file mode 100644
index 000000000000..dbb8df6b5175
--- /dev/null
+++ b/devel/py-openapi-spec-validator04/pkg-descr
@@ -0,0 +1,5 @@
+OpenAPI Spec Validator is a Python library that validates OpenAPI Specs against
+the OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0.0 specification. The validator
+aims to check for full compliance with the Specification.
+
+WWW: https://github.com/p1c2u/openapi-spec-validator