aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2023-03-18 20:37:43 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2023-03-18 20:37:43 +0000
commit27a07f6066d18368f0b7216f7f4e1c7beeeac2a4 (patch)
tree572daee3c5d69267fff01c984ffc7e21ac4f2bf1
parentf53e3975bd470d74936a26139521d5d1c2196314 (diff)
downloadports-27a07f6066d18368f0b7216f7f4e1c7beeeac2a4.tar.gz
ports-27a07f6066d18368f0b7216f7f4e1c7beeeac2a4.zip
graphics/gnash: add camera support
fix build on FreeBSD-14
-rw-r--r--graphics/gnash/Makefile6
-rw-r--r--graphics/gnash/files/patch-configure.ac9
2 files changed, 13 insertions, 2 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index bf6f418c0d3c..a13a1d1b7412 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -1,6 +1,6 @@
PORTNAME= gnash
PORTVERSION= 0.8.10
-PORTREVISION= 54
+PORTREVISION= 55
CATEGORIES= graphics
MASTER_SITES= http://git.savannah.gnu.org/cgit/gnash.git/snapshot/
DISTNAME= gnash-2b3bdede0305c4fc3ad21a0a4197330606c9b880
@@ -26,12 +26,14 @@ LIB_DEPENDS= libltdl.so:devel/libltdl \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
libdca.so:multimedia/libdca \
- libgsm.so:audio/gsm
+ libgsm.so:audio/gsm \
+ libdc1394.so:multimedia/libdc1394
CONFLICTS= gnash-devel
USES= cpe tar:bzip2 compiler:c++11-lang autoreconf gmake libtool \
pkgconfig jpeg gnome gl sdl desktop-file-utils xorg
+USE_CSTD= gnu89
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
USE_GNOME= atk gdkpixbuf2 gtk20 libxml2 pango
diff --git a/graphics/gnash/files/patch-configure.ac b/graphics/gnash/files/patch-configure.ac
index e07ab86b66e9..c9881689de80 100644
--- a/graphics/gnash/files/patch-configure.ac
+++ b/graphics/gnash/files/patch-configure.ac
@@ -1,5 +1,14 @@
--- configure.ac.orig 2016-07-21 12:25:09 UTC
+++ configure.ac
+@@ -1201,7 +1201,7 @@ if test x"${build_egl_device}" = xyes; then
+ build_egl_device=no
+ fi
+ save_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS -Wall -Werror"
++ CFLAGS="$CFLAGS -Wall -Werror -Wno-unused-but-set-variable "
+ native_window_type=none
+ AC_MSG_CHECKING([For EGLNativeWindowType type])
+ AC_TRY_COMPILE([#include <EGL/eglplatform.h>], [
@@ -4144,7 +4144,7 @@ if test x${build_ssl} = xyes; then
fi
echo " SSL libs are: $SSL_LIBS"