aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-09-21 07:31:51 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-09-21 07:38:37 +0000
commit28149de0a616dd364bce3485aafb31dcfba27946 (patch)
treee1b7cd1a60f04db62a855720b61b7bd0ff51db2d
parent186080b50f06b2dbb652b0fc5f3686b40924b809 (diff)
devel/cmake-core devel/cmake-gui misc/mbuffer: cope with librhash.so bump
Because rhash 1.4.4 updated the librhash.so symlink from .0 to .1, build-time dependents such as cmake-core and cmake-gui need their PORTREVISION bumped. The other case is misc/mbuffer, which uses librhash only at runtime, but hardcodes dlopen("librhash.so.0", RTLD_NOW). I changed this to just "librhash.so", and it seems to work fine with light testing. PR: 273775 Reported by: Tomoaki AOKI <junchoon@dec.sakura.ne.jp> Fixes: e0acbd158ec9 security/rhash: update to 1.4.4 and fix build with lld 17 MFH: 2023Q3
-rw-r--r--devel/cmake-core/Makefile2
-rw-r--r--devel/cmake-gui/Makefile1
-rw-r--r--misc/mbuffer/Makefile1
-rw-r--r--misc/mbuffer/files/patch-hashing.c11
4 files changed, 14 insertions, 1 deletions
diff --git a/devel/cmake-core/Makefile b/devel/cmake-core/Makefile
index 018e73febdff..0e5f63ee4bdf 100644
--- a/devel/cmake-core/Makefile
+++ b/devel/cmake-core/Makefile
@@ -1,7 +1,7 @@
PORTNAME= cmake
# Remember to update devel/cmake-doc and devel/cmake-gui as well.
DISTVERSION= ${_CMAKE_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
PKGNAMESUFFIX= -core
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 8fc18a76114a..bcce5e488d08 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -1,5 +1,6 @@
PORTNAME= cmake
DISTVERSION= ${_CMAKE_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMESUFFIX= -gui-${FLAVOR}
diff --git a/misc/mbuffer/Makefile b/misc/mbuffer/Makefile
index 1a2d36f72ac3..e2b5e34d140c 100644
--- a/misc/mbuffer/Makefile
+++ b/misc/mbuffer/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mbuffer
PORTVERSION= 20230301
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.maier-komor.de/software/mbuffer/
diff --git a/misc/mbuffer/files/patch-hashing.c b/misc/mbuffer/files/patch-hashing.c
new file mode 100644
index 000000000000..6b75015ccf37
--- /dev/null
+++ b/misc/mbuffer/files/patch-hashing.c
@@ -0,0 +1,11 @@
+--- hashing.c.orig 2023-02-27 19:18:52 UTC
++++ hashing.c
+@@ -102,7 +102,7 @@ static void initHashLibs()
+ LibMhash = 0;
+ }
+ }
+- LibRhash = dlopen("librhash.so.0",RTLD_NOW);
++ LibRhash = dlopen("librhash.so",RTLD_NOW);
+ if (LibRhash) {
+ debugmsg("found librhash\n");
+ void (*rhash_library_init)() = (void (*)(void)) dlsym(LibRhash,"rhash_library_init");