aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-05-22 13:07:21 +0000
committerStefan Eßer <se@FreeBSD.org>2022-05-22 13:07:21 +0000
commit28b107d8779f1c7a8c46f8f6fe0974f8245ee1ea (patch)
tree949c7db17b59b7255a9b0a044e90dc15b8157171
parentd58f6d9926a104178851b1603504be48907a3b38 (diff)
downloadports-28b107d8779f1c7a8c46f8f6fe0974f8245ee1ea.tar.gz
ports-28b107d8779f1c7a8c46f8f6fe0974f8245ee1ea.zip
devel/lua-mode: add new port of LUA mode for emacs
-rw-r--r--devel/Makefile1
-rw-r--r--devel/lua-mode/Makefile26
-rw-r--r--devel/lua-mode/distinfo3
-rw-r--r--devel/lua-mode/pkg-descr12
-rw-r--r--devel/lua-mode/pkg-message11
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a10e40faf070..09445623287e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1531,6 +1531,7 @@
SUBDIR += lua-luacheck
SUBDIR += lua-luarocks
SUBDIR += lua-lunit
+ SUBDIR += lua-mode
SUBDIR += lua-posix
SUBDIR += lua-pty
SUBDIR += lua-rds-parser
diff --git a/devel/lua-mode/Makefile b/devel/lua-mode/Makefile
new file mode 100644
index 000000000000..1b2d55b1d7de
--- /dev/null
+++ b/devel/lua-mode/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= lua-mode
+PORTVERSION= 20210802
+DISTVERSIONPREFIX=v
+CATEGORIES= devel elisp
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= Minor mode for LUA
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= emacs
+
+USE_GITHUB= yes
+GH_ACCOUNT= immerrr
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PLIST_FILES= ${EMACS_SITE_LISPDIR}/lua-mode.el
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lua-mode.el ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}/
+
+.include <bsd.port.mk>
diff --git a/devel/lua-mode/distinfo b/devel/lua-mode/distinfo
new file mode 100644
index 000000000000..c60d319256bd
--- /dev/null
+++ b/devel/lua-mode/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1653067134
+SHA256 (immerrr-lua-mode-v20210802_GH0.tar.gz) = c00bca8a99427ea7696838837b45cf0093066e0c463c0c4048f3e413b2b7e0d9
+SIZE (immerrr-lua-mode-v20210802_GH0.tar.gz) = 53708
diff --git a/devel/lua-mode/pkg-descr b/devel/lua-mode/pkg-descr
new file mode 100644
index 000000000000..ebf2c440349d
--- /dev/null
+++ b/devel/lua-mode/pkg-descr
@@ -0,0 +1,12 @@
+lua-mode is an Emacs major mode for editing Lua files.
+
+Main features:
+- syntactic indentation & highlighting (incl. multiline literals/comments)
+- evaluation of lines/regions/functions/files in Lua subprocess or direct
+ interaction with its REPL
+- documentation lookup (using online/offline reference manual, e.g.
+ string.find
+- imenu integration
+- HideShow integration
+
+WWW: http://github.com/immerrr/lua-mode
diff --git a/devel/lua-mode/pkg-message b/devel/lua-mode/pkg-message
new file mode 100644
index 000000000000..b73eadb4ba1e
--- /dev/null
+++ b/devel/lua-mode/pkg-message
@@ -0,0 +1,11 @@
+[
+{ type: install
+ message: <<EOM
+You should add the following line to your ~/.emacs:
+
+ (autoload 'lua-mode "lua-mode" "Lua editing mode." t)
+ (add-to-list 'auto-mode-alist '("\\.lua$" . lua-mode))
+ (add-to-list 'interpreter-mode-alist '("lua" . lua-mode))
+EOM
+}
+]