aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-30 13:32:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-30 13:36:06 +0000
commit291cc6cb6ae8f2d938cbd132898e07fc28df8756 (patch)
tree09c82b59f7492d8f948550cd1b8f05cf61b6ec57
parent70964cc69016f43315813477f0e47603c7e7b53a (diff)
devel/rubygem-google-protobuf3: Add rubygem-google-protobuf3 3.25.4 (copied from rubygem-google-protobuf)
- Add PORTSCOUT
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-protobuf3/Makefile23
-rw-r--r--devel/rubygem-google-protobuf3/distinfo3
-rw-r--r--devel/rubygem-google-protobuf3/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 454417ae1978..3f4eeffe6793 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -7169,6 +7169,7 @@
SUBDIR += rubygem-google-iam-credentials-v1
SUBDIR += rubygem-google-iam-v1
SUBDIR += rubygem-google-protobuf
+ SUBDIR += rubygem-google-protobuf3
SUBDIR += rubygem-google-protobuf4
SUBDIR += rubygem-googleapis-common-protos
SUBDIR += rubygem-googleapis-common-protos-types
diff --git a/devel/rubygem-google-protobuf3/Makefile b/devel/rubygem-google-protobuf3/Makefile
new file mode 100644
index 000000000000..c89aa8970385
--- /dev/null
+++ b/devel/rubygem-google-protobuf3/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= google-protobuf
+PORTVERSION= 3.25.4
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 3
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby extension to Google Protocol Buffers
+WWW= https://protobuf.dev/ \
+ https://github.com/protocolbuffers/protobuf \
+ https://github.com/protocolbuffers/protobuf/tree/main/ruby
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= rubygem-rake>=0:devel/rubygem-rake
+
+USES= gem shebangfix
+
+PORTSCOUT= limit:^3\.
+
+SHEBANG_GLOB= *.rb
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-protobuf3/distinfo b/devel/rubygem-google-protobuf3/distinfo
new file mode 100644
index 000000000000..a345a3896e99
--- /dev/null
+++ b/devel/rubygem-google-protobuf3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1722249138
+SHA256 (rubygem/google-protobuf-3.25.4.gem) = a1c594ca9d99c894e558f984d70731a8935ec639e75865f0181cab126a0aef0e
+SIZE (rubygem/google-protobuf-3.25.4.gem) = 251904
diff --git a/devel/rubygem-google-protobuf3/pkg-descr b/devel/rubygem-google-protobuf3/pkg-descr
new file mode 100644
index 000000000000..c47ffe5244ab
--- /dev/null
+++ b/devel/rubygem-google-protobuf3/pkg-descr
@@ -0,0 +1,6 @@
+rubygem-google-protobuf is a Ruby extension that implements Protocol Buffers
+functionality. It makes use of generated Ruby code that defines message and enum
+types in a Ruby DSL. You may write definitions in this DSL directly, but we
+recommend using protoc's Ruby generation support with .proto files. The build
+process in this directory only installs the extension; you need to install
+protoc as well to have Ruby code generation functionality.