aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-02 22:39:29 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-02 22:39:29 +0000
commit2b4710473cd02432da6608b02dd667cbaf19cfda (patch)
tree0264a3d0ba6d9cca53a94dc9cf9b551dcb3f832e
parent560c6d1bdf4d7b4eff1bdfed0506443b3444e597 (diff)
downloadports-2b4710473cd02432da6608b02dd667cbaf19cfda.tar.gz
ports-2b4710473cd02432da6608b02dd667cbaf19cfda.zip
security/py-gvm-tools: Update to 23.3.0
-rw-r--r--security/py-gvm-tools/Makefile19
-rw-r--r--security/py-gvm-tools/distinfo6
-rw-r--r--security/py-gvm-tools/files/patch-setup.py11
3 files changed, 20 insertions, 16 deletions
diff --git a/security/py-gvm-tools/Makefile b/security/py-gvm-tools/Makefile
index a3b2ea540bf6..130a77785e6e 100644
--- a/security/py-gvm-tools/Makefile
+++ b/security/py-gvm-tools/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gvm-tools
-DISTVERSION= 22.6.1
+DISTVERSION= 23.3.0
+DISTVERSIONPREFIX= v
CATEGORIES= security python
-MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= acm@FreeBSD.org
@@ -10,11 +10,26 @@ WWW= https://github.com/greenbone/gvm-tools
LICENSE= GPLv3+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry2setup>0:devel/py-poetry2setup@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-gvm>=0:security/py-python-gvm@${PY_FLAVOR}
+USE_GITHUB= yes
+GH_ACCOUNT= greenbone
+GH_PROJECT= ${PORTNAME}
+
USES= python:3.7+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
+post-extract:
+ ${MV} ${WRKSRC}/tests ${WRKSRC}/gvmtools/
+ ${MV} ${WRKSRC}/scripts ${WRKSRC}/gvmtools/
+
+post-patch:
+ ${REINPLACE_CMD} '32,33d' ${WRKSRC}/pyproject.toml
+
+pre-configure:
+ @cd ${WRKSRC} && poetry2setup > ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/security/py-gvm-tools/distinfo b/security/py-gvm-tools/distinfo
index 7a500cb743af..15d9ec771e66 100644
--- a/security/py-gvm-tools/distinfo
+++ b/security/py-gvm-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1659331386
-SHA256 (gvm-tools-22.6.1.tar.gz) = 4a24cffe05f38a3fb22ae27dc5845ab86a39c58a2af6d065ffd8109d0d61ebbe
-SIZE (gvm-tools-22.6.1.tar.gz) = 100454
+TIMESTAMP = 1680420138
+SHA256 (greenbone-gvm-tools-v23.3.0_GH0.tar.gz) = 3633490cb251be83e17e89e14e6996e45a6a17e504b74cdc892a98508a626684
+SIZE (greenbone-gvm-tools-v23.3.0_GH0.tar.gz) = 219338
diff --git a/security/py-gvm-tools/files/patch-setup.py b/security/py-gvm-tools/files/patch-setup.py
deleted file mode 100644
index 645b3e9c6578..000000000000
--- a/security/py-gvm-tools/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2021-01-04 15:47:34.037289000 -0500
-+++ setup.py 2021-01-04 15:47:58.669103000 -0500
-@@ -2,7 +2,7 @@
- from setuptools import setup
-
- packages = \
--['gvmtools', 'scripts', 'tests', 'tests.scripts']
-+['gvmtools', 'scripts']
-
- package_data = \
- {'': ['*']}